Ireboot can't access XP on triple OS boot

#1
I have XP pro, Vista Ultimate and 7 Ultimate on the same hard drive with 3 partitions. All works fine from the bootloader, I see the 3 OS and any I select it works fine. My problem is with ireboot, it will work for 7 and Vista but not for XP, when i try to boot to XP, it will start loading it but then it just dies half the way.

Please help!

Thanks.
 

JustinW

Super Moderator
Staff member
#2
If XP appears to be loading iReboots done its job (pick that entry when the system reboots). If you could describe more than "just dies" we might be able to work out what may be wrong with XP.
 
#3
XP only loads from a clean start up and selecting manually from the OS list. If I select XP from within an OS witn ireboot, when it restarts and tries to load XP, it loads the xp logo and the progress bar and then it shuts down, it doesn't even get to the users welcome screen.

I noticed a something funny, these are the setting Easy BCD shows, but XP is pointing to Vista's partition, instead of its own (E:smile:, maybe that will help:

There are a total of 3 entries listed in the Vista Bootloader.
Bootloader Timeout: 5 seconds.
Default OS: 7 Ultimate
Entry #1
Name: Vista Ultimate
BCD ID: {0b27e389-6d6e-11de-8566-d89e6b09a9b7}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
Entry #2
Name: XP Professional
BCD ID: {8ffd1d23-88a3-11de-9b3c-001b38ab2639}
Drive: D:\
Bootloader Path: \NTLDR
Entry #3
Name: 7 Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Thanks for your time, FYI, I tried changing the partition on XP from D: to E: and gives the NTDLR mission error.
 

JustinW

Super Moderator
Staff member
#4
Leave the drive letter for the entry alone. Its already correct as you can normally boot XP. I haft to run off to class at the moment, but someone else well be around soon I'm sure or I'll be back later to look over the details.
 

mqudsi

Mostly Harmless
Staff member
#5
Quick question: how much ram do you have?
 
#6
I have 4gb. Vista is 32 bit, same as XP and 7 is 64 bit. The weird thing is that it use to work fine, i dont know what messed it up. Also I noticed that on XP's boot.ini it said Windows XP = Windows x64 ....bla, but it was never XP x64, it actually the XP media center edition.

Thanks for your time in advance.
 

mqudsi

Mostly Harmless
Staff member
#7
Thought so!

We've seen this issue a number of times. Try removing just 1GB of RAM, and you'll see your non-cold-reboot issues will go away.
 

JustinW

Super Moderator
Staff member
#9
3GB or less for it to work correctly... wouldn't that be a problem as machines typically come with more memory now?
 

mqudsi

Mostly Harmless
Staff member
#10
If you can find a decent way of searching through the archives here in the forums, you'll find a number of people with similar problems. It really vexed me - their machines would always cold-boot OK, but warm starts would fail.

I don't know why, but the poster decided to try lowering his RAM and it solved the issue. We had other people with the same problem, and that advice worked for most of them, too.

I'd recommend using a 64-bit OS if you need 4GB of RAM. As it is, you'll only be getting ~3.2GB anyway on an x86 OS.
 
#11
Thanks everybody for their time and help, actually I got it to work, in my case it was a Koutech IO-ECSU120 Single Channel Power Over eSATA & Hi-Speed USB 2.0 ExpressCard, I unplugged it and it worked fine, cold boot or any other boot issues gone.

The weird thing is that I plugged it back ti and cold boot worked fine! I know what to do if it happens again.

Addendum:

Actually i got it to work in my case it was a Koutech IO-ECSU120 Single Channel Power Over eSATA & Hi-Speed USB 2.0 ExpressCard, it unpluged it and cold boot worked fine.

The weird thing is that I plugged it back it and cold boot worked fine again! I know what to do if it happens again.

Thanks everybody!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#12
Talking of "decent way of searching the archives", there is a problem with generating a decent search argument when the forum disallows "too small" parameters.
I can see the point of avoiding a/at/of/an/to etc. but disallowing XP/W7 makes it much more difficult to home in on an old thread.
Is there any way of excluding specific parameters from the "too short" category.
 

JustinW

Super Moderator
Staff member
#13
I don't think there is? For pratical purposes it doesnt make sense to search for a single term or something with only 2-3 characters so I can see why its disallowed. Googles your friend.
 

mqudsi

Mostly Harmless
Staff member
#14
Not just that - terms like "VHD" and "ISO" also cannot be searched for.

There's something I can try to implement when I get the time - it's most similar to hosting my own search engine which will archive the site and display <<<smarter>>> results.
 

Terry60

Knows where his towel is.
Staff member
#15
It's not a single term that's the issue Jus, it's trying to eliminate the irrelevant with additional info, like "XP bootloader" to eliminate the thousands of unwanted Vista hits. Unfortunately most of the extra terms you need to focus in on the post you seek, get ignored.
Irrational I know, but I try to avoid all things "google". Never have liked their intrusive behaviour on their search or their browser.