iReboot.exe - Application error


Dual boot, Vista Home Premium 64-bit SP 1 and XP Pro 32-bit SP 3.
Installed iReboot 1.1.0 in Vista used it to reboot to XP
Installed iReboot in XP and select to launch iReboot at Finish
iReboot did not launch
Went to Start/Programs/NeoSmart Technologies/iReboot and launched from there
Got iReboot.exe - Application Error " The application failed to initialize properly (0xc0000135). Click on OK to terminate"

Clicked OK, uninstalled, downloaded again, reinstalled, got the same results.

I noticed that easyBCD was not installed so I installed that and got the same error message.

AMD Phenom Quad core
160GB hard drive partitioned for XP and Vista
500GB Hard drive for program files, data etc

iReboot has worked in such a dual boot environment for me before.

My only suspects at this point are:

1. I recently stripped both OSs clean with uninstall utilities and CCleaner, then in Vista relocated documents, program files and other assorted folders to the 500GB drive using TweakVI and regedit. Have not done that in XP yet. iReboot works fine in Vista.
2. The firewall (CA Internet Security Suite 2007 with all updates). I don't know where to look there but will be exploring that and any other ideas I have as I await answers or ideas from here.

Last edited:
Hello dswabc, welcome to NST.
Do you have .Net Framework installed in XP?
If not, then you will need to install it before iReboot works.
.net 2.0 or higher is required to be pre-installed in order to run NST programs. You may download .net 3.5 SP1 for XP here. If you continue to have issues visit Windows Update and make sure you have installed any updates that are available.
Will do. But I've been using easyBCD in a couple of dual and triple boot situations over the last several weeks and never had problems until this newest dual boot setup. I don't expect any more problems but I will certainly remember where to get great support when/if I need it.

Thanks again,