iReboot issue?

First off, I want to make clear that I'm not "blaming" iReboot for this problem. I know that in any OS, there can be things that happen which the user is totally unaware of, and which can cause major headaches. Even so, I just wanted to pop in here and mention my experience after installing and using iReboot.

Yesterday I discovered iReboot, it sounded like a useful tool, so I installed it. Just to mention, my PC was set-up as Tri-Boot with XP (x64), Win7 (RTM), and Ubuntu, and has been rock solid under all 3 OS's for months. So, in other words, as far as I know, at the time I installed iReboot, the whole machine was very stable and worked perfectly.

I installed iReboot under XP (x64), and that is my "Active" boot partition. To test it I told iReboot to reboot back to XP. At which point the machine went through the shut-down MUCH faster than usual, and when it tried to restart, I got an error about C:\NTLDR being corrupt or missing. (I don't recall the exact error msg)

I rebooted into Win7, and crossed my fingers that whatever iReboot had done, would be fixed after another reboot. So after Win7 had fully loaded, I did a normal reboot.

But this time, before getting the boot menu, I got a message that my C:\ drive had to be checked (XP is installed on C:\). So, it ran diskcheck, and "recovered" and "removed" a whole ton of files. I can't even begin to guess how many, but it was several hundreds, maybe a couple of thousand. It ran for a fairly long time. After diskcheck finished, I tried to boot into XP again, but got the same message about C:\NTLDR being missing or corrupt.

Fortunately, I was still able to boot into Win7. After Win7 started I tried to view the XP partition from Explorer. But it came up with some dialog about not being able to view that directory. So, bottom line, something is now totally fubar about that partition.

I've booted under Ubuntu, and can see the XP partition, and it looks "normal", but beyond that I don't know what else I can do.

At this point I'm backing up my important files and planning to do a re-install of XP.

Let me again say that I'm not "blaming" iReboot for my problems. But the bottom line is, as far as I know, the machine was rock solid under XP. Then I installed and used iReboot, and now my XP partition is weirdly fubar'd. I'm not claiming that iReboot f*d up my partition, but given the stability before, and the fubar'd state after ... one can only wonder.
Hiya HighlyDubious,

I can assure you that iReboot did not cause the problem you described - if you had said EasyBCD under certain circumstances that might be possible since EasyBCD does some re-configuration of the partition tables, etc... BUT that's not how iReboot works.

What is more likely is that using iReboot exacerbated an existing problem. In all likelihood, certain portions of the filesystem were corrupted. From your description, I'm assuming it was something towards the beginning of the filesystem, near the file table and the bootsector. Now iReboot sent a command to the Microsoft tools responsible for managing the bootloader telling them to boot into XP at next boot. The thing is, this involves the Microsoft tools writing to a certain portion of the disk (on the filesystem though, not to the partition table) which could have triggered write to a corrupt section of the disk, messing up the data on your system and triggering the chkdsk session.

Of course, what's more important than putting the question of blame to rest is getting your system back up and running....

Run chkdsk on C: once more, with the "/r" parameter (Start -> Run -> "chkdsk C: /r" without the quotes) and let that finish. Then run EasyBCD 2.0 and use it to delete then re-create the XP entry. Let it auto-configure your settings, and try booting into XP once more.

If that doesn't work, post back and I'll walk you through some more alternatives.

Good luck!
Thanks for the reply CG, unfortunately, I'd already attempted my own sort of repair.

I'd read some other mentions in a few other forum threads here about using EasyBCD 2.0 to recover, so I downloaded it and just follow my own intuition for what made the most sense.

From the "Diagnostic Center" Button, I told it to "Rescue My System". This resulted in a BCD with only the Vista Bootloader (for my Win 7 partition).

Next, from the "Add/Remove Entries" Button, I added entries for Win XP, and Linux.

Sadly though, the end result is that now, everything is fubar. :frowning:

On reboot, I didn't even get a boot menu. Just some message about "\Windows\system32\winload.exe" having a status of "0xc000000e" and being corrupt or missing. No indication of if that is the C: or D: drive (Win XP was on C:, Win 7 was on D: )

So, now I've just completed backing up my data (from a Linux bootable CD), and I'm off for a few hours to take care of some other personal business. After that, I guess I'll re-install XP and Win 7 from scratch (I'd already planned to re-install Win 7 for completely unrelated reasons, I just hadn't planned to do it so soon).

Anyway, I guess this is what happens when one goes off half-cocked and guessing what to do, rather than waiting for good advice from professionals.

For what it's worth, shortly after installing iReboot, I did load up EasyBCD (1.7.3), but as best I recall, I just looked around at the settings, and I don't remember making any actual changes to anything before quitting.

Thanks for the advice anyway, obviously I should have waited for it, rather than going out and doing something truly stupid. <sigh>

Last edited: