Is EasyBCD Windows 7 64-bit / UEFI compatible?


I have a very easy question. Is EasyBCD Windows 7 64-bit / UEFI compatible? I ask this because I tried to install Ubuntu 10.10, and that goes very well but grub2 doesn't get installed, and I'm only be able to boot Windows 7. Windows 7 bootloader is located on the EFI system partition. Because of that I've added an grub2 entry to BCD with EasyBCD but I get an error similar to this one:

As you see, I've also tried to install Ubuntu via Wubi but that fails as well.

The specifications of my computer:
XXODD 860tnu (no, this is not a mac computer)
UEFI firmware (Phoenix SecureCore)
Windows 7 64-bit
GPT-partitioned harddisk

Thanks in advance.
Kind regards.
I am using EasyBCD in Windows 7 64-bit and it is working perfectly, but I do not know the answer to your question about "UEFI".

You have said, "I tried to install Ubuntu 10.10, and that goes very well but grub2 doesn't get installed, and I'm only be able to boot Windows 7."

I have yet to try Ubuntu, but I have had similar experience with GRUB not going in during installation of Linux Mint 9. I could be wrong here, but I no longer suspect EasyBCD as being any part of my problem back then since it works perfectly with Mint 8 after Mint 8's installer *could* install GRUB just like it should. Personally, I highly suspect only GRUB there.
Thanks for your reply. The package grub-pc gets installed, where I believe the package grum-efi-amd64 should be installed, but the doesn't work either. If I could install another EFI bootloader that either could invoke the Windows Bootmanager or GRUB (or just boot Linux by itself) my problem would be resolved.

But the fact that EasyBCD does'nt seem compatible with my computer seems to be caused because my computer runs an EFI firmware. I'm not able to use any of EasyBCD's features, ISO boot, Grub legacy boot, Grub boot, it all fails.


Mostly Harmless
Staff member
Hi Sebazzz, welcome to NeoSmart Technologies.

I've never had opportunity to play around with an EFI computer (I have a MacBook, but that uses its own MBR impersonation mode), so I don't know if EasyBCD will work or not.

Can you try assigning your EFI partition a drive letter while in Windows, then trying with EasyBCD once more? If the boot partition has a drive letter, EasyBCD works in a different mode.
I've assigned the EFI partition a drive letter with the "mountvol X: /S" command where X: is the drive letter. The partition is visible in Windows Explorer, but I cannot access it. Windows asks me I want permanent access to the partition, if I continue it tells me I don't have access and should use the 'security' tab, but in the properties window of the partition there is none.

As for EasyBCD, I don't detect any difference in its behaviour. It still adds *.mbr entries to the bootloader that simply don't work and return an error similar to the one in the screenshot.


Mostly Harmless
Staff member
Well, if Windows cannot access the EFI partition, then EasyBCD can't either...
According to the Microsoft knowlegde base the mountvol /s command is only available for IA-64 (aka Itanium) architecture, not AMD64.

But, I figured already out how to do it. There is probably a better way, but at least it works. By using the keystroke for 'Cancel' (in my case ESC) in the Windows Boot Manager, EFI goes to the next item in the boot sequence and reloads Windows Boot Manager from the hard disk. Then if I press ESC a second time EFI reverts to legacy boot and loads grub from the bootsector which in its turn launches Ubuntu.

It's not the right way, and I don't know how reliable this method is nor how easy it breaks, so suggestions how to do it the right way are always welcome.


Mostly Harmless
Staff member
Have you looked at rEFIit?
Yes, but there is no install guide for a normal laptop, MAC only. I've replaced the /EFI/Boot/bootx64.efi file with refit.efi and although refit works it is not able to boot any of my OS.


Mostly Harmless
Staff member
I think you need to configure it first?


Mostly Harmless
Staff member
You can see the files, but the real question is what to do with them.