Is it Vista or my hard drive?

#1
Hello! You guys helped me so much in recovering my data when my laptop crashed, now my 8 month old desktop crashed! I made the recovery disk and made a restore disk, but I can't get either to load! I can't enter in safe mode or anything. Will I be able to extract my data on another computer? They are all zipped files, and when I try to look at it on my laptop, I don't see any data files. Thanks!
 

Terry60

Knows where his towel is.
Staff member
#2
Get a bootable Linux distro, burn it to CD, boot the CD in "don't change my computer" mode, use "places" on the desktop to open an Explorer-like window.
Navigate to your HDD and drag your files to external storage and safety.
Then you can think about using the OEM recovery partition to restore or factory-reset your PC.
 
#3
When I used the Vista boot CD I hit install now did I screw up. I have a back up CD how can I access the data and OS.
I am going to try Ubuntu I made a CD is there any thing I should be careful of.

Thank You
 

Terry60

Knows where his towel is.
Staff member
#4
If you clicked "install" from our recovery disk, it won't do anything (except fail) because it has no installation files. Only the "repair your computer" link (bottom left) will do anything.
The Ubuntu CD will enable you to find the files on your HDD and copy them off to externnal storage.
Don't hit the install button on the Ubuntu CD, just use the option to run Ubuntu directly from the CD.
 
#5
just use the option to run Ubuntu directly from the CD.
...the option named, "Try Ubuntu with No Change to My Computer".
Once on the Ubuntu desktop, just open up the Places menu, select Computer, find the partition your data is on, and copy your stuff over to an external HDD.
For Vista, the folder you're likely to find most of your stuff in is:

Users/USERNAME/Documents

For XP, it is:

Documents and Settings/USERNAME/Documents
 
#6
Hi,
I have loaded Ubuntu and went to places and computer and the only I see are three icons one is my printer and one files and one generic multi card. I clic on files and i looks like its all ubuntu files

Thanks for all the help
Jim

Addendum:

My hard drive is also clcking. This is what my last one did and I ran Disk check several times and got all my files. After I was done it made no noise but I got a new one.
 
Last edited:
#7
Last edited:
#8
Thanks for the link I will go through it.
Is the Files icon the hdd otherwise I cant see it. Also when I run vista disk boot I dont show any drivers and can't add any no OS.


Thanks again
Jim

Addendum:

Yes last time I successfully backed up ALL my files with your help.Thank You!!!!! I had five computer places tell me that they could not get the files. I did everything you said ran ckdsk 20 times and it fixed the problem.
 
Last edited:
#9
Great! :smile:
So your problem is completely solved now?

Cheers.

Jake
 
#11
Hi coolname007,
I loaded Ubuntu and booted from cd went to places and then to computer no hdd just printer, router and filesystem.
Can you help?

Thanks
Jim
 
#12
Hi Jim.
Have you tried mounting the Vista partition from Ubuntu's command-line (Applications->Accessories>Terminal) using the commands in the link I gave above?

The commands are:
Code:
sudo fdisk -l
sudo /bin/bash
mkdir /media/disk
mount -t ntfs-3g /dev/sda1 /media/disk -o force
where /dev/sda1 is replaced with the correct thing given in the fdisk output for the Vista partition.

Addendum:

Also, your bootsector may be corrupted. That could be why Ubuntu didn't detect your Vista partition (I had that problem with my XP partition, when its bootsector got corrupted).

If that is the case, you'll need to boot from your Vista dvd or the neosmart recovery disk, access the Command Prompt, and run:
Code:
bootrec /fixboot
That will rewrite the boot sector of the "active" partition, which assumedly is your Vista partition. If for some reason, the "active" (and hence, "system") partition is some other partition on your HDD, you can temporarily set the "active" flag using System>Administration>Partition Edit from the Ubuntu desktop (though Gparted calls it "boot" instead of "active) to your Vista partition, then run the command, and so that way the bootsector of Vista's partition will get rewritten instead of the other one.

BTW, sorry for all the confusion earlier. Its obvious now after re-reading this thread that you were talking about the other computer, when you mentioned recovering your files and fixing your system with chkdsk, and I thought you were talking about this one. My bad, I'm sorry.

Addendum:

And in answer to the question in the title of this thread, I believe its probably your hard drive that is the problem.
 
Last edited:
#13
I cant do the first option, because Ubantu doesnt even show my hard drive. Tried the second option, but can't get to a C: prompt, because it says it is not recogized as internal or external command, operable program or batch file.

Jim
 
#14
I cant do the first option, because Ubantu doesnt even show my hard drive. Tried the second option, but can't get to a C: prompt, because it says it is not recogized as internal or external command, operable program or batch file.

Jim
Did you try running the commands anyway? Just because Ubuntu's "Computer" program doesn't show your HDD doesn't mean fdisk wont. :wink: Run the commands from the Applications->Accessories>Terminal like I already stated.

And where are you trying the second option from?
 
#15
This is what I get when I do the fdisk.

Invalid option -- '1'
Usage fdisk (-b SSZ) (-u) DISK Change Partition table
fdisk -l (-b SSZ) (-u) DISK List partition table
fdisk -s PARTITION Give partition size (s) in blocks
fdisk -v Give fdisk version


Addendum:
I got to the root@ubuntu: but because fdisk didnt give me the inital information, I cant replace the dev/sda1, because I dont have that information.


Then when I do the bin/bash command, it says no such file or directory. The second option, I was using my Vista boot disk, and I can't get a C:, only the XSources prompt.
 
Last edited:
#16
Its a lowercase "L" in the fdisk command (not a number 1-one).
To get to your C from X, you can do:

C:

or

cd /d C:\Windows\system32

to change directory. But I believe the bootrec program can be accessed straight from X.
 
Last edited:
#17
Hi Guys,
I have tried using ubuntu with the live walk through and when type fdisk -l nothing comes up.
I also went through all the commands and it does'nt seem like it sees a drive
I have a back up disk but I cant access it they are zipped files. maybe if I can access this dvd I can check to see if my files are ok and my OS. There are 8 files on this dvd.

Thanks
Jim

Addendum:

Could it be a bad part in the drive? I can rebuild it with a new doner drive I just dont know if its bad and I rebuild it could one of the platters be bad or sectors. I think my last vista crash caused the drive to click. this ones doing the same thing.:??:wtf:

Thanks again
Jim
 
Last edited:
#18
If fdisk's not showing a HDD, then you're definitely screwed, and your HDD failed. :frowning:
The only other thing that comes to mind that may help is this:

Take the HDD out of the computer, put it in an external HDD case that fits it, and plug it into any other computer you have at your disposal. Then using the other computer, try using various data recovery programs, including testdisk, to try to fix the HDD. Chances are though, even that will not work. Once an HDD goes (by hardware failure), not much chance in recovering the data off of it, unfortunately...

But, hey, anything's possible. However, I'd suggest getting in the habit of actually backing up to that "backup disk" in the future...
 
#20
Yes, you should be able to. As I understand it, its your primary HDD that's the problem, not the backup HDD. Just connect the backup HDD to another computer, and use the other computer to access whatever's on it.