I've kinda killed EasyBCD - system will not boot

irishbiker

New Member
Hi

As previous I am running XP, MacOSX and BT R5

Using EasyBCD along with a boot from Windoze 7 I got it to work quite well. BUT

Messing about with MacOSX I've kinda killed the windows boot:

It starts the windows boot but I get the following errors:

When I select Windows:

File: \NST\ntldr

Status: 0xc000000e


When I select Linux:

File \NST\AutoNeoGrub0.mbr

Status: 0xc000000e

......You get the picture :smile:


I'm guessing the NST Folder is missng or the config is corrupted


I can drop into a dos box using your vista boot disc. How do i:

Repair the config or remove the windows loader to allow it to boot XP and get the system back up and running.

Where is the NST folder stored?

Thanks

Paul
 

irishbiker

New Member
Thanks for getting back to me,

I've been using your vista system disc, it can't find
bootsect.exe either using:

x:\boot\bootsect.exe /nt60 all /force

bootsect.exe /nt60 all /force

where is bootsect.exe located?
 

mqudsi

Mostly Harmless
Staff member
You can find it in \Program Files\NeoSmart Technologies\EasyBCD\bin\
 

irishbiker

New Member
thanks for the link:

It reports that Bootcode was successfully updated on at least one volume.

del C:\boot\bcd

This was not found. Checked the boot folder and found the file (hidden system file)
I think you need to add the command attrib -h -s BCD then del BCD

worryng running bootrec.exe /rebuildbcd found 0 windows installations


rebooted the system

It now reports:

\Boot\BCD

0xc000000f
so close but so far....... Any ideas?
 

mqudsi

Mostly Harmless
Staff member
Good point.

Anyway, move on to "Option 3: Nuclear Holocaust"
 

irishbiker

New Member
ok skipped to
bcdedit /createstore c:\boot\bcd.temp (worked ok)

bcdedit.exe /store c:\boot\bcd.temp /create {bootmgr} /d "Windows Boot Manager"

reports:

The specified entry identifier is not valid.
The parameter is incorrect

Addendum:

update used wrong type of brackets.... make sure you use { }

Addendum:

phew! ok entered all the instructions as per list

rebooted the unit to get:

file \windows\system32\winload.exe

status 0xc000000f

:/

Remember my system is xp....
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Your system is XP? I thought you had Windows 7 in there!
 

mqudsi

Mostly Harmless
Staff member
You need to use the Windows XP CD. Boot into the recovery console there and run bootcfg and bootfix

Or, use bootsect.exe /nt52 instead of /nt60 and bootgrabber.exe /bootcfg
 

irishbiker

New Member
YES!

I am back up and running. Thanks a lot :smile:

Addendum:

For anyone in the same issue I booted using the vista boot disc.

then

c:

cd Program Files\NeoSmart Technologies\EasyBCD\bin\

bootsect.exe /nt52 all /force

bootgrabber.exe /bootcfg

reboot

Addendum:

However EasyBCD won't let me add a XP boot, it reports

EasyBCD failed to detect a valid installation of Windows NT-2003 on all mounted drives and was unable to continue.

How do I get a valid XP boot so EasyBCD will play nice?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Can you post the output of bootgrabber.exe /v /bootcfg from within Windows?
 

irishbiker

New Member
BootGrabber utility.
Copyright NeoSmart Technologies 2009-2010 <http://neosmart.net/>

Located active partition on drive 0: \ArcName\multi(0)disk(0)rdisk(0)partition(1)
Drive 0, Partition 1: Valid Windows 2k/XP/2k3 (Added).
Located active partition on drive 0: \ArcName\multi(0)disk(0)rdisk(0)partition(1)multi(0)disk(0)rdisk(0)partition(4)
Located active partition on drive 0: \ArcName\multi(0)disk(0)rdisk(0)partition(1)multi(0)disk(0)rdisk(0)partition(4)multi(0)disk(0)rdisk(0)partition(4)
Failed to create file to \ArcName\multi(0)disk(0)rdisk(0)partition(1)multi(0)disk(0)rdisk(0)partition(4)multi(0)disk(0)rdisk(0)partition(4)\Boot.ini. Error code: 0xc000003a.
 

mqudsi

Mostly Harmless
Staff member
What the heck!

You've got some super corrupt BG output there. Let me review the code and see how this might have happened.
 

irishbiker

New Member
Thanks for checking for me. I have however fixed it. From reading the output Part 4 is my linux partition. As I've not done much with it I deleted the partition and EasyBCD started to work fine. I just reinstalled Linux and all seems to be well again.

Thanks for your help.
 
Top