Kernel_Stack_Inpage_Error help

#1
For about a week and a half now I get the above error and the stop error changes from crash to crash. (I've included two below) I can reboot and be fine for a day or two or a short time. No ryhme or reason. I've run a checkdisk with repairs that took 10 1/2 hours and ran an update to Norton 360 and ran a virus scan. Nothing. I'm comfortable enough to try fixes, but I am not a PC guru. Hoping one of you might be able to help guide me to getting this fixed.

**STOP: 0x00000077 (0xC000000E, 0x000000E, 0x00000000, 0x0CB1000)

or I get
**STOP: 0x0000007A (the codes in here vary from crash to crash)

I have checked that my memory cards are in tight and even sprayed the area for any dust before closing it back up. I'm running a Sony VAIO VGN-CR220E. This is the last VAIO I buy. I've had five now and every single one of them has had problems. *sigh*

Thanks in advance for any help you can provide.

Cindi
 

mqudsi

Mostly Harmless
Staff member
#2
Upload a copy of the minidump files from C:\Windows\minidump\ to here in an attachment.
 

JustinW

Super Moderator
Staff member
#4
You might want to switch your antivirus? Norten 360 don't run all that well and could very well be causing these problems. Have you tried system restore to go back before this started occurring?
 

mqudsi

Mostly Harmless
Staff member
#5
I'm afraid it looks like a hardware problem.

Seems to be bad memory to me - run the Windows memory test tool... Hit F8 during startup, press <tab> to access the tools menu, then select the memory tester tool from there.

Details:

Code:
KERNEL_STACK_INPAGE_ERROR (77)
The requested page of kernel data could not be read in.  Caused by
bad block in paging file or disk controller error.
In the case when the first arguments is 0 or 1, the stack signature
in the kernel stack was not found.  Again, bad hardware.
An I/O status of c000009c (STATUS_DEVICE_DATA_ERROR) or
C000016AL (STATUS_DISK_OPERATION_FAILED)  normally indicates
the data could not be read from the disk due to a bad
block.  Upon reboot autocheck will run and attempt to map out the bad
sector.  If the status is C0000185 (STATUS_IO_DEVICE_ERROR) and the paging
file is on a SCSI disk device, then the cabling and termination should be
checked.  See the knowledge base article on SCSI termination.
Arguments:
Arg1: c000000e, status code
Arg2: c000000e, i/o status code
Arg3: 00000000, page file number
Arg4: 146cd000, offset into page file

Debugging Details:
------------------




ERROR_CODE: (NTSTATUS) 0xc000000e - A device which does not exist was specified.

DISK_HARDWARE_ERROR: There was error with disk hardware

BUGCHECK_STR:  0x77_c000000e

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from 81eb6c70 to 81ee20e3

STACK_TEXT:  
88993c24 81eb6c70 00000077 c000000e c000000e nt!KeBugCheckEx+0x1e
88993cb0 81e9898e c05514d0 c05514d0 00000001 nt!MiMakeOutswappedPageResident+0x47a
88993d38 81e66563 ac5f4938 88993d58 00000000 nt!MiInPageSingleKernelStack+0x20a
88993d6c 81e5071a ac5f49a8 00000000 88993dc0 nt!KiInSwapKernelStacks+0x43
88993d7c 81feab18 00000000 388a028d 00000000 nt!KeSwapProcessOrStack+0x83
88993dc0 81e43a2e 81e50697 00000000 00000000 nt!PspSystemThreadStartup+0x9d
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt!MiMakeOutswappedPageResident+47a
81eb6c70 cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt!MiMakeOutswappedPageResident+47a

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

DEBUG_FLR_IMAGE_TIMESTAMP:  48d1b7fa

IMAGE_NAME:  memory_corruption

FAILURE_BUCKET_ID:  0x77_c000000e_nt!MiMakeOutswappedPageResident+47a

BUCKET_ID:  0x77_c000000e_nt!MiMakeOutswappedPageResident+47a

Followup: MachineOwner
 
#6
I ran the memory diagnostics with no errors found.

On the Norton front, my 360 subscription expires in a few weeks...wonder if it might be a problem given I installed the first release of the software. I'm due to update it, so I'll remove it and reinstall and see if that helps. If not, I will remove it and try McAfee.

Thanks for your help guys. I'll let you know what happens after I try the antivirus path.

Have a great week!

Cindi
 

mqudsi

Mostly Harmless
Staff member
#7
How many passes did you run in the Memory Test?
 

Terry60

Knows where his towel is.
Staff member
#8
#9
Hi, Guru!

It did two passes each time...and I have learned to run things in threes:wink:

Knock on wood, no crashes since yesterday morning. But it seems to go a few days, happen a few times within a short time period and then starts the cycle over again.

Should I run it again or something else I should check?

Thanks,

Cindi
 

mqudsi

Mostly Harmless
Staff member
#10
This isn't really scientific, but the next time you experience such a crash run the memory test right then and there?

The better option is to download yourself a copy of Prime95 and run the stress test... it'll let you know if there's something funky going on with your hardware.

http://www.mersenne.org/freesoft.htm
 
#11
I will download that now and see what it finds. And next time it crashes, fingers crossed it doesn't but I know better, I will run the memory test right then.

Funky...I do love technical jargon:wink:

Thanks again, Guru!

Cindi
 

JustinW

Super Moderator
Staff member
#12
Is this Vista pre-sp1? I supposedly had hardware problems with my desktop but not anymore after a re-install. There have been reports of pre-sp1 Vista causing memory corruption issues. You should run the system file checker to check the install for corruption.

From an elevated command prompt, use:

Code:
sfc /scannow
If it finds corrupted files but can't fix them its time for a re-install. Apply SP1 immediately if you don't have it or after the installation. Right-click on computer and select properties to see what version/service pack you have in the window that appears.

Addendum:

Yeah the new AVG is great. Been using it in W7 and it even has siteadvisor type features for searching.
 
Last edited:
#13
Hi, Justin!

I am running Vista SP1 and apply updates as they come through from Microsoft. But I will run the scan and check to see if it finds anything. This system is only a year old, I surely don't want to buy another one any time soon. Though it seems, looking back, I've done that far too frequently with the Sony Vaios.

Thanks for your help.

Cindi
 
#14
Last edited:
#15
Hi, all!

I've been on the road, but wanted to thank you all again and provide an update.

The errors continue even though no errors are found when I test the memory. I've broken down and ordered new memory and decided to upgrade it to the max while I was at it. Not sure what happened, but it's cheaper to just replace the memory and call it even. Not to mention the stress that rebooting after the BSOD brings:wink:

Thanks again all, keep your fingers crossed that this fixes it.

Cindi
 
#16
Just a quick update.

I put new RAM into the machine and it worked for a day or two before I started getting more errors. Multiple memory and hard drive scans revealed no errors. Eventually I could not even reboot without getting the BSOD. I went ahead and completely restored the C Drive to the factory settings from a year ago. (I WILL NEVER BUY ANOTHER PC WITHOUT A DVD OF THE OS INCLUDED!) That crashed and burned after a few hours. Did it a second time and, knock on wood, so far so good.

*sigh* That said, I never could determine what caused the problem. Perhaps it was some fault drivers as suggested...too bad I never could figure out which one(s).

Thank you again for all your assistance. What a great community!

Cindi
 

mqudsi

Mostly Harmless
Staff member
#17
Hi Cindi,

Sorry to hear the ordeal wasn't over, but glad to see everything is going well now.

Do stick around and enjoy the chit-chat and support - we'd love to have you a regular here :smile: