Kubuntu booting to grub console

First of all I'm sorry for posting another Ubuntu-boot-problem, but the others I checked mostly seemed to deal with something else...

On my laptop I have 5 partitions on one drive which are the following:
1. Vista 32 (NTFS)
2. Data-Partition (NTFS)
3. Kubuntu 8.10 (Ext3)
4. Lunix-Swap (SWAP)
5. Recovery-Partition (EISA)

while Installing Kubuntu the drives where named like that:
1. sda1
2. sda4
3. sda5
4. sda6
5. sda2
(Dont ask where sda3 is, i have no idea...)

So now I want to use the Vista Bootmanager. I set all up with EasyBCD, so the Bootscreen would have an option for Vista und one for Kubuntu.
While booting it all works like it should work, but when I want to boot Kubuntu, i directs me to the grub-console.
During the installation I selected to install grub to /dev/sda5, like pointed out in the ubuntu-install-manual by EasyBCD, but at the end of the installation an error with the grub instal occurred. So I reinstalled Kubuntu -> same error. I tried to reinstall grub to the Partition-Boot-Record of sda5, but seemingly it doesnt want to work. Any ideas?



Super Moderator
Staff member
Hi Madnebular, welcome to NST

Uninstall NeoGrub. Delete the current entry. Create a new one without installing NeoGrub. Check the "grub is not installed to mbr" option when you re-add the new entry.
Thanks for the quick reply.
I'm not exactly sure how to add a new entry without installing neoGrub.
What I'm doing is the following:
Select Add/Remove Entries
There select Kubuntu from the list, switch to the NeoGrub Tab und uninstall it, then remove the kubuntu entry.
Switch to Linux-Tab, select GRUB from the drop-down menu, tyoe in the name, and check "GRUB isn't installed to the bootsector". Since the Partition-selection is becoming grey, I'm not mentioning it...
Click on "Add Entry"

The new entry appears, but when I go to the neogrub-tab, there is again the option to remove neogrub, so I guess I didnt add the entry without it. What am I doing wrong?


Super Moderator
Staff member
No its fine. Whats happening in the background is that NeoGrub is being installed, but in the automatic configuration, where it uses the menu.lst on the linux partition you point to if it can find one.


Super Moderator
Staff member
Ok either...

grub hasn't been installed to the linux partition


grub wasn't installed properly and/or menu.lst on the linux partition is missing.