Laptop is now toast?

argy

New Member
#1
Hi,

I installed bcd on my vista laptop having previously created a centos partition running trixbox pbx which I couldn't subsequently boot in to. I installed bcd to allow me to boot into this partition.

With bcd I backed up my boot records (to the root of my c drive) and I can see this as a 20 byte file. I then added the new centos entry to the list and saved. When I rebooted I didn't get any options, I saw a black screen flash which I presume had the boot options but as the delay was set to the default 0 seconds I could not do anything with this.

In Vista I ran bcd again and told it to boot into the centos partition and restarted. That's when I lost my laptop...

The laptop now only boots into the acer recovery screen and none of the startup fixes solves the issue despite multiple iterations. I have a vista recovery dvd from neosmart and have run all flavours of bootrec. The result I get is that bootrec can not find any installations.

Anything I can do (other than a new install) to get my laptop, and preferably all my data, back?

Thanks in anticipation
Argy
 

argy

New Member
#2
Well, seeing as the laptop boots into its recovery mode and since I wrote that I can see backup that I placed on the root of the C drive I can't see that that the hard drive has worked loose.

Thanks for your input.

Argy
 

argy

New Member
#4
Sorted

Hi,

Yes, I tried all the approaches on the site.

I solved the problem by making a backup image of the hard drive (put the drive into another PC and ran Macrium Reflect free edition). I then re-installed (recovered) the saved image back onto the laptop hard drive and told the application (Reflect) to replace the MBR with the standard XP MBR.

I did this with some reservation as my laptop is vista.

After the above I put the hard drive back into the laptop which wouldn't reboot so I then had to go through the install from dvd process and get the computer to repair itself. The laptop recognised an issue with the boot record and resolved the issue. I had to make one more reboot and now the system is working fine.

I don't think I'll be bothering with easybcd.

I will be sticking with Macrium Reflect and will definitely save an image before doing anything with the mbr in the future.

Regards
 

Terry60

Knows where his towel is.
Staff member
#5
What version of EasyBCD were you using ?
Why were you rewriting the MBR anyway ? That's not necessary to add entries into the MS BCD.
Why on earth did you have timeout set to zero ?
How did you expect to see a boot menu ?
Don't blame EasyBCD for borking your system.
There are (literally) millions of users of this app, which would hardy be the case if it broke systems.
A simple socket set can be successfully used to wreck a fine motor car. It's not responsible for the damage.