Laptop Win 8 recovery

#1
New laptop with Win 8. Tried to resize boot partition with Easeus Partition Manager and it no longer boots correctly. Connecting the hd as an external shows that it was resized but recovery partition is missing now.

I tried installing Win 7 and Ubuntu from USB using unetbootin but neither worked. Win 7 got as far as "Windows is loading files" but that appears to be the system attempting recovery because I've been getting the dreaded:
"your pc needs to be repaired" "a required device isn't connected..." error 0xc0000225
with both boot options (exact same heading though).

In EasyBCD, under Windows Boot Manager, device showed Boot. Boot was also shown under osdevice for Windows Boot Loader. I tried changing the latter to C: under Advanced Settings to no avail. Tried Re-create/repair boot files but no result either.

This is the first time I've had to repair any installs since Win XP and it's also my first exposure to UEFI so I could be doing a lot of things wrong. I was trying to read up on UEFI as I found many things were different from BIOS but most of it was beyond me or what I wanted to know.

Addendum

Was able to create a recovery flash drive from an identical laptop and went through
bootrec /fixmbr
bootrec /fixboot
bootrec /scanos
bootrec /rebuildbcd
in that order with everything appearing to be successful.
Still got recovery screen error on first reboot but 2nd reboot went into Windows...


Whew...