Linux boot

#1
After following the “Adding Linux to the Vista Bootloader” instructions I am unable to boot from my Linux drives. Grub installed just fine with FC6 and I’m able to boot from Linux (Grub) if I change my BIOS and select that RAID configuration. Vista sees the drive just fine as drive 1 and with two partitions. I have tried drive 1 with partition 1 and drive 1 with partition 2. Nothing happens though just black screen with the cursor flashing in the upper left-hand corner. I do have two RAID 0 configurations, one for Vista and the other for Linux using the Intel ICH8R controller. FC6 sees the RAID configuration just fine and installs with no problem, Again, I am able to boot from Grub when I switch the BIOS to but from that RAID setup. I’ve used BootMagic in the past with this exact configuration and didn’t have a problem, but I don’t know what the problem is in this case besides not selecting the right drive and partition, but again, I have tried all combination that Vista is detecting. Or maybe I need to tell EasyBCD that I have a completely separate drive with a RAID configuration so it can switch control to that drive, I had to do that in BootMagic when using physically separate hard drives. But I just guessing, not sure how EasyBCD handles that. Any help is MUCH appreciated. Thanks in advance.

David
 

mqudsi

Mostly Harmless
Staff member
#2
Hey Dave,

The problem is that you're using GRUB from the MBR of the second HD. You need to install GRUB to the *bootsector* of the partition FC6 is installed to instead.

Refer to the EBCD docs about "Reinstalling GRUB" @ http://neosmart.net/wiki/display/EBCD/Linux for how to install GRUB to the bootsector.

Instead of booting from a Live CD just boot into Linux by changing the drive order, then install GRUB to the bootsector of the partition, boot back into Vista, delete the EBCD Linux entry and re-create it with the proper partition numbers this time around.

Good Luck!