Locked out of Fedora.

#1
Greetings Neosmart,

I'm a newbie to Linux for the most part and an old Windows user.

I'm having troubles getting BCD and my Vista bootloader to recognize Fedora Core 10. Here's a rundown of how I formatted my had drive:

I made several partitions using my Windows XP cd (one for XP, Vista, Fedora, and a ton of reserved space) on the same hard disk. I then installed Windows XP, Vista and Fedora in that order. I used Fedora Core 10 and all the default settings after selecting 'Install Fedora on free space' which installed just fine.
I rebooted and began updating my OS's until I inserted my motherboard's drivers cd for XP and rebooted, which prompted me to boot from CD, I ignored this but then was locked out of all my OS's with just having the Grub command prompt come up. I looked around for help with Grub but I finally decided to do a fixmbr from my XP cd. I was able to use Windows XP again and in XP the partition manager I could see all of the partitions I created. I repaired my Vista install from the Vista cd and it changed the bootup sequence to Vista's where I then installed EasyBCD.
After installing EasyBCD I tried to create a Linux boot option, but it simply brings me back to the Grub console as before when I choose it. I have a feeling not configuring Fedora's setup installed Grub on the MBR and now it can't boot. How do go by reinstalling Grub to the Fedora partition? Or if I were to reinstall Fedora which settings would I need to change so this wouldn't happen?

Thanks in advance and pardon my Linux incompetence.. :x

By the way, love the forum and EasyBCD software! You guys are doing superb work.
 

JustinW

Super Moderator
Staff member
#2
No this shouldn't be an problem. Go to the NeoGrub tab under Add/Remove entries and uninstall NeoGrub. Delete the entry you tried to create for Fedora and than recreate, but before hitting the add entry button check the box for grub is not installed to the mbr and than reboot to test the entry.
 
#3
Thanks for the quick response. I attempted your suggestions to no avail. :frowning:

Here's a look at the settings overview in EasyBCD:

There are a total of 3 entries listed in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS: Microsoft Windows XP

Entry #1

Name: Microsoft Windows XP
BCD ID: {ntldr}
Drive: D:\
Bootloader Path: \ntldr

Entry #2

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #3

Name: Fedora Core 10
BCD ID: {a3904885-dbae-11dd-8718-00508db5b088}
Drive: D:\
Bootloader Path: \NST\NeoGrub.mbr


And an image of my partition layout: http://img387.imageshack.us/img387/8184/partitionsny7.jpg

Not sure where the 9 MB of unallocated space came from.
 

JustinW

Super Moderator
Staff member
#4
What do you get with the new entry (are you getting a command prompt or a menu)? When you installed Fedora it should have also written the boot information to the bootsector of its partition though you had it write to the mbr. You might need to re-install grub to Fedora's partition to get it working correctly. As far as the 9mb gap, it looks as if it is part of Fedora seeing how Windows doesn't know the filesystem of it and it doesn't have a label.
 
#5
I have never used Fedora 10, but are you using NeoGrub to try to boot it? If so, then please post your NeoGrub menu.lst file, located at C:/NST/menu, so we can take a look at it, to make sure it is configured correctly. :smile:

Cheers! :wink:

-Coolname007