Long Delay before bootloader appears

#1
After installing Windows 8 to partition 2 of Disk 0, where partition 1 holds Windows 7, I am getting a blinking cursor for about 45 seconds before the bootloader appears. Everything works properly, just the delay is disturbing. EasyBCD shows the same information that MSCONFIG shows. ie.​Windows 7 default, Windows 8 and a 10 second delay. Can EasyBCD be used to correct this condition and does it sould like a bootloader problem?
 

mqudsi

Mostly Harmless
Staff member
#2
It sounds like a bootloader problem to me. You must have something other than the standard chainloader written to the MBR. You can try to reinstall the MBR in EasyBCD?
 
#3
Alas, no joy. That assumes that I did it correctly. I went to BCD Deployment, selected "Install the Windows Vista/7 bootloader to the MBR" and clicked "Write MBR." If I did this correctly, I am open to other suggestions.

Addendum

Update:
I attempted to use bootsect.exe to restore the MBR, but that too, yielded no improvement. Should I go to the windows forum to seek further help?
 

mqudsi

Mostly Harmless
Staff member
#4
Check your BIOS settings, maybe?
 
#5
I don't see any oddities in the bios. Since your reply, things have gone south in a hurry. I can no longer boot into Windows 7 at all. I suspect that the Windows 8 bootloader has corrupted things because that was when the long delay started. Also, when I make W8 the default OS, the computer boots into W8, then shows the W8 bootloader and when I choose Windows 7, it reboots the computer and tries to go to W7.

I tried unplugging the drive that contains W7 and W8 and restored a backup to a clean partition on a different drive and I have the same results. Long delay then no boot into Windows 7. I am about out of ideas on this mess. If anyone has any ideas, I'd like to hear them. I see a lot of posts on the web about W8 screwing up W7 installations, but all the advice I see to the problem is "You shouldn't have done that." That doesn't go a long way toward solving the problem.
 

Terry60

Knows where his towel is.
Staff member
#6
#7
Thanks for the reply, Terry. I'm back up and running after a couple of days of troubleshooting and a lot of chkdsk and BSOD. I still have a 45 second wait between POST and the dual boot screen, but I guess I'll live with it for now. I disabled the "Fast Boot" option, but that didn't help my situation. The only thing that I haven't tried is updating my BIOS, but I'm a little shell shocked right now and think I'll just put up with the delay.
 

mqudsi

Mostly Harmless
Staff member
#8
Do you have a RAID card by any chance? That's *exactly* how it would behave at boot time.

In the BIOS, make sure any "ROM" options (such as "Option ROM" or "PCI ROM") are set to disabled or try toggling their current state.

As designed, this is how the BIOS works: it first runs the POST to check present hardware and minimal functionality, it then has an option to run firmware from any installed PCI cards that need to initialize themselves prior to the system boot, and once control is returned back to the BIOS, it calls up the bootloader in the form of the MBR on disk 0 (or other selected disk).

A hang between BIOS and boot would be caused by either a) the BIOS looking for/trying to load the ROM from a PCI device to allow it to initialize, or b) the BIOS calling the initialization code in the add-on card, and that code taking time as it does its thing before returning control to the BIOS.

Failing that, your BIOS could need an update or your motherboard (one or more of its components, starting with EEPROM chip to the PCI buses) are on their way out.