Lost access to recovery partition after new multi-boot install

#1
Hi,

I have a Lenovo Thinkcentre computer with one single hard drive, Vista preinstalled, and a hidden Vista recovery partition.

I was having Vista-Ubuntu 9.10-Mint 8 triple boot, using EasyBCD when Ubuntu was installed; everything was working fine. After adding another operating system, the general result was lost access to the recovery partition and Windows Boot manager screen switched to a new one.

Details as follow,

Recently installed Fedora KDE 12 for 4-booting, selecting install Grub to the Fedora partition, but the hard drive didn't boot.

By using the Vista Recovery Disc (thanks for that) Vista start-up was repaired, with no existing system found by the disc, and booted up to Vista.

Using EasyBCD deleted-added GRUB 2 (option "Grub isn't installed to MBR" was-is grayed out), being able to 3-boot.

Then updated Ubuntu Grub and Fedora Grub was automatically added to it, allowing 4-booting.

Thus, my system layout is:

/dev/sda
/dev/sda1 7.7GB (Vista recovery). Note: Ticked as bootable
/dev/sda2 70GB (Vista)
/dev/sda3 Extended
/dev/sda5 10GB (my data)
/dev/sda6 1.4GB (Swap)
/dev/sda7 25GB (Ubuntu)
/dev/sda8 17GB (Mint)
/dev/sda9 200MB (Fedora /boot). Note: Ticked as bootable
/dev/sda10 17GB (Fedora /)

By the way, viewing the Ubuntu Grub screen, noticed that the new single Fedora entry was added in between the two current Vista entries, /dev/sda1 and /dev/sda2, rather than chronologically appended, as were all of the others.

So, by choosing Neosmart Linux at startup, the Ubuntu Grub screen shows two Vista options, /dev/sda1, and /dev/sda2, so that:

1. Selecting Vista /dev/sda1, goes to my current Windows Boot Manager screen in English containing two choices: Vista (recovered), and Neosmart Linux.

2. Selecting Vista /dev/sda2, goes to my previous Windows Boot Manager screen in Spanish, containing two choices: Vista, and Neosmart Linux, and access to the Windows memory diagnostic tool.

It can be noticed that the Vista option on path (1) above is tagged as (recovered), while on path (2) it isn't.

I'd really appreciate your help to get back access to the recovery partition, and my usual Windows Boot Manager screen in Spanish.
Thank you very much.
Sheers
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Try EasyBCD 2.0 -> Diagnostics -> Reset BCD

Then recreate all entries?
 
#3
Many thanks for your directions, Guru. Following them, all entries recreated, noticed that Grub isn't installed to MBR continued grayed out. Then, restarted Windows but failed, showing a new Windows Boot Manager screen in English, this time with a failure message, containing the following :

File: \windows\system32\winload.exe
Status: 0xc000000e
Info: The selected entry could not be loaded because the application is missing or corrupt

This new screen does include access to the windows memory tool, as well as the other options the Spanish one does.

Following the instructions on the screen, by using the recovery disc, my language settings chosen, Vista startup was repaired, with the window message being:

The following startup option will be repaired:
Name: Windows Vista
Identifier: {E8709FB6-FASF-11DB-BE4D-E219ECE5282E}
Windows device: Partition=not found

So, booted up to Vista, noticing that Grub isn't installed to MBR continues grayed after deleting and adding GRUB2. Also had to reset Vista time out.

Now, from the Ubuntu Grub screen:

- Choosing dev/sda1 goes to my new screen in English. The new access to the memory tool fails though, showing failure on File: \boot\memtest.exe, Status and Info same as above,.
- Via dev/sda2 goes to my former screen in Spanish; also tryed the memory tool and worked fine.

Besides, access to the recovery partition still isn't possible.

Thus, I've been checking the status of the partitions with Windows Disk Management, having that 7.7GB (Vista recovery), and 200MB (Fedora /boot) are both Active. So, after fedora install, I've been having two active partitions rather than one, other than 70GB Vista as it used to be before. Couldn't be that where the problem is?

By the way, as per Windows Disk Management, the Vista recovery partition isn't recognized by its label "SERVICEV002" any longer, and appears as having no GB usage, while as per other Windows 3rd party partition programs, they still recognize its label, its GB usage, and can be explored.

Thank you very much.
Sheers.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#5
Are you using the latest build.
I suspect not, because of your "greying" reference.
Easy used to "grey" redundant fields, but so many users said "something's wrong - the field greys", that the latest build completely removes all fields which have been made redundant by automation features (grub2 and XP). The information is not needed.
 

mrjag

New Member
#6
Thank you very much for your reply. Thus, I installed current EasyBCD build 82, and repeated steps as per Post #2 above. During startup noticed that the Windows timeout had been shortened.

Once in Vista, tried to view the settings with EasyBCD, but both the program and the computer didn't respond altogether, having to disconnect the PC from the power supply finally. When comparing the two BCD settings, before and after the computer mishap, can be seen that the Windows timeout was changed from 5 to 30 sec, and the then new AutoNeoGrub5.mbr file was switched to AutoNeoGrub0.mbr, besides changes on some identifiers were made, and some other entries were either added or removed.

Also noticed that Windows Disk Management shows Vista (C: drive) as the only active partition (/dev/sda2 from Linux), so the issue with having two active partitions was regularized. :smile:

Now, from ubunt grub 2 screen the Vista paths are:

- /dev/sda1 (Vista recovery) goes directly to Vista, i.e. doesn't go to any windows boot manager screen anymore.

- /dev/sda2 (Vista) goes to my current yet another new windows boot manager screen in English, containing two choices: Vista, and Neosmart Linux, and access to the Windows memory diagnostic tool, where the Vista option isn't tagged as (recovered) anymore, and the windows memory diagnostic tool entry is in Spanish.

So, my current windows boot manager screen is in mixed language, and access to the lenovo recovery partition is not possible yet. :frowning:

What should be the next step?

Many thanks.
 
Last edited: