Lost My Mepis (Linux) Install

#1
Greetings.
I knew it would happen sooner or later and I was correct.

I have been using EASY BCD for quite a while and find it great for dual boots with Windows. I have many problems when adding Linux to it. You all have helped me many times in the past.

Here is the current problem.

I am at work using my laptop now, & do not have access to the desktop (problem) machine right now. I cannot remember which drive is called what. So, my narrative is somewhat generic.

My system hasn't had any hardware changes recently.

Something I was messing with the other day changed the boot order in the BIOS. The result was that I lost my Mepis 8.0.15 install. It is still there, I just cannot access it without the Live CD.

I thought I got the BIOS order back; however, it does not work. Vista & Seven both boot OK==I get the Error 17 when attempting to boot Mepis. I booted Mepis via the Live CD and reinstalled GRUB to Root. I rebooted via the Live CD and copied menu.lst to my Vista drive so that I could access it from Vista. It always saves it as a big glob of words==no formatting at all. PITA.

I have 3 SATA drives.

My boot drive has Vista & 7 on it, with Vista being listed as "System".

Another drive has no OS, just two storage partitions.

The third drive has 4 partitions==3 for Mepis and a fourth for other things.

Remember, I cannot (at this time) tell what the drive identifications are.

I simply cannot remember how getting Mepis to boot last time was accomplished.

I have EASY BCD 2.0 build 78 installed. It worked fine till I messed it up==Not an EASY BCD problem.

I need guidance on the steps to configure NeoGrub & menu.lst.

Specifically, do I copy menu.lst into the NST folder?

Do I need to modify menu.lst in some fashion to reflect where Mepis is?

Do I need to modify the menu.lst in Mepis?

(Getting old is not fun==memory going & hair nearly gone.)

I think that I can do it if I have some general guidance. I cannot locate any help files that cover this situation.

Jerry in Anchorage
 

mqudsi

Mostly Harmless
Staff member
#2
Have you tried to simply add a new Linux entry in EasyBCD?
 

Ric95

New Member
#3
Does the Mepis liveCD have a partition editor ( like gparted )?
From any live cd with that, open the partition manager and find where mepis is located. Check to see if Mepises hard drive is labeled as 'hidden'.
Thats the only thing I could think of.
 
#4
I've Tried

Affirmative on the attempt to re-add a Linux entry==NO GO.

There is some magical, mystical combination of sdx,y & hdx,y that appears to be required in a menu.lst file to make it work. Unfortunately, there is no guidance as to what those entries should be, or how to go about determining them.

I have a dual boot system on my laptop with Vista & Mepis==both on the same drive and that worked flawlessly the first time. There appears to be some real difficulties when using more than one drive in the system. This is where some documentation is needed.

I have had this same problem at least 2 times previously. Both times, I stumbled onto the correct entries. (Although it took many many hours of trying.)

It would be helpful if I could remember the steps==I cannot.

I was actually beginning to get a bit comfortable with Linux, too. Now I cannot boot it.

Here is what I would like: I would like some documentation as to how to add a Linux entry to EasyBCD. If it exists, I can't find it.

What I can find is some steps that say "Configure NeoGrub and it will work". Nowhere can I find how to "Configure NeoGrub".

Nowhere can I find information that gives more than just a hint towards that configuration. The different drive numbering systems used by Windows & Linux also causes confusion. After running GParted from a LiveCD session and determining which drive contains which OS, what do I do with that info? When attempting to copy the menu.lst file to the Windows drive, itisallruntogetherintoonebigsentancethatcannotbeeasilyunderstood.

Enough blowing off steam.

In order to make it work, I need to know about modifying the menu.lst. (At least I think I do.)

1. Do I need any mods to the one in Mepis (Linux)?
2. Do I copy it directly into the NST folder in Windows (without any changes)?
3. Since Windows & Linux designate the drives differently, do I need to account for that when modding the menu.lst file in NST?

It appears that the newest Beta 2 (78) also does some things a bit differently. I was using 78 successfully before I messed up the boot order. I know that 78 works. I know that I caused the problem. I just don't know how to fix it.

Thanks
Jerry in Anchorage
 
#5
Am I blackballed?

Did I offend someone?

Can anyone offer any assistance?

Jerry in Anchorage

Addendum:

Well, I'm back up & running.

I started reading old posts & found the one by Coolname007 (Tutorial) from way back in Nov or Dec 09.

I thought I knew what I was doing, but as we say up here in Alaska, "WRONGO, MOOSE BREATH!!"

What cured my problem was to input the drive location for Mepis (Linux) into the box (the one that requests it) prior to checking the "GRUB not install******" box. I had not been filling in that box. To me, when that box greyed out, I assumed that it didn't do anything. I kind of thought it was like turning on a light and then turning it off just to make sure it was off. Does that make any sense??

Anyway, I feel pretty silly. Course, I feel like that lots anyway.

Thanks for a great product. Please, somebody write a manual.

Jerry in Anchorage
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
#7
Thanks, Terry

Thank you Terry.

Sometimes things just aren't obvious.

I had read the Sticky repeatedly, but it just didn't hit me.

If you open the pic that is referenced in the Sticky, it doesn't show an entry for a drive, either. Actually, it shows that space grayed out==which to me means unusable. I was very confused.

I suspect that being older doesn't help any either, and add to that that I am a commercial pilot who is used to having pretty clear-cut guidance, &, well, you can figure the rest.

I really do appreciate the help of the members such as yourself, and the developers of this program.

Thank You

Jerry in Anchorage
 

Terry60

Knows where his towel is.
Staff member
#8
I couldn't fill in the drive without it obscuring the flag with the dropdown, as in the previous illustration.
It isn't greyed, just omitted for clarity. (seems to have produced the opposite effect !)