Mac OS X doesn't start without keypress

#1
Hi all

This software is great, but, I have one problem.
I have 3 partitions:
  1. Mac Osx
  2. Linux ubuntu
  3. Vista - with active partition
All works, I've add Ubuntu and Mac on the entry menu.
Linux start correctly, but Mac OsX don't, I must press any key, and the menu of Mac Osx appears, and I must choose (hd0,1), because by default, it want start on other partition.
I run "Repair OS X "HSF+ partition error" but, nothing, when I start my PC, Mac OsX doesn't start.
If I don't press on keyboard (any key, not only F8 key) anythings start and return on first menu.
Why ? Could you help me . (but, if I press key , Mac OsX start and works fine)
Thanks :smile:

Scorpio92
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Scorpio, welcome to NeoSmart Technologies.

I'm afraid that though this is a bug, it's not one that is a part of EasyBCD - it's an OS X issue caused by the way Apple designed and implemented the Darwin bootloader.

The only solution ATM is to install OS X as the first OS, then install the others. In that case, EasyBCD will work just fine without requiring to press a key to enter OS X after selecting it in the Vista bootloader.

Cheers.
 
#3
Hi Guru

Tanks for your quicly answer.
But, my Mac OsX is the FIRST Os that I have installed.

I have installed Mac Osx, unbuntu and Vista in this order.

Another thing, another idea for my problem ? :scared:

Thanks

Scorpio92
 

mqudsi

Mostly Harmless
Staff member
#4
Did you re-partition your drive after installing OS X?

Topic Moved to correct location.
 

mqudsi

Mostly Harmless
Staff member
#6
I don't understand - if you formatted your drive after installing OS X, then how is OS X still installed?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#7
CG would be right. If you re-formatted OS X wouldnt be installed and therefor your "problem" is that the OS isnt installed. That is why nothing happens when you try to boot to OS X.
 
#8
No No No !!

I explain you:

I have install Mac Osx, and I've create 4 paritions with hard drive utilities (Mac)
After, I' ve installed Max Osx on the first partition. All works fine, reboot on Mac; OK.
I reboot with ubuntu cdrom, I have formatted second partition with ubuntu hard drive utilities in EXT3, and installed ubuntu.
I' ve added in Grub, the Mac OsX boot...
Reboot , Grub appears with 3 choices:
  1. Ubuntu
  2. Ubuntu recovery
  3. Mac OsX
All works fine. OK ?
After, I 've boot on Gparted Cdrom for change active partition (for vista)
i've boot on Vista CDrom, I format the 3th partions in NTFS, and live the 4th non formatted (for FAT32 in the future)....OK ?
I install Vista, i'ts ok, and install EasyCbd 1.7, for add ubuntu and Mac Osx
I reboot for the ast time, and ubuntu, Vista run parfectly, but Mac Osx, I must press on any key, Darwin menu appears, and I select (hd0,1) for run, else, I I don't press key, the screen become black 2/3 sec, and Vista boot menu appears nex time, and Mac doesn't start.
:grinning: I'ts good ? (sorry for my poor English, I'm French)

Thanks all
Scorpio92
 

mqudsi

Mostly Harmless
Staff member
#9
OK, I get it now.. I thought you meant you formatted the entire drive, not a single partition.

Can you cut and paste the contents of /Library/Preferences/SystemConfiguration/com.apple.Boot.plist here in a
Code:
 tag please?
 
#10
com.apple.boot.plist

Hi all,
So, my com.apple.boot.plist.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
  <key>Kernel</key>
  <string>mach_kernel</string>
  <key>Kernel Flags</key>
  <string></string>
  <key>Boot Graphics</key>
  <string>Yes</string>
  <key>Quiet Boot</key>
  <string>No</string>
  <key>Timeout</key>
  <string>5</string>
</dict>
</plist>
Thanks , Scorpio92
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#11
I don't see the option I was looking for there..

Edit:
OK, this is a confirmed Mac bug.

It'll default to the partition set as active on your disk. So if it's on the same disk as the other operating systems with the Vista bootloader active, it'll almost always display this behavior.

Solution:
Add a new NeoGrub entry. Add this to the bottom of the NeoGrub configuration file:
Code:
rootnoverify (hd[B]x[/B],[B]y[/B])
makeactive
chainloader +1
boot
Replace X and Y with the correct numbers for the OS X partition.
 
#12
Hi..

This is my "Neogrub configuration":

find --set-root --ignore-floppies /boot/grub/menu.lst
configfile /boot/grub/menu.lst

And, I've add :

rootnoverify (hdx,y)
makeactive
chainloader +1
boot

But, no change.... I must press on any key for start Mac OsX correctly.

Another idea ? :tongueout:oint:

Scorpio92
 

mqudsi

Mostly Harmless
Staff member
#13
That's it then :frowning:

People talk about M$ being very anti-competition and no documentation - I've seen the exact opposite, and this is the very embodiment of my observations. Whereas MSDN and support.microsoft.com are completely loaded with information on NTLDR, BCD, and the Windows startup process; Apple makes its living by keeping everything quite.

This is all the info in the world that Apple makes available with regards to the entire OS X startup-boot-shutdown procedures and it doesn't come close to providing the level of information to change this kind of behavior.
 
#14
Thanks for all !

Ok,

I understand, but I hold with you thank largely for all your time spent to try to correct our problem.
And still cheer for this formidable software.
I would be satisfied to press on a key when I would like to start Mac OsX
Many thanks

Scorpio92
 

mqudsi

Mostly Harmless
Staff member
#15
hey, you're welcome!

If I do ever come across an answer to this, I'll be sure to let you know.
 

jayk

New Member
#16
A simple and perfect solution....

Scorpio92, do this:

put the os x installation disc and try to boot from it, press F8 just before it boots and then type -s and hit enter (to boot in single user mode), then just wait for a while till u get the console, then type this :

Code:
$> fdisk -e /dev/rdisk0
$> print
(ur partitions will be printed now with the partition numbers and other details) 
$> flag 1  
(flag is used to mark a partition active, be sure that "1" is the partition number of the OS X partition)
$> update
$>write
$>quit
Now restart ur system and voila! OS X will be ur default OS & u dont need to do that F8 thing!
Warning: be sure that rdisk0 is ur master hard disk (in case u have 2 hard drives), and dont use this technique from OS X terminal application it will screw up ur sys, use it after u boot from the OS X installation DVD!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#17
Hi jayk, welcome to NeoSmart Technologies.

Question: doesn't this also make Darwin the default bootloader (instead of using the Vista bootloader as default?)
 

jayk

New Member
#18
thanx Computer Guru, yes you are right, darwin becomes the default bootloader, but now u dont have to press the F8 key! another solution if u dont want to press the F8 key and dont want darwin as the default bootloader is edit the boot.plist in OS X (/Library/System/Preferences/SystemConfiguration/com.apple.Boot.plist) preferably in BBEdit,

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
  <key>Kernel</key>
  <string>mach_kernel</string>
[B]  <key>Kernel Flags</key>
  <string>rd=diskXsY</string>
[/B]  <key>Boot Graphics</key>
  <string>Yes</string>
  <key>Quiet Boot</key>
  <string>No</string>
  <key>Timeout</key>
  <string>5</string>
</dict>
</plist>
change the part in bold where in diskXsY, X is disk number and Y is the partition number so if u have the os x in the first partition of the first disk it would be disk0s1, if u r not sure about it go to disk utilities in OS X, control click the partition in which os x is installed and select information, here u can find out whats the name (diskXsY) !
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#19
Thanks jayk, I'll definitely add that to the wiki!