MBR is like...destroyed.

#1
Well my MBR is like invisible to my computer. Let me tell you my story in detail.

I was trying to install Snow lep on my PC...didn't really work out...but by doing so, i think it installed a third party boot manager. Now, I went through the setup of SL and everything and it asked me to restart my computer .After the restart, SL just hung at a white screen. I thought it'd be pointless for me to even try to get SL on my pc ...so I boot back into vista, erase the partition that I had for mac. Now...this is where the problem starts. Somehow all of the boot record is gone, when I restart my computer, it says boot0: error (I don't really remember the exact error, but it was very brief..almost like i describe here). Now, I managed to get my hands on a Vista recovery disk from online and I burned it onto a DVD...I tried going through the command prompt in RE and fiddling around with bootsect.exe and bootrec and /fixmbr and the whole nine yards..but it kept telling me that 'Element could not be found' error all the time.

So after trying all the commands, I decided to pull out my XP media center disk that I had lying around. Installed XP on the unpartitioned space...XP is working right now, and I am on it. The problem is, the Vista drive is still there and I want to restore my MBR so I can boot between Vista and XP...but every time I open EasyBCD, it will tell me that my MBR is corrupted, and ask me to fix it...I select the drive where Vista is located and it gives me this error:

Access to path 'bootmgr.exe.mui' is denied. Now BCD starts. Me thinking that I can manually recreate my boot partition, I go in and try to add a manual entry...when I hit 'Add Entry' BCD crashes and gives me unhandled exception.

Right now, my computer just boots into XP...it wont recognize that vista exists.

Help please?

Sorry for posting a long story...just didn't want to leave anything out.

My Specs (Just in case):

Toshiba Satellite A505-S6965
Inte Centrino Dual core
Windows Vista Home Premium x64 Bit

Here is the Unhandled Exception error in detail:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentOutOfRangeException: Index and count must refer to a location within the string.
Parameter name: count
at System.String.Remove(Int32 startIndex, Int32 count)
at (Object , Int32 , Int32 )
at .Invoke(Object , Int32 , Int32 )
at ..(String name, String drive)
at ..(Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
EasyBCD
Assembly Version: 2.0.0.92
Win32 Version: 2.0.0.92
CodeBase: file:///D:/Program%20Files/NeoSmart%20Technologies/EasyBCD/EasyBCD.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
{51e27215-b9a9-4e80-9c87-5ef5f4ca53cf}
Assembly Version: 0.0.0.0
Win32 Version: 2.0.0.92
CodeBase: file:///D:/Program%20Files/NeoSmart%20Technologies/EasyBCD/EasyBCD.exe
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///D:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Open EasyBCD, and go to Install/Repair BCD -> Reset BCD
 
#3
It wouldn't work, it would say its done but it still wouldn't fix the problem. I fixed it though. I downloaded the beta, and there was an option to install a boot record onto a partitioned space. Used it, and it worked like a charm!


Thank you for your help!
 

mqudsi

Mostly Harmless
Staff member
#4
You're welcome :smile:

Out of curiosity: what partitioned space did you install the BCD to?