Mice and other pointing devices, and Network adapters not working

My mouse (also touchpad) isn't working on my laptop on any usb port, but it works on my other computer. Both of them receives a Code 39 (already did the uninstall part;doesn't work), so at the moment I'm stuck at using the keyboard to move the cursor. If i plug my usb flashdrive in any port, it works. (on device manager, they have a yellow exclamation point)

Files for touchpad
C:\Program FIles\Synaptics\SynTP\InstNT.exe
C:\Program FIles\Synaptics\SynTP\Syncntxt.rtf
C:\Program FIles\Synaptics\SynTP\SynISDLL.dll
C:\Program FIles\Synaptics\SynTP\SynMood.exe
C:\Program FIles\Synaptics\SynTP\SynTPCOM.dll
C:\Program FIles\Synaptics\SynTP\SynTPCpl.dll
C:\Program FIles\Synaptics\SynTP\SynTPCpl.dll
C:\Program FIles\Synaptics\SynTP\SynTPEnh.exe
C:\Program FIles\Synaptics\SynTP\SynTPhHelper.exe
C:\Program FIles\Synaptics\SynTP\SynTPRes.dll
C:\Program FIles\Synaptics\SynTP\SynUnstini
C:\Program FIles\Synaptics\SynTP\SynzMetr.exe
C:\Program FIles\Synaptics\SynTP\Tutorial.exe


Same thing is happening for all of my network adapters (code 31) except Bluetooth device (RFCOMM Protocol TDI)

System Restore is out of option
Last edited:


Super Moderator
Staff member
Look at your other thread for troubleshooting the mouse. We'll work on your network adapter issues once thats fixed.
Look at your other thread for troubleshooting the mouse. We'll work on your network adapter issues once thats fixed.
Apparently, I got two HID-complaint mouse (one that has the mouse sys file and the other one has the touch pad sys files) and synaptics PS/2 Port Touchpad. I uninstalled them by going to properies>driver>uninstall for all 3, then I restart my comp. Sorry, but it doesn't work either *sigh*

Anyways, thanks for being active to support me in solving this difficult situation.

edit: Windows Service is off when I logged on.
I wonder if it could be viruses/etc. that could be causing all of this, but it seem my Spybot: search and destroy didn't detect anything. (Note: I can't use Microsoft Security Essentials since most of the anti-virus requires internet for it to be installed and used. Although, I could transfer files to give the anti-virus program its updates if both comp are 32-bits or 64-bits)

Or its possible that I need to do something with regedit to fix the mouse problem.
Last edited:
Just a update on how I'm doing.

I deleted the upperfilter in the mice and other pointing devices folder by using regedit.
In the device manager, the usb mouse no longer have the yellow exclamation point and it appears to be working fine according to its status. (still not working though)

Also i took a look at the hidden files in device manager. It appears my NETBT , QoS packet Scheduler, sptd, Virtual WiFi Filter Driver, and WFP Lightweight Filter are all having an error code of 24
Last edited:


Mostly Harmless
Staff member
Have you tried downloading the latest drivers?