Missing AutoNeoGrub0.mbr - Windows 8.1 and Elementary OS (Ubuntu) 64-bit UEFI

#1
Hi everyone,

This is a continuing issue from the Ubuntu Forums: [Elementary OS] Dual-boot Elementary OS and Windows 8.1 - 64-bit UEFI - the moderator there recommended that I post my question here instead.

I have Windows 8.1 and Elementary OS (an Ubuntu variant), both 64-bit and using UEFI, currently installed on my computer. It boots to Windows first, and then after setting it up with EasyBCD, I get a nice Metro option between Windows 8.1 and Elementary OS. However, selecting the Elementary OS option gives me this error: http://i.imgur.com/DCXZ4FM.jpg (Missing file/contains errors: \NST\AutoNeoGrub0.mbr, Status: 0xc000007b). Pressing ESC and going to the UEFI boot options gives me this screen: http://i.imgur.com/vkjaOal.jpg which allows me to boot into Elementary OS's grub.

This isn't ideal, since it would be better if grub started once the Elementary OS option is picked from the Windows Boot Manager, instead of getting an error and then having to go to the UEFI settings. I would also like to keep the Windows bootloader since it looks much nicer than grub. I have already tried running Elementary's boot-repair with varying results, none of which resolved my issue (and probably destabilized my computer too). I tried switching the indicated drive on Elementary from C:/ to E:/ (which is where Elementary is installed), but that just reset the bootloader entries.

Can someone help me with this? It would be greatly appreciated. :smile:
 

Terry60

Knows where his towel is.
Staff member
#2
Microsoft won't allow the W8 bootmgr to boot a "foreign" system on a UEFI PC with secure boot.
The only way to effect a working dual-boot is to let Grub to take over the boot process and allow it to boot W8.
Remove any Linux entry from the BCD to prevent an unnecessary second menu when you choose W8 from grub.
(Incidentally, you should not alter the disk letter of a non Vista/7/8 BCD entry. It is not pointing at the OS but at the file which does point to the OS)
 
#3
Oh, that's unfortunate. Did this happen recently though? The guide I followed specifically used Windows 8 and its bootmgr. I also have Secure Boot disabled at the moment.

Two questions though: There's two Elementary entries on EasyBCD - the one I added that points to AutoNeoGrub and another one that points to the partition (I think, can't check right now). Should I remove both or just the one I added?

Also, should I make grub the default through EasyBCD or by switching the boot order in UEFI?
 

Terry60

Knows where his towel is.
Staff member
#4
EasyBCD just alters the MS BCD, so cannot effect the boot sequence. Remove both linux entries and just leave the W8 options which MS (and the UEFI BIOS) put there.
Switch the BIOS entry to start at the partition containing grub, and add a W8 entry to the grub menu if it isn't there already.
W8 is very fussy. I have it dual-booted with W7 and the bootmgr is happy to replace the W7 version and offer W7 as an option, but the moment I altered the boot to make W7 default (from W8's own boot options - this is nothing to do with EasyBCD), it immediately blue-screened in the same way as yours, and can only continue to function with secure boot disabled.
That's how it reacts to the presence of it's own (superior) predecessor. Afaik, nothing can persuade it to boot anything other than Windows.
I imagine your guide was referring to a legacy BIOS / MBR installation of W8, which will still function normally.