Missing boot directory, BCD corruption, and more!

#1
I have a Lenovo SL400 running Windows Vista Basic. A few months ago I had to have the hard drive replaced as I was having issues booting/etc. First I cloned the data from the hard drive to another one. Once I received the drive back, I cloned the data to the new drive. However, it now tells me that the bootmgr is corrupted and that there is not BCD file, and things to that accord. When I first purchased the PC I set it up so that in addition to the useless small lenovo service partition there would be two others: one for Windows Vista and one for Linux. I never ended up using the Linux one, so I reformatted it to NTFS and used it as extra storage. However, I had installed Linux and the boot manager for the computer was grub (a linux boot manager). I think this is why I am having this trouble now. I don't know how to get the computer to boot Vista, or install the vista bootloader. I don't see any boot directory in my E drive. I've tried using the recovery CD that this website provides, and I couldn't fix the problem. I've also tried using EasyBCD from another vista computer, and couldn't fix it.

Thanks in advance,
majikstreet
 

Terry60

Knows where his towel is.
Staff member
#2
Hi majik, welcome to NST
Did you boot the recovery CD then "repair your computer" "startup repair" three times ?
It needs to create several things to completely restore the Vista boot and can only do one per pass.
 

Terry60

Knows where his towel is.
Staff member
#4
What exactly are the symptoms of the failure to recreate the boot ?
If you're trying to recreate the bootmgr on a previously functional Vista, where the problem was caused by letting grub replace bootmgr, it should be very straightforward.
If you're getting any kind of indication of disk errors, you could try chkdsk /r on the partition before attempting to repair the boot.
 
#5
I'm not currently experiencing any disk errors that I'm aware of. Right now nothing is recreating the boot directory or BCD file so when I try to boot vista it says: "Windows failed to start .... FILE: \Boot\BCD Info: An error occurred while attempting to read the boot configuration data"


Right now I'm trying to figure out if I can reinstall Grub or another bootloader instead of the vista bootloader, since the vista one doesn't seem to want to work. Any ideas?

[Edit]

Let me elaborate on my system setup: Before I had the hard drive issues, I had three partitions: one Linux partition, one LenovoService partition, and one Vista partition. I believe I installed linux after Vista, and I removed the Vista bootloader from the MBR and installed Grub. Later, I removed Linux from that partition and formatted it NTFS to use as extra storage. I have no idea why grub continued to work, because I had obviously removed its /boot directory. My current situation is that the Vista bootloader is installed to the MBR, but for whatever reason the /Boot directory on the vista partition isn't right. I'm not sure how the computer was originally set up, maybe it was supposed to boot from the lenovoservice partition? Anyway, right now I think the easiest thing to do would be to install an alternate bootloader, but I'm not really sure how to do it.

Right now chkdsk is correcting errors in my disk.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
The "startup repair" from the booted recovery CD recreates the boot files. If it's not doing it, what does it say is the problem ?
 
#7
Now when I try to run Startup Repair from the DVD it says "The exception Priviledged instruction. (0xc0000096) occurred in the application at location 0x73df7e02." Wh
 

Terry60

Knows where his towel is.
Staff member
#8
When you mounted this HDD in the other working PC, did Explorer see it OK (except for the missing boot files) ?
If so, you could try using EasyBCD 2.0 latest build and then diagnostics/ change boot drive (pointing it to whatever letter the other PC sees your HDD as). That will build a set of boot files on your HDD.
DON'T reboot. Change the boot drive back again (if it has changed) to restore the "system" flag on the other PC back to its proper place (make sure you know the right place by checking which partition is marked "system" on the other PC before you start)
When you're sure that the other PC is back as it started, remove your HDD and put it back in your PC, making sure the BIOS boots from it first in the HDD sequence.
The problems you're having getting the recovery disk to work, make me think that you have a more fundamental problem with the clone than just missing boot files. "startup repair" is normally very straightforward and has never failed on the occasions when I've needed it.
 
Last edited:
#9
Yes, the last time I mounted it in another PC Explorer saw it fine. I'm going to try what you said now

Addendum:

Okay, now when I go to boot the "bad" computer, it gives me a menu with two options Windows Vista or Windows Vista Basic (Recovered). I chose the Recovered one, and now I get another error: "File: \Windows\system32\ntkrnlpa.exe" "info: Windows failed to load because the kernel is missing or corrupt".

ugh.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#10
Try the "startup repair" sequence from the recovery CD again, now it's got a BCD to work with.
 
#11
I tried running Startup Repair again, and I get the same error as before: "The exception privileged instruction. (0xc0000096) occurred in the application at location 0x74ab7e02. "
 

Terry60

Knows where his towel is.
Staff member
#12
Are actually getting through the boot, selecting "repair your computer" and "startup repair" before this failure ?
 

JustinW

Super Moderator
Staff member
#15
Repair your computer -> Command Prompt:

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows\

Run a chkdsk /r as well if you havent already and than try startup repair again if needed.