Missing MBR Helper - Win7/Debian

Eck

New Member
#1
I've tried several times to get my dual-boot setup and need some help here.

It's a 2 hard drive setup, Windows 7 on the first sata drive with its hidden system partition doing whatever it does to boot itself up fine and load the rest of Windows 7 from the C drive. I install Debian to the 2nd hard drive, choosing to put grub into hd1,0.

Back in Windows I use EasyBCD beta build 63 to add Linux, select the partition where grub is, and choose that grub is not installed since I have Linux on the 2nd hard drive.

Bootup, choose Neosmart/Linux, and get a "trying floppy (fd0) MBR Helper not found" message.

The Windows choice boots Windows fine.

I tried using Grub instead by having the Debian installer install Grub to the mbr of the first hard drive. That resulted in Grub being able to boot Linux fine, but any combination in the Windows Vista/Longhorn section of menu.lst (root (hd0,0), root (hd0,1)) just came up with a grub message stating that the device I have selected does not exist.

Following that I found that the drives do indeed still exist because I was able to reinstall the Windows 7 bootloader from my RTM DVD by running that bootsect /NT60 /SYS /mbr command and have it boot Windows up fine again. I used bootsect because Windows 7 Startup Repair found nothing wrong with my setup so I needed to resort to using bootsect to overwrite the Debian Grub there.

Wiped Linux from Windows and tried installing it again, grub to the linux boot partition.

I tried EasyBCD again with the same result, and then editing the configuration from the Neogrub section of add/remove and adding root (hd1,0) to the sections. I still just got the trying floppy (fd0) missing mbr helper message out of the NeoSmart Linux bootup.

Now I've emptied the Linux drive again from Windows (Disc Management) so I can try again. I make sure to uninstall neogrub properly. I've got a nice clean default Windows 7 and a RAW partition with no drive letter waiting for my Debian installation (Lenny 5.02 DVD).

I'll tell you that this worked with Vista (using the grub is not installed choice).

I thought perhaps it had something to do with that hidden Windows 7 System partition so I did try giving it a drive letter so EasyBCD could see it. That process did change what was detected on the current settings screen to show the boot drive as M: (what I named the Windows 7 system partition). But neogrub just came up with the same error trying to boot Linux. So I got rid of all that and have no drive letter assigned (as Windows 7 does by default).

So I can use Windows 7 and only boot Windows 7, or I can use Grub and only boot Debian. Obviously not very happy right now!
 
#2
Same Boat

Obviously this isn't much help, but I am in exactly the same boat as you.
Got Windows 7 and Ubuntu installed and when using Vista bootloader to boat windows works fine. When I use neogrub to boot into Ubuntu on another disk - doesn't work.

When I had VIsta installed this worked fine with Ubuntu (neogrub to boot into Ubuntu)

Now when Windows 7 installed and neogrub used to boot into Ubuntu, it can't find ubuntu boot image. But that is because is can't see the device. Running root command in neogrub only shows Windows 7 drive.

Why can I see all my drives from Neogrub anymore?

Using EasyBCD beta 2 build 60
Windows 7 RTM
Ubuntu 9.04 (2.6.28-11)

Any help appreciated,

Cheers,

Paul
 

JustinW

Super Moderator
Staff member
#3
Hello guys,

You should both be using b63 instead of b60. With beta software make sure you've always got the latest build. If checking the grub not installed option doesnt work try it again without, or uninstall NeoGrub, delete the entry, and add a new one.
 

Eck

New Member
#4
My problem is while using the latest beta 63. I tried it without neogrub and deleting and recreating the enties all with no change.

Windows 7 Disc Management sees the other drive fine, showing the changes in it made by the Debian installer. It's just NeoGrub apparently having a problem detecting the contents and, in Grub's case, it too not able to see the existence of the Windows partitions when attempting to get it to boot Windows if it is in the mbr of the Windows (first) hard drive.

So both Grub's, Grub and NeoGrub, are having difficulties with something that is different about Windows 7. With Vista either NeoGrub or Grub could handle things so there was a choice, either using EasyBCD with NeoGrub to boot Linux with its Grub in the partition that Linux is installed on or Linux's Grub installed into the first (Windows) hard drive's mbr. Now neither are seeing what is on the drive they aren't installed on. Since they see nothing there they try the floppy and fail. Well, at least NeoGrub attempts to boot from the floppy. Grub just reports that the drive selected (where Windows lives) doesn't exist.

I suppose the option of switching the boot drive using the bios setup when we want to switch between operating systems is available. Just switch it to the Linux drive booting first, install Linux inserting Grub into its mbr, and use Linux that way. When wanting to use Windows switch the boot drive back to the Windows hard drive and boot up. Don't like it, but I can't see another way.

Sure do miss Partition Magic and Boot Magic.
 

Eck

New Member
#5
Well, the bios switching boot device method just happens not to work with these Sata drives on my motherboard so that was useless for me. Grub doesn't boot from the 2nd hard drive's mbr so the bios just reports no operating system found. Switch back to booting from the 1st drive and Windows boots right up. EasyBCD with or without NeoGrub couldn't boot Linux either.

Tried again with Grub on the first (Windows) drive's mbr and no settings got Grub to recognize that any device existed on the first hard drive. It booted only Linux but couldn't see any drive where Windows was (even though it was booting from it!) So of course I've done that bootsect thing to get Windows back and deleted Linux again. Easy, by the way since I just do a quick install of the standard task without a desktop and just keep trying edits of menu.lst and rebooting to see if it worked. It's not as if I do a long install of the full distro.

EasyBCD got tried again too. Completely useless process as well. Neither EasyBCD itself nor EasyBCD with NeoGrub can locate any operating system over there, just trying the floppy and failing.

I haven't a clue why, if others have gotten this type of setup to work with Windows 7 and its hidden system partition and 2 hard drives, it works for them and not over here and for that other fellow. I suspect we won't be the only folks with this problem though. Windows 7 obviously does something different enough from Windows Vista to mess up this sort of dual-boot.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
Try giving the W7 booot partition a letter, then add your XP entry letting it auto-configure. The code for dealing with the "secret" boot partition was included in build 63 and tested successfully, but has been revealed since, not to work for eveyone.
Guru is working on debugging why it doesn't always work, but taking a step back and "lettering" the partition is a workaround at the moment.
 

Eck

New Member
#7
Thanks for the suggestion. But I had tried giving the Win7 System Partition the letter M. EasyBCD then reads M: as the boot drive instead of C but still cannot boot Linux on the 2nd hard drive whether EasyBCD by itself or with NeoGrub.

And also it is Debian Linux I'm trying to boot, not XP.

I read a suggestion that the Grub in several Linux distros does not always include all necessary parts when installed to the Linux partition rather than the mbr, so to fix that we should use SuperGrubDisc to install Grub again to the Linux partition and then it should work.

I find that doubtful in my case because EasyBCD with NeoGrub was able to successfully boot Linux with Grub in my 2nd hard drive's Linux partition just fine without messing with Debian's Grub installation there when I was using Windows Vista.

There is also a SuperGrub auto-boot cd that just boots the first Linux it finds on any partition. I've burned that and will try that out just to get my Linux installed and going here.

Hopefully the kinks in the armor will be found and fixed shortly so I won't need to boot from a cd to boot up Linux. Assuming this will work (the cd) I do hope I won't need to use it for too long a time.
 

Terry60

Knows where his towel is.
Staff member
#8
Sorry Eck, problem with working on several threads at once. I must have got you confused with another one about XP.
 

Eck

New Member
#9
That's no problem. :smile:

But that SuperGrub auto-boot thing wouldn't even boot from the cd. Just went right into Windows. Used IMGBurn, probably just burned it wrong.

I did try a few things with the System drive visable as M again. It looks like EasyBCD by itself can then recognize the Linux partition as I get the same GRUB prompt that I got with Vista before applying the grub isn't installed choice in EasyBCD. But instead of applying that choice and having it find and load Debian Linux like in Vista, NeoGrub doesn't find things and just gives me that trying floppy error.

I tried the auto-detect boot.ini thing in the Tools menu but that got me nowhere as well so I deleted the old NTloader stuff it created. It didn't even create a boot.ini.

I've deleted the NST folder in M and made the Windows 7 System partition have no drive letter again after removing EasyBCD's entries in add/remove. I figure I'd best get back to square one.

Maybe I'll try to boot with a Knoppix DVD and copy my Debian's /boot/grub/menu.lst to a cdr. I'll replace what gets put into NeoGrub by EasyBCD with a paste of that text and see what happens when I choose NeoSmart Linux at the bootup. After all, Grub can boot Linux (disturbing ONLY Linux) if I put it into the 1st drive's mbr so maybe NeoGrub can too if I give it the same info that Grub was using.
 
#10
Build 63 now and still not working

Hi Guys,

Tried with build 63 but it didn't work. It seems that Windows 7 does something funky to booting when set as BIOS boot disk.

The reason I say this is because I used to have a triple boot system (Windows Vista, Windows 7 and Ubuntu 9.04) I had Vista on a RAID 0 configuration, then Windows 7 and Ubuntu on another single SATA drive. Vista RAID was set as boot disk in BIOS and used EasyBCD installed in vista to put the 3 entries into Vista boot loader. I used the NeoGrub (grub not installed in MBR) option to boot into Ubuntu. This works fine and I was happy.

I recently got the RTM version of Windows 7 and it doesn't have a time limit so I thought I would bite the bullet and get rid of Vista as daily operating system on RAID 0 configuration and run WIndows 7 on the RAID instead and have secondary Ubuntu OS as well.

I thought this would be relatively easy to do as Windows 7 is the same kernel and not much different....but alas it does something weird with booting and puts some random partition at the start if the drive and messes everything up....

Guess we're just going to have to wait and see if someone very clever and nice like Computer Guru manages to work out whats going wrong and fix it.
 

Eck

New Member
#11
Yep, we need gurus! I can't figure it out. Even giving NeoGrub the same info that's in /boot/grub/menu.lst didn't work. I still got that trying floppy message and no Linux bootup.

Hmm. I wonder if I can type into Debian's installer instead of (hd1,0) a floppy? I suppose I'd have to mount the floppy first which would likely force me to leave the graphical installer environment and mount it first. Then type in there /dev/flp0 I guess. Unless it would already get mounted if I have it in there when starting the install. Then boot from the floppy to get into Linux.

You KNOW Microsoft did this on purpose. I wonder how many newbies who discover that Grub can't boot Windows and Windows can't boot Linux are even going to bother any further with Linux?

I'm not bothering with the stupid floppy disk. That's for the stone age. I'm just totally peeved right now.

Addendum:

Hey hey! Happiness, sort of.

I used a SuperGrub cd to boot Linux for me using their "Indirectly Boot Linux" choice in the help section. So when I want to boot to Debian I boot up with SuperGrub cd, choose the English Help, navigate through the Linux help until I get to that option and click on the /boot/grub/menu.lst choice. Boom! Debian's Grub takes over and does what nothing else can so far. It boots up from my Linux partition on the 2nd hard drive.

For Windows, just boot normally. For Linux, insert the SuperGrub cd.

Not elegant and I really hope not needed for too long.

I installed Debian testing (after the initial install from the Stable DVD) and I'm rocking in KDE 4.2.4. Since I installed the NVidia driver from their unstable repo (the only thing I mix in from Sid), I was greeted with KDE 4's Desktop Effects (like what Compiz would offer) by default. Lots of other experiences but this isn't the place. :smile:

Maybe see what SuperGrub does to be able to see what's on the other hard drive (since NeoGrub can't at this point) and it'll help fix whatever the problem is with EasyBCD? Just guessing.
 
Last edited: