Missing Operating System

aria

New Member
#1
A few days ago I installed EasyBCD 1.7.1 so I could try to boot into Ubuntu, which I haven't been able to do since I installed it. I'm using Vista Home Premium and after setting up the Ubuntu in the boot menu with EasyBCD I restarted and tried getting into Ubuntu. When I tried to boot into it I got an error message, something like Error 26: Disk not found. After this I just went into the Vista/Longhorn option and was able to boot from there. So I deleted the Ubuntu on in EasyBCD and tried again, but this time not only did I get the error in the Ubuntu selection, but it wasn't able to find the Vista option either. Then I restarted the computer and am now getting either a "Missing Operating System" or "Operating System Not Found" error.
I then tried to boot from the Vista disk to try to use the Startup Repair function or to manually fix the bootloader, but the computer doesn't show any operating systems to select and I can't find anything to select.
 

mqudsi

Mostly Harmless
Staff member
#4
That's OK - you just need to launch the command prompt, no need for it to locate an OS in that list.
 

aria

New Member
#5
Ok, thanks, I'll go try that

Addendum:

Ok, so I went into the command prompt and it brought me to X:\Sources and I started doing the manual recovery steps.
The 'bootrec.exe /fixmbr' worked fine, but the 'bootsect.exe /nt60 all /force' didn't. I got an error message that said "bootsect.exe is not recognized as an internal or external command, operable program, or batch file."
Then I tried the next thing, 'bootrec.exe /rebuildbcd' which showed that it identified one windows installation in C:\Windows but when i tried to add it it said "The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted"
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Run
Code:
chkdsk /f c:
 

mqudsi

Mostly Harmless
Staff member
#8
Sorry, that was a typo!

Post updated.
 

aria

New Member
#9
It said that Windows checked the file system and found no problems. And then it said 'Failed to transfer logged messages to the event log with status 50'.
 

mqudsi

Mostly Harmless
Staff member
#10
It sounds like your MBR may have been somehow damaged.

If you type in
Code:
C:
dir *
Do you get the contents that you know are in drive C: (no more and no less)?
 

mqudsi

Mostly Harmless
Staff member
#12
It sounds like you've somehow lost your partition :S

Grab yourself a free copy of GParted and check if your partitions are all still there, in the correct order and with the right (more or less) size and free space available:
GParted -- LiveCD
 

mqudsi

Mostly Harmless
Staff member
#14
No problem.

Good luck :smile:
 

aria

New Member
#15
Actually, I saw that I could use a flash drive to do it but I can't figure out how to make the CD version into the USB version.

Addendum:

ok, I downloaded GParted and booted into it and started it up and its showing my Vista partition, my Ubuntu partition, and another smaller one that I'm not sure what it is.
 
Last edited:
#16
I think it may be as simple as you having the wrong partition set to be booted from. In gparted make sure the windows partition is set as boot.

Addendum:

you can also try using ultimate boot cd to repair the mbr. my favorite program on the cd is testdisk in partition tools
 
Last edited:

aria

New Member
#17
ok, ill check that out in gparted, thanks.

Addendum:

hmm, I can't find where to check which partition it has set to boot from, where would I find that?

Addendum:

Ah, so I deleted my Ubuntu partition with gparted and then booted up in the Vista cd and ran system restore and everything looks like its working fine now.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#18
Welcome to NeoSmart Technologies, chedder. I think I'm going to have to take another look at UBCD and see what utilities we can take advantage of in the documentation. (what a coincidence though, testdisk by CG security is one of my favorites too! :grinning:)

Aria: That's great news. It seems like creating the Ubuntu partition may have either set it as the primary partition or else screwed up the order of your existing partitions.
 
#19
Wipe and Erase

Hi to all,

I have a Sony Vaio laptop and I opted to chose Wipe and Erase because I wanted to have a clean slate.

I used the first recovery disc, after finishing I clicked OK, then took out the cd. I opened my laptop and it said that OPERATING SYSTEM NOT FOUND, close it. then inserted the 2nd cd, but nothing happened when I opened it again and still OPERATING SYSTEM NOT FOUND.

As I write this, it has been 24 hours but nothing happened. Later on, I will try to open it.

PLEASE HELP ME I WOULD KILL MYSELF IF ANYTHING HAPPENED TO MY LAPTOP.

PLEASE HELP ME.

Addendum:

Hi to all,

I have a Sony vaio laptop.

is there a way to downgrade from vista to XP?

also is true that all XP Operating system will be replaced by vista?

Please help me.
 
Last edited: