Multi-Boot Nightmares

Hi, new to the forum and wondered if I could beg some help.

Yesterday I create a clone of my Windows 7 partition for beta testing, using Norton Ghost to copy my existing Windows 7 partition onto a completely new and unformatted drive. Everything ran fine. I may have also ticked the box which instructed Ghost to copy the MBR to the new drive (I don't recall for sure), but for some reason I now have a completely messed up boot situation which I desperately need to try and resolve.

Basically, after I added the newly created Windows 7 partition to the BCD (using EasyBCD) I tried a reboot, and selected the old, original Windows 7 partition to boot into. The system got to the point where I would normally expect the login screen to appear, and I got a black screen with the error:

"autochk program not found, skipping autocheck"

Followed by a blue screen. This happened everytime I tried to boot into the old partition. As far as I was aware, nothing on this drive should have been changed, this is my original Windows 7 partition.

So, I rebooted and tried to boot into the newly created Windows 7 partition - this worked fine, except that, according to Explorer, I'd actually booted into my original Windows 7 partition! I could see that changes I was making on the desktop were appearing in my old system drive (Drive C) and not in the new one (Drive H). When I checked in Disk Manager, Drive H (the new partition) appears to be the active drive - it has 'Boot, Page File, Active, Crash Dump etc.' visible in the disk management GUI for that partition, but no changes are being made to that drive.

So, bottom line, I seem to have arrived at a situation where booting into my old partition doesn't work - I get the autochk error. Booting into the new partition seems to perhaps be using the MBR on the new drive, but actually loading the old OS. I can't delete either volume because they appear to be mutually dependant, and I can't find a way to straighten things out.

I've tried using the Windows 7 Startup Recovery, but this just results in only the new partition being bootable, which in turn appears to actually load the old OS, as described above.

Is there any way of fixing both MBR's on both drives and whatever else needs fixing, on both drives, so that I can at the very least boot into my original partition and delete the newly created one?

Sorry if the explanation above is confusing - I'm not sure I totally understand the situation myself.

Thanks in advance for any help.



Knows where his towel is.
Staff member
Firstly, check the BIOS boot sequence to make sure you're booting the HDD you think you are.
(If you disconnect/reconnect HDDs to do safe independent install to a new drive, the BIOS boot sequence will reset, and will need to be manually set back the way it was.
Secondly, make sure that your partitions have unique volume labels for the same reason.
Disk letters change between OSs (unlike volume labels) and you can become confused about which system you're actually looking at. (When booted my W7 is C: and sees Vista as I:, whereas if I boot Vista, It is C: and W7 is I: In either case they're labelled "Windows 7 System" and "Vista System" so no confusion exists.
After that, post a Disk Management screenshot and copy/paste the EasyBCD "view settings" text.
The sticky thread will advise how to do that.