multiboot issues on USB flash drive

#1
Hello, I am trying to make myself a flash drive with multiple booting options like digiwiz miniPE-XT, Hiren's boot CD or Ultimate Boot CD. miniPE seems to be working when the flash is formatted and has NT loader in MBR (via PEtoUSB utility). I also tried GRUB but there is some strange problem when starting miniPE - it flashes "please wait while minPE is taking control" or something like that and then the computer restarts. I have been tinkering with bcdedit and vista boot loader all day just to get the same result :smile:
I have used EasyBCD's prepare external disk function to install bootmgr, but that WinPE still does not work (it is based on XP PE not Vista)
That's my BCD setup
Code:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=J:
description Windows Boot Manager
locale en-us
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {18a61c7b-fe18-11de-9fc1-001fd09ab099}
resumeobject {18a61c7a-fe18-11de-9fc1-001fd09ab099}
displayorder {466f5a88-0af2-4f76-9038-095b170dc21c}
{18a61c7a-fe18-11de-9fc1-001fd09ab099}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
resume No
Windows Legacy OS Loader
------------------------
identifier {466f5a88-0af2-4f76-9038-095b170dc21c}
device boot
path \minint\SETUPLDR.BIN
description digiwiz miniPE-XT
Resume from Hibernate
---------------------
identifier {18a61c7a-fe18-11de-9fc1-001fd09ab099}
device partition=C:
path \Windows\system32\winresume.exe
description Windows Resume Application
locale en-us
inherit {1afa9c49-16ab-4a5c-901b-212802da9460}
filedevice partition=C:
filepath \hiberfil.sys
debugoptionenabled No
I don't really get why the id of "Resume from Hibernate" is the same like the one of "Windows Boot Loader" :-\

Anyway, do I have it right? The flash drive is 32GB SuperTalent pico and is formatted as NTFS. MiniPE fails to start but as I said it worked with just the NT boot loader.
I also used
Unetbootin which uses syslinux, but it seems to fail to overwrite vista MBR so it does nothing :smile:

Another question: is there any way to use bootmgr to load Hiren's boot cd? It uses some boot.gz file to boot and it seems to be working only with GRUB. Thank you for any ideas.