Multiboot Ubuntu 10.10

#1
I have installed Ubuntu 10.10 and followed exactly the EasyBCD instructions for 10.04 which previously worked for me on this laptop. Now when I select the Ubuntu boot choice I get the message 'Windows failed to start' with message 'The selected entry could not be loaded because the entry is missing or corrupt'. The file name is '\NST\AutoNeoGrub4.mbr'. EasyBCD hasn't picked up the Grub stuff at all, I guess. Any ideas?

Addendum:

BTW, I'm running EasyBCD 2.0.2.117

Addendum:

And here's my Ubuntu entry details:

Entry #2
Name: Ubuntu
BCD ID: {d6af241c-b90c-11df-8884-fa0df68ad8a5}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub4.mbr
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
You see "Windows failed to start" ??
were you using the Linux tab or the Windows tab in "add new entry" ?
did you select grub2 from the dropdown ?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#5
Can you post a Disk Management screenshot and copy/paste the whole text output of EasyBCD "view settings" in detailed mode.
(how-to details in the sticky)
 
Last edited:
#6
The Disk Management screen is attached. Here's the View Settings detail.
---------------------------------------------------------------------------------------------------
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume1
path \bootmgr
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {d6af2419-b90c-11df-8884-fa0df68ad8a5}
resumeobject {72a33e32-b8c1-11df-97f2-806e6f6e6963}
displayorder {d6af2419-b90c-11df-8884-fa0df68ad8a5}
{d6af241c-b90c-11df-8884-fa0df68ad8a5}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
displaybootmenu Yes

Windows Boot Loader
-------------------
identifier {d6af2419-b90c-11df-8884-fa0df68ad8a5}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 Home Premium
locale en-US
recoverysequence {d6af241a-b90c-11df-8884-fa0df68ad8a5}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {72a33e32-b8c1-11df-97f2-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier {d6af241c-b90c-11df-8884-fa0df68ad8a5}
device partition=C:
path \NST\AutoNeoGrub4.mbr
description Ubuntu

 

Attachments

#7
Any thoughts or ideas on what I might do? One possibility is to ditch EasyBCD and just go with the Grub menu which is ugly but at least works. What would be the disadvantage of just using Grub?
 

Terry60

Knows where his towel is.
Staff member
#8
Is there a reason why your recovery partition is active ?
Does your OEM use a customized boot menu to access the recovery ?
 
#9
Is there a reason why your recovery partition is active ?
None that I know of
Does your OEM use a customized boot menu to access the recovery ?
No, I think Toshiba uses a booted recovery DVD
 

Terry60

Knows where his towel is.
Staff member
#10
In that case, check whether a \boot folder and bootmgr file exist on C: (set folder options to see them)
If they do, set C active and reboot, then delete/add the Ubu entry again.
If they are not on C, but hidden on the recovery partition, use EasyBCD > BCD Backup/repair > change boot drive and point it to C when it asks.
That will copy the boot files to C and set it active.
Then do the Ubuntu stuff again as above.