Multiboot Win 7, Win XP

glaus mauch

New Member
Hi

I have installed Win7 x64 on the internal HDD of my NB and clones of Win 7 x86 and Win XP x86 on a external ESATA drive each System on a single Pratition.

Internal drive: Win7 x64
external drive: 2x cloned Win7 x86, 2x cloned WinXP x86

My Problem is that only one of my in Win XP boots when I select XP (1) it loads XP (1) but when I select XP(2) it boots XP(1).
I testet that by leaving a txt document on the desktop with the current Win name.


There are a total of 5 entries listed in the bootloader.

Default: Windows 7 x64 intern
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7 x64 intern
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows 7 1
BCD ID: {6f26bc38-b985-11df-a3b0-002314c6be0c}
Drive: E:\
Bootloader Path: \Windows\system32\winload.exe

Entry #3
Name: Microsoft Windows 7 2
BCD ID: {6f26bc43-b985-11df-a3b0-002314c6be0c}
Drive: G:\
Bootloader Path: \Windows\system32\winload.exe

Entry #4
Name: Microsoft Windows XP 2
BCD ID: {6f26bc44-b985-11df-a3b0-002314c6be0c}
Drive: C:\
Bootloader Path: \NST\easyldr2

Entry #5
Name: Microsoft Windows XP 1
BCD ID: {6f26bc46-b985-11df-a3b0-002314c6be0c}
Drive: C:\
Bootloader Path: \NST\easyldr1
I hope there is a solution for my little problem ^^
 
Last edited:

glaus mauch

New Member
Hi

The Problem seems to be EasyLDR that directs me to the wrong partition. Is there any way to check this?

greetz glaus
 

Terry60

Knows where his towel is.
Staff member

glaus mauch

New Member
Yes I did read all that ^^, as you can see in my attatched config, I used the there mentioned EasyLDR methode to add the WinXP copies. That should do it if i got that right. But it seems not to work for me.

Any ideas whats worng? Or may the cloned WinXP be the problem here?
 

glaus mauch

New Member
Problem Solved

I had to use the autodetect function to get my WinXP entries after checking the boot.ini I found out that autodetect did one big mistake it writes the Partitioninformation from the last "installed" (i just restored a clone) WinXP for all enties.
The bootfile looks like that than:

; This boot.ini was automatically generated by NeoSmart Technologies' BootGrabber.exe
; Use EasyBCD from Download EasyBCD 2.0.2 - NeoSmart Technologies to manage your bootloader

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(5)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Windows XP on F:\Windows XP 1" /fastdetect
multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Windows XP on H:\Windows XP 2" /fastdetect
multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Windows XP on I:\Windows XP 3" /fastdetect
Than i just needed to correct this in the boot.ini and now all WinXP clones start like a dream.

corrected entries
; This boot.ini was automatically generated by NeoSmart Technologies' BootGrabber.exe
; Use EasyBCD from Download EasyBCD 2.0.2 - NeoSmart Technologies to manage your bootloader

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(1)partition(5)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Windows XP on F:\Windows XP 1" /fastdetect
multi(0)disk(0)rdisk(1)partition(4)\WINDOWS="Windows XP on H:\Windows XP 2" /fastdetect
multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Windows XP on I:\Windows XP 3" /fastdetect
This may be a bug in easyBCD so check this, please.

Thanks for all your help and for this great bootloader!
 
Top