Multiple Boot loaders GRUB AND Windows Loader

#1
I tried to use Easy BCD to solve a problem.

My problem was that I installed UBUNTU 9.10 on the same drive that 9.04 was on previously. (The 9.04 installation was not working when the option to load it was taken from the Windows 7 loader page.)

Now I get a GRUB loader which, when I take the option for Windows 7 takes me to the aforesaid windows loader ( the Ubunu option still does not work). The OS are installed in separate SATA drives. Obviously i would prefer just one boot manager to load at startup.

I could not install EasyBCD v 1.72 so I have now tried BETA V2

It installs but gives me a message that the boot configuration store could not be opened, the system could not find the file specified. It goes on to give me the option of manually loading a BCD registry to manage. See attached snip.

Is EasyBCD the correct tool to use to correct my problem? If so how can i get it to work?
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
EasyBCD looks for the BCD in the "active" partition. (where it resides when it's in control)
Point it to the BCD inside the boot folder on your W7 partition, and when it opens remove the unwanted Linux entry. (leave Windows 7).
The second menu won't be presented if there is no choice to make.
That leaves grub2 in control of your boot. (you failed to override the Linux default behaviour when you installed 9.10, so it's taken over the MBR)
If you want W7 to be in control, you'll need to use EasyBCD 2.0 latest build / Manage Bootloader / Reinstall Vista/7 bootloader, then reinstall grub to the Linux partition bootsector (not the MBR).
 
#3
Further problems

Many thanks for you assistance on the multiple loader problem. It worked nicely.

I have another HD related problem.

When booting, I get the attached screen showing PRIMARY MASTER HARD DISK ERROR.

It happens intermittantly and, when F1 is taken, the computer boots normally but very slowly into Windows 7, normally fast into UBUNTU.

I have CHKDSK'd the windows 7 drive which shows it to be "clean"

I know the active drive is the ubuntu drive but which drive is the PRIMARY MASTER HD so i can check it or arrange for its replacement?

ps. being a UK expat here in the Bahamas, I do miss an nice scone n' lurpak butter
 

Attachments

Terry60

Knows where his towel is.
Staff member
#4
You appear to have the BIOS HDD boot sequence wrong.
Put whichever one is controlling the boot top of the list.
It seems to be searching the SATA2 disk in vain and then skipping on.
 

Terry60

Knows where his towel is.
Staff member
#6
Are you looking in the right place ?
Phoenix BIOS has a tree structure. Device type first, then nested pages for individual devices within that device type. Disk 0 being your F: drive in DM indicates that you've got it before the other HDDs in that secondary boot layer.
 

Terry60

Knows where his towel is.
Staff member
#8
Wierd !
I've seen W7 DM transiently display a HDD other than the boot disk as disk 0, but not consistently.
I don't know if that's why it's an intermittent problem, or if its a grub2 bug.
You could always reinstall grub to the Linux boot sector, and put W7 bootmgr in charge.
 
#9
can you please direct me to instructions to reinstall grub to the Linux boot sector and put W7 bootmgr in charge?

thanks for you patience and help
 

Terry60

Knows where his towel is.
Staff member
#10