My First Dual Bool Almost Right ....

#1
Dual booting Win7 / Fedora 12 each on their own drives. EasyBCD 2.0 build 76.

Every worked correctly except when the Linux partition tried to boot I got error messages and complaining of NTFS partition but I got to the grub4dos menu.

Looking at the first line was hdr(0,0) but should have been hdr(1,0) so I edited that line and booted fine. After that I changed grub.conf and fix the error there as well. Not sure what when wrong and I double checked boot partition during the install.

It seems like this is a Fedora install issue not EasyBCD.

Addendum:

Just wanted to clarify something in case some reads this. I was typing very late and I meant to day "root (hd0,0) should have been root (hd1,0)". I used the wrong grub syntax above.
 
Last edited:
#2
When you edited grub was there a note at the top about running update grub or something similar?
I've only experienced Ubuntu and Suse, but in the past I have had to run update grub after editing the file.
hth
Mike
 
#3
I did not have to run grub after the edit but I know what you are talking about. I have not used Linux or Unix for a long time but I remember having to do that in the past.

Here is what the header looks like in FC12 grub.conf

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_mycomputer-lv_root
# initrd /initrd-[generic-]version.img

Addendum:

BTW, maybe I was not clear, but once I fixed the pointer to (hd1,0) the system works fine. For some reason FC12 install made the entry (hd0,0) even though I told it I was booting from the other drive.
 
Last edited: