My mistake - but PC now inaccessible - please help

#1
Hi.
I started with a disk with a recovery partition and win 7
I added XP
Loaded .net and BCD
And bcd ran ok and system auto restarted into XP
I then deleted both the refs to 7 and xp in the BCD control panel
Added 7 and xp (I probably did the WRONG thing here and put xp on d: (where the auto option puts it on c)
And then did the change MBR instruction.

Result
XP won't load - I get the: use install disc/ restart/ language/ next / repair computer message with file \nst\ntldr status 0xc000000f
And my install disc (which is in an external cd drive) doesn't run

And 7 won't load - it starts to - but I get a blue screen flash and then a restart
(I have no win7 media - the files are on the disc somewhere)
My win7 recovery cd won't load - specifically - the one I created from within my install.

However the win 7 recovery cd created by downloading an iso from here Download Windows 7 System Recovery Discs The NeoSmart Files did run - but ended with message "startup repari cannot repair this computer automatically" - I noticed that it saud in teh details - signature 7 - MissingOSloader

NB I DO get the option of running command line - X:\windows\system32> but I don't know what to do here.

Also I AM able to get into the options presented by my Partition Wizard Boot CD which shows disc 1 as having:
PQservice: 12GB. Status none. Type primary (the recovery partition I think)
Acer: 145GB: Status: Active. Type primary (my win 7)
no label: 140GB. Status : none. Type primary (my XP)
plus 10MB of unallocateed space
Using this Boot CD
...I tried 'rebuild MBR now'... AND I still get the windows 7 trying to start for 2 secs, flash of blue, then recycle back to start...
I tried repair boot ini - but no change

I can see that my boot.ini is now on C (the win7 partition) and not D - can I move it to D, create it on D, delete it from C?

Is there a way out of this?
Can I start BCD from a boot disc and undo what I've done?

Thank you
 
Last edited:
#3
Thank you - but I'm not winning

bootrec.exe /fixmbr

IS FINE

x:\boot\bootsect.exe /nt60 all /force,
or as I have tried it
x:\bootsect.exe /nt60 all /force

Where x is either a usb stick or the cd drive with bootsect.exe in it and I have confirmed I am looking in the correct place by ising dir x:but I get the message "the subsystem needed to support the image type is not present. Am I supposed to burn an iso disc with bootsect.exe on it?

Just tried that - iso cd no good.

Please can you tell me why I cannot run bootsect.exe - I am definitely in the right place and have all the spaces etc in teh cmd intact


Even though this wasn't working, I tried the next step
del C:\boot\bcd
bootrec.exe /rebuildbcd

Which obiously did something cos this time the command said there was a windows system it could see (Previously when I ran this cmd it saw none).
Alas on restart no I only see the win 7 system and it crashes within 2 secs of booting up.

I'm trying with your recovery cd again...

no joy

Addendum:
Fixed it using XP recovery console
Never did manage to get the instructions given to work though...and the win7 partition seems completely dead.
Will now save an image of the XP partition and restart from image of whole disc.
Lesson learned!
 
Last edited:
#4
One possible problem is that since you are in the XP partition last, the XP partition may be active. If that is the case there is no way Windows 7 will boot. I suspect that the Windows 7 partition needs to be active. There’s a slight possibility that the hidden recovery partition should be active, but I doubt it.

One way to check this is to download and make a Ubuntu install disc and run it in live CD mode so it does not install anything. Run the Gparted Linux partition editor from it (system, administration, Gparted) to see which partition is active. From the graphical partition screen the partition that is active will be listed as the boot partition in the upper far right under flags.

Alternatively you can Make an Ultimate boot 5.0.3 disc which also has a similar partition editor on it.
http://neosmart.net/forums/showthread.php?t=7636


In hindsight, if you had made the back half of the hard disk as an extended partition and made a logical partition within the extended partition for Windows XP, then the XP partition could not become active. XP would have installed its boot files in the Windows 7 partition.

If all else fails you can follow the procedure below to reinstall Windows 7.

How do I reinstall the Operating System on my computer? Acer
http://acer.custhelp.com/app/answers/detail/a_id/2631

One possibility is that they hidden recovery partition is causing the Windows 7 recovery CD to not function. I’m not going to recommend this I’d be curious to see if one deleted the hidden recovery partition, if that would allow the Windows 7 recovery CD to function correctly.

Before one starts doing the multiple partition multiple OS thing, it is best to get a backup. The program below can backup the entire hard disk and burn it down to DVD blanks. It also allows you to make a DVD restore self booting disk to run the restore from. It only backs up the data on the hard disk, not the entire hard disk and it uses compression. It can backup whatever’s on the hard disk regardless of what OS’s they are.

Macrium Reflect Free 4.2 build 3141
http://download.cnet.com/Macrium-Reflect-Free/3000-2242_4-10845728.html?tag=mncol;1


“Loaded .net and BCD”
And BCD ran ok and system auto restarted into XP
I then deleted both the refs to 7 and xp in the BCD control panel
Added 7 and xp (I probably did the WRONG thing here and put xp on d: (where the auto option puts it on c)
And then did the change MBR instruction.”

I wouldn’t recommend deleting any entries in Easy BCD unless you don’t want to boot into the OS anymore. Also while it should work either way, if you have Windows 7 at the front of the drive, I would run Easy BCD from Windows 7 rather than from Windows XP.