Need help getting past Fedora 16/Windows 7 dual boot issue

#1
Hi --

I'm trying to add Fedora 16 to a Dell Precision M6500 laptop that already has Windows 7 64-bit installed. I had forseen the need to do this and left some free disk space on one of my three internal drives (2 solid state and one SATA). The Fedora 16 installation goes off without a hitch and is clearly installing about 1225 packages that include the Windowing system I requested. I chose to do a Custom Layout and set up an 8GB swap partition and a 180GB ext4 partition for Fedora 16. After installing the Fedora distro, I went back into Windows and used Easy BCD to set up the dual boot menu. I chose grub2 for the linux entry I added, but was not able to specify the partition information (it informed me it would be automatically configured). It has produced the following entries, which I suspect is wrong:


Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume2
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {079b397c-5494-11e0-a713-a409df4d3db0}
resumeobject {079b397b-5494-11e0-a713-a409df4d3db0}
displayorder {079b397c-5494-11e0-a713-a409df4d3db0}
{079b398a-5494-11e0-a713-a409df4d3db0}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
displaybootmenu Yes
Windows Boot Loader
-------------------
identifier {079b397c-5494-11e0-a713-a409df4d3db0}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {079b397d-5494-11e0-a713-a409df4d3db0}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {079b397b-5494-11e0-a713-a409df4d3db0}
nx OptIn
Real-mode Boot Sector
---------------------
identifier {079b398a-5494-11e0-a713-a409df4d3db0}
device partition=C:
path \NST\AutoNeoGrub0.mbr
description Fedora 16 Linux



In particular,I suspect the path in the Fedora 16 entry because during Fedora installation I chose not to use a master boot record, but to place the loader on the first sector of the drive. I'm a total Linux newbie (this is absolutely my first time dealing with it at all), so I of course could be wrong about all of this. But wondering has any ideas on how I can diagnose this problem and fix it.

Incidentally, what happens when I choose the Fedora boot from the boot menu is that it simply boots up to a Grub> prompt and doesn't apparently load much more than that. Among the Grub commands it informed me I could use was Boot, so I tried that but got a message back saying Kernel wasn't loaded. When I tried Kernel, it wanted a path name.

Any help would be greatly appreciated. Thanks.

Mike
 

Terry60

Knows where his towel is.
Staff member
#2
Are you using the latest available EasyBCD ?
Fedora and grub2 issues have been recently addressed.
 

mqudsi

Mostly Harmless
Staff member
#3
It sounds like when you opted not to install GRUB2 to the MBR, you did not install GRUB at all.
EasyBCD searches for the GRUB2 loader file. In 2.1.2 and for Fedora 16, the paths it searches are /boot/grub2/core.img and /grub2/core.img (on a separate /boot/ partition).

This could be either a bug in the Fedora setup (we've seen this before with Ubuntu, many, many times) or a problem with the options that you chose during setup.

Install Fedora again, use the default MBR options, and allow it to write to whatever it wants. You can fix that very easily with EasyBCD's BCD Deployment option to write the BCD MBR back to the disk.
 
#4
You know this actually makes a lot of sense. Because one of the things that I observerd during this entire ordeal, was that when I went to install Fedora 15, to see if that would work, on the Fedora screen that allow one to choose where to put the boot loader, beneath the buttons that activate the dialogs for choosing there was a list with an entry and a path that referenced where the boot loader was going to be. I ultimately switched back to Fedora 16, because with Fedora 15 I encountered a geometry error that seemed even less likely that I was going to be able to solve, given my complete Linux neophyte status. But when I install Fedora 16, I don't see this list, which lends credence to the idea that the boot loader is not being installed at all.

So I will follow your advice above and choose the master boot record option, but with ignorance comes paranoia and you're pretty sure I'm not going to hose my Windows installation in the process (because it represents a tremendous amount of effort at finding the minimal set of services that can allow me to use the machine but still provide no disk activity while I am using the Cubase sequencer program; I would hate to have to go through all of that again)?

Thanks again for your help.
 

mqudsi

Mostly Harmless
Staff member
#5
1) BACKUP, BACKUP, BACKUP. Always. Even when not doing something dangerous. There's tons of free software out there, and until recently, 1TB drives were for under 70 dollars. No excuses.
2) You won't lose your Windows. You *might* lose the ability to access it, but that's something entirely different and easily remediable.
 
#6
Fair enough. I have a backup device, which I was being too lazy to use. So you have accessed the better man in me and I will first go do a Windows backup before anything else. Then I'll try again and be back probably about forty-five minutes to report the results. I probably can't thank you enough times, so this will just be another thanks on the pile. (Actually I just went and made a $20 donation; that's probably better thanks anyway).
 

mqudsi

Mostly Harmless
Staff member
#7
Thank you.
 
#8
I believe the problem is that grub is not seeing my drive.

Hi --

After a bit more exploration and several more attempts to install Fedora 15 and Fedora 16, I think I may have discovered what my problem is. I actually have four drives in my Dell Precision M6500 laptop. There are slots for 2 internal SSD drives as well as a third SSD Minicard. Finally, I have installed a fourth SATA drive that I put into my DVD drive caddy, moving my DVD to an external enclosure. I also have this set up for ACHI. It is the fourth drive (the one in the DVD drive caddy) that I am trying to install Linux on. When I run both the Fedora 15 and Fedora 16 installs, they both see all four drives and let me create partitions and install the OS onto the drive I want. Also when I boot back into Windows both the Windows Drive Manager and EasyBCD see these partitions and recognize that Linux is installed on them. But when I try to boot into the Linux install, however, I always just get put into the grub utility. I recently learned about the Grub Find command and when I issue it, it only reports three drives. Moreover, when I issue the root command passing as paramaters (hd0,0), (hd0,1), etc., it recognizes only three drives and from those that it reports back on, it sees only NTFS partitions and I can see from these that it is only seeing the three SSD drives. So I think the install has been going just fine all along, it's just that grub doesn't ssem to be able to see the fourth drive that I need.

Does this seem plausible, and if so, is there anything I can do to get that fourth drive visible? If so, I think my issues will all be resolved.

Any assistance would be greatly appreciated. Thanks.

Mike
 

mqudsi

Mostly Harmless
Staff member
#9
Hi Mike,

If you told me the SSD Minicard was the one not being detected, I'd say that made some sort of sense. But from what I know about the way SATA DVD drives are connected - it's absolutely no different than a SATA HDD, and you can switch it without any problems.

I'm interested in what you can see from the BIOS. You should be able to get a listing of all HDs in there and their status, does the 4th drive appear in any way to be different from the other 3 there?

However, the fact the grub find command is unable to see your drive is indeed the cause of the problem. We just need to fix that!
 
#10
Well, I do want to get to the bottom of this, but the urgency has just been removed. In looking at my drive configurations, I realized that that 79GB minicard ssd hadn't actually been used for anything yet. And although it was already formatted as an NTFS, I hadn't actually set up a drive on it or used it in any way. So I just blew away the partition and the installed Fedora 16 on that (which went without a hitch with the help of EasyBCD. So I'm happily looking at a gnome screen and will worry about why my other drive wasn't visible at some later time.

Thanks for all your help and your timely responses.
 

mqudsi

Mostly Harmless
Staff member
#11
I googled around a bit, but couldn't find any references to a DVD bay using anything other than a standard SATA connection.

I'm thinking it might be standard SATA but on a different controller using a chipset with non-standard drivers.