Need Vista DVD In Drive To Boot (Vista SATA, Added ATA)

Eck

New Member
#1
Hi all, first post.

I plan to have Vista on SATA (where it is now) and dual-boot OpenSuSE 10.2 on a just added ATA drive placed on the Primary IDE Channel. I have 2 Optical Drives on the Secondary IDE Channel.

I had read that it was best to not connect the ATA drive until after Vista was installed, otherwise it would put its boot files on the IDE drive instead of the SATA drive where Vista is installed to. So I did that.

Today I wanted to get started installing Linux so I added the ATA drive. The Bios is set to boot to the SATA drive first (well, after CDROM and Floopy in the boot order, but the SATA set as the chosen hard drive to boot from).

This ATA drive had been setup with no partitions defined previously. Vista installed the new drive, and I went into Disk Management. First I tried just initializing it without formatting or letting it give it a drive letter. When I could only restart with the Vista DVD in the drive I tried formatting it (Quick) and Vista gave it F: as a drive letter. It is empty except for the Recycle Folder and that other folder who's name escapes me (not boot!).

I still couldn't get past the nothing to boot from message unless I inserted the Vista DVD. I don't get it. If the DVD's in there it will go past the press any key to boot from cd and boot just fine from the hard drive. No DVD and it can't find a system disk (NO SYSTEM DISK message).

I tried doing bootrec.exe /Fixmbr and bootrec.exe /Rebuildbcd. Same problem. I tried running from the DVD the \Boot\Bootsect.exe -NT60 All. Same problem. I tried letting the DVD do its startup repair. It told me there were no problems with my startup stuff. Same problem.

I tried putting in a normal cd, but Vista wouldn't boot unless I replaced it with the Vista DVD.

I tried setting the Maxtor ATA drive jumper off cable select to both Master and Slave and neither worked (but of course Master worked, if I inserted the Vista DVD).

Why in the world would just having the DVD in there make it boot from the hard drive properly? It's not as if I'm pressing a key to boot from cd. If the DVD's there it just simply boots up fine. No DVD and I get the no system disk error, please insert one and press enter.

Since I'm going to let Linux delete the NTFS partition I let Vista setup on the ATA drive, I can't very well just run a Vista Upgrade install (which, I guess, would install the Boot folder to the ATA drive). So then when I install Linux Vista would no longer find the wiped out Boot folder on the ATA partition! So that would be pointless.

I think I'll just install SuSE's Grub to its boot sector (hda2, right? That's because it puts the swap partition on the hda1), boot to the Bios and swap the SuSE DVD to the Vista DVD, boot to Vista and setup EasyBCD to add Linux to the Vista boot loader, swap back to the SuSE DVD and finish the Linux installation (it needs to boot to the hard drive to finish).

Hmm, let's see what happens. Using Grub in the MBR would be pointless in this situation as I would pick the Vista section and get nothing to boot without the Vista DVD in there, and I have no idea how it would react to seeing Grub there if it is somehow providing what the Vista boot loader needs to boot up Vista. I just don't think the normal Chainloader stuff will work in this case.

What a pain in the neck! I've got to keep the stupid Vista DVD in there whenever I want to boot to Vista.

Does anyone know how this can be fixed?
 

Eck

New Member
#2
I've got both operating systems up, running, and bootable but in a pain in the neck way.

I had to have YaST install Grub to the MBR after I had done what I said (and what it automatically picked, that is installing Grub to the Linux boot sector). See, The EasyBCD addition to the Vista boot loader of the Linux section was not able to boot Linux. The only way I got in was from the SuSE DVD's Installation option of booting the installed system. Once I picked that, the installation started up its final configuration and booted me into my KDE desktop. Then I went in and had YaST install Grub into the MBR.

I think both systems want the ATA hard drive to be the first to boot. That's the problem. Grub is installed to the MBR of the ATA (Linux) hard drive as it had no option to install it to what I would have preferred to be the first boot drive, the original SATA drive with Vista on it.

I have to switch my Bios to boot from the ATA (Linux) drive first to boot to Linux, and then to boot to Vista I need to switch it to the SATA (Vista) drive and insert my Vista DVD.

I know that others boot this way, but I don't know how many are forced to always have the Vista DVD inserted into the optical drive in order for Vista to bootup!

Isn't that kind of strange?

I think I'll try adding that swap hard drives line to the Vista Grub section that folks use to make Vista think it's booting from the IDE (now first) drive and yet the files are really on the SATA (now second) drive. That way I could leave the Bios set to the ATA (Linux) drive as the first and perhaps Grub will be able to hand things over in a way that Vista will work with. I don't know exactly how to do that in YaST, or remember exactly (that (sdao, hda1) (hda1, sda0) line?) what to put there, but I'll figure it out from all the stuff like this I've got printed out from all the dual-boot guides on the net.

As of now the Grub Vista section doesn't boot Vista anyway so it won't hurt anything to try to add those two swap lines and see what happens. I'll have the Vista DVD inserted as for some weird reason it seems to need that if I have the ATA drive installed.

I suspect it's a combination of how my motherboard's bios works and the way Vista is designed to insist that any IDE ATA hard drive on the Primary port has to be the first hard drive that boots no matter what the Bios setting says.

Well, even if I can't get Grub to boot Vista at least I have a way in to both operating systems, albeit a weird, slightly cumbersome (the Vista DVD being necessary) way.

If anyone has any suggestions about that DVD problem or a better explanation for it than I have been guessing, please jump in.
 

mqudsi

Mostly Harmless
Staff member
#3
Hi Eck, welcome to NeoSmart :grinning:

Here's what you need to do:
In SUSE, install GRUB to the bootloader of the SUSE partition. Directions can be found here: http://neosmart.net/wiki/display/EBCD/Linux
Skip down to the installing GRUB section and go from there.

Boot into Vista. USe EasyBCD -> bootloader management -> reinstall vista bootloader -> write MBR
Go to the add/remove tab, and select linux/bsd, choose the SUSE partition from the list, and press add.

Should work now :smile:
 

Eck

New Member
#4
Thanks for the welcome. I've been using EasyBCD off and on since early on in the Vista beta period and sure appreciate all the good work done by you folks.

Unfortunately that's what I tried. I had neglected to mention that I had first tried using EasyBCD to reinstall the Vista Bootloader/MBR when I first experienced the needing the DVD inserted problem, and after doing much the same using the DVD's tools had failed to correct the problem.

I then tried again with SuSE Grub installed to the Linux partition. Again no difference as EasyBCD installed the same boot settings as Vista did, which are interpreted as being correct by both the tools on the Vista dvd and within EasyBCD. Still, Vista needs the DVD inserted and Linux would only boot from the SuSE DVD starting the install then choosing to boot installed system.

The only way to boot SuSE directly from the hard drive is the Bios hard drive setting and the SuSE Grub installed into the ATA (Linux) hard drive's MBR. Then when I want Vista I need to change the Bios hard drive to the SATA (Vista) hard drive and insert the Vista DVD, then Vista boots normally.

Like I said, all this likely relates to actually both Vista and Linux thinking the ATA hard drive is the first boot drive. This, even when setting the Bios to use the SATA drive as the first one.

I'm probably just the victim of the Via 8237R southbridge and the way the bios's were designed for it. What I'm using is the latest bios update version available for my board and I seriously doubt they'll be any more updates. At least this board lets me use IDE mode for SATA so I don't need to mess with that fake raid stuff. Not using any raid, I don't need that.

For Vista alone, I'm sure that if I had both hard drives hooked up during installation then Vista would have put its boot files on the ATA drive even though I would have set it to install Windows to the SATA drive. So no DVD inserted would have been necessary to boot up with both drives hooked up.

However, as soon as I had installed SuSE Linux with things setup that way, SuSE would have repartitioned the ATA drive, removing the Vista boot files, and I would be in an even worst situation.

This new Microsoft boot style in Vista sure presents problems for mixing ATA and SATA. I'm sure there would have been no problems if I had used both SATA or both ATA, as that's what I had done previously and everything was nearly automatic. Grub installed to the Vista HD MBR and booted up either Vista or Linux perfectly.

Unfortunately that large ATA drive started clicking and I decided to purchase a SATA drive to replace it. I also switched from ATI video to NVidia, hence this reinstall of everything fresh.

I'm sure I had set the EasyBCD Linux boot partition to the correct one, and had Grub installed to that partition and not the MBR at the time. It simply could not handle it, and would just tell me to insert a system disk, just like Vista does if I do not have the Vista DVD inserted while trying to boot Vista.

So, the strangeness remains but both are booting up fine with my workarounds. Heck, it is possible that even XP would have shown the same sort of problem with this mix of ATA and SATA.

One thing I will watch out for is if I ever need to reinstall Vista. I'll need to disconnect the Linux hard drive, otherwise Vista will, behind my back, format the thing and put it's boot files on it, erasing Linux! Although I can see Linux nearly never needing reinstalling I sure don't have that kind of confidence in Windows. So I'll have to be careful about that with this semi-weird boot setup.
 

mqudsi

Mostly Harmless
Staff member
#5
Really sorry to hear you had to go through all that.

I always say, if you're doing something, might as well do it right the first time. Vista has many issues that should have been addressed as it was being built, but unfortunately weren't - and this is one of them.

Quick question: are you using EasyBCD 1.6? You don't mention, because I added 3 or 4 workarounds for this very issue in 1.6 - if you're not using it that is.
 

Eck

New Member
#6
Heh, heh. Yes! In fact, I first installed the just previous version and then checked for updates. I hate when that happens, especially with Nero (yeah, they updated the day after I had installed it. Run the installer and uninstall it, reboot, run the clean tool, reboot, install the new version, reboot, reinstall the new version again to repair the stupid Nero search crap just so the thing to turn it off and make it disappear from Explorer works, done. Hate that.

So all these things were done with the newer EasyBCD. At least your's was "easy." I just uninstalled it from the start menu icon and installed the new one. Why can't they all do that?

I haven't tried the Grub line to trick Vista that it's booting from its own drive instead of where Grub is, and might not for awhile seeing as at least I've got them booting.

I really thing the major problem is the SATA, ATA combination. And the secondary problem that was likely dealt with by your newer version is Vista wanting to control everything and just boot Microsoft operating systems. Unfortunately the first problem likely needs to be dealt with before seeing the benefits of whatever fixes you've put in to the program.

I hope someone over there has a similar older motherboard like mine so some testing could be done with this. There's probably a way to fix it all up but we'd need a similar bios and motherboard to test out the SATA first drive with Vista and the ATA second drive with Linux. I think I mentioned that I've set the bios SATA setting to IDE mode rather than RAID mode.

Thanks for the support!
 

mqudsi

Mostly Harmless
Staff member
#7
Actually, it's even easier than that. Just install the new version and the older will be auto-uninstalled :smile:

Try this:
EasyBCD | Useful Utilities | Power Console

Code:
cd bin
mbrfix.exe /drive 0 fixmbr /vista /yes
mbrfix.exe /drive 1 fixmbr /vista /yes
bootsect.exe /nt60 ALL /force
 

Eck

New Member
#8
Hi again!

I've been busy in Linux. Heh, once I get into Linux it's a bit difficult to pry myself away to return to my Windows partition! Usually it's just when I yearn for some game I just must play now. And now having discovered that with my switch to NVidia Mupen64 now gives me playable N64 frame rates, and with gfce ultraNES and snes9x I have those games available as well, Windows is even less alluring. Gosh, with OpenCompositing, the Vista Black Emerald theme and Vista Black Firefox theme, I'm kind of looking at Vista while still running OpenSuSE Linux 10.2! Except without that hard drive grinding that occurs in Vista due to indexing and previous versions logging.

Anyway, I didn't spend over $600 on 2 Vista's and the Office Home and Student not to use it so I expect I'll be back in there soon.

I hadn't tried mbrfix, just fixmbr from the normal Vista DVD command line like I told you about in the first post here. And I hadn't tried doing both drives like you have there. So maybe there's a chance to use this thing normally.

Only thing is I'm not at the same point now as I have SuSE's Grub in the mbr. It's not in the mbr of the Vista drive, but the ATA drive that has Linux on it. And I boot the machine now (in order to use Linux) with the bios boot order set to boot the ATA drive first.

So if I want to try your suggestion I'll first need to get Grub moved from the mbr to the Linux boot partition (where it was when first installed).

Thing is, when Vista is booted (after switching the bios boot order back to the SATA drive and inserting the Vista DVD), it, and EasyBCD, think that the boot loader is configured properly. And when I had used both Vista's tools and EasyBCD to reinstall the boot configuration earlier, both times it had reinstalled things to exactly the same state. These tools just seem to thing things are just fine as they are! So I'm not sure if doing as you suggest will set things up any differently than before either.

Hmm, perhaps after restoring Grub to the Linux partition, if I then leave the bios boot order set to the ATA drive and use the Vista DVD tool for startup repair, it will then move its mbr over to the ATA drive? See, I'd need to use the DVD for this as Vista will not boot right now with the ATA drive set as the first drive since all the Vista boot files are in the mbr and boot folder of the SATA drive. So, EasyBCD is inaccessable as Vista won't boot that way. So the Vista DVD must be used for this.

But wouldn't Vista then format a partition for it to place its boot folder on the ATA drive? And that would destroy the Linux partition, wouldn't it? (I've read folks complaining about Vista wiping out Linux this way.)

Sheesh, I don't want to do that! Worried now. This may fix up Vista but destroy Linux in the process. Or even lose both if I make a mistake somewhere.

I think I'll leave the weirdness for now. Of course all this would have worked perfectly natively if I had left both hard drives connected, installed Vista on the ATA drive (configured as the first hard drive in the bios boot order), then Linux on the SATA drive. But Windows software needs gigabytes to accomplish the same things Linux software does in megabytes. And so there's my desire to use the larger SATA drive for Vista.

And okay, next time I'll just install the new EasyBCD over the old version. It's nice that it's that easy.
 

mqudsi

Mostly Harmless
Staff member
#9
Hey Eck,

That's how I feel about Linux too. I've been a Linux user forever now (almost since the very beginning of desktop Linux), but since leaving Vista for Linux I've rarely looked back.

Now I boot into Vista to play a game or code EasyBCD, because it really does perform bad..

I'm checking out that theme you mentioned, been looking for a nice one.
 

Eck

New Member
#10
The one I'm using is Vista Black 1.0. I just noticed there's a Vista Black 1.1 also on kdelook, but they are by different authors!

Just wanted you to know since I gave it a good report. Don't know about 1.1.

If you see the Vista Black 1.0 page, I use the Firefox extension recommendations he makes and they look great (the Firefox Vista Black theme, with the extensions he says make things work better). Firefox will ask if you want to keep the built in session manager active. I told it no. I have no idea why he says these extensions help the theme look proper, but just followed his advice. But the Firefox theme itself looks great. It's kind of like Internet Explorer 7 in Vista, but with the alt button pressed so you get the classic menu bar (which is black with white fonts, while the standard Firefox navigation bar becomes a nice blue with white fonts and colorful stop, home, etc buttons).

I'm not using the LiNsta toolbar, icon stuff (the GTK theme) only because I have no clue how to get it installed or working. But the Vista Black 1.0 Emerald theme was easily installed by the Emerald theme manager as were the Firefox things that I needed to get separately. I guess it would be nice to use the Vista toolbar and start button but only temporarily anyway, so seeing how complicated it looked to try to figure out how to install it I decided not to bother.

I likely will only use this for a short time even though it looks great. I kind of like using default looks most of the time, when they're done well as SuSE's KDE is. But it is very nice to have the Glass effect on the titlebar all the time, while the normal window is still controlled by OpenCompositing. You know, the alt/scroll like Beryl. (Sheesh, I hope they choose a better permanent name than OpenCompositing!)
 

mqudsi

Mostly Harmless
Staff member
#11
YEah, in the GPL community things like that happen :tongueout:

I'm currently using "Frame" which is a nice, minimal theme. I'm not a big fan of overdone themes (can't stand WinBlinds!) and I didn't switch to Linux to use Vista :tongueout:

With regards to OpenCompositing, I just call it the "fadey-thingy" and people seem to know what I'm talking about :tongueout:
 

Eck

New Member
#12
Yep, back to defaults for both Firefox and the desktop now. Got tired of looking at Vista stuff. If I want that I can boot into it. And those Firefox extensions seemed to do the same sort of things that are already built into Firefox. I guess those extensions make that Vista theme behave correctly. I have no idea if the normal session restore and crash handler are now back. I first disabled all the extensions then uninstalled them. That should have done it but who knows. It all appears to be working fine.

I'm keeping the "fade thingy" though. Heh, heh. I like Compiz stuff.

I also tried the Kde3 Xp Style using the latest RPM download he has there. I had YaST install a KDE Tools package that includes the Super Karamba, and installed Kbfx as that KDE3 XP theme uses that I guess.

Although some things are selectable from the KDE Control Center, the theme itself wasn't there. So it was a matter of icons, colors, splash screen, and I guessed the Bubble decorator being applied. I opened the KBfx control and the Kde3 XP Style theme was there but applying it did nothing. Maybe you somehow need to switch the system to use KBfx to get its settings applied? The Super Karamba was able to install the seperately installed Winbar. It appeared on top of my Kicker! So I had 2 Kickers. Weird. I guess I could have removed the normal kicker, but sheesh, the icons and programs accessible from the Winbar (the XP style start menu bar) were missing a bunch of things. Not worth the bother.

I like one of the last posts on the Kde 3 Xp Style section there. "Can you make this thing more confusing to install?"

Then I returned everything to normal, which I'm sure you know isn't a one step process. Fonts, icons, colors, styles, gtk styles, taskbar, etc, etc, all had to be redone after I applied the default SuSE theme.

I do use the Microsoft fonts. Tahoma, Courier New, Ariel, etc. Years of Windows use made me not enjoy the default font look that comes with SuSE. Hey, I paid my way in, buying every Microsoft operating system as soon as they released them, so hey, I might as well borrow some of the stuff!
 

Eck

New Member
#13
Hey, it works!

I would have made a new thread since this is getting old, but I figure (hope) you'll catch the date of the new post and it's still up there in the thread listings, so here it goes.

I decided to try messing around a bit with the Grub menu.lst. I first tried using YaST to do it. YaST has had problems in OpenSuSE when a user attempts to use the manually edit the boot loader configuration files, and even editing the main section, since the couple of Kernel updates pushed by the OpenSuSE Updater. I thought that might have been fixed with the last one so I tried YaST again.

The first stuff I tried was saved properly but didn't boot Vista. So I went back in and this time what I tried to edit in there just wasn't being saved at all! Same old problem. So I guess all the Perl updates they included with the last Kernel update didn't really do the trick. I just opened su- kate menu.lst from the /boot/grub folder and did it myself. Funnily enough, when I went back into YaST to see if it also had my change it set things back to before I changed it again. So I edited the file with Kate again and restarted the computer.

I stuck the Vista DVD in there just to see if the Grub settings would successfully boot Vista the way I had been before, except with my ATA drive with Grub and Linux on it set in the bios as the first boot drive. Vista had not been able to boot itself even with the DVD in there if I didn't reset the bios to boot the SATA (Vista) drive first. All right! I selected Windows from Grub and Vista booted up!

Following that I took the Vista DVD out and restarted the computer to see what would happen. Magic! I selected Windows from the Grub screen and Vista booted up without the DVD! It's fixed!

What I did was the usual suspects recommended to fool Vista into thinking it is the first boot drive again.

title Windows
rootnoverify (hd1,0)
map (hd0,0) (hd1,0)
map (hd1,0) (hd0,0)
make active
chainloader (hd1,0)+1

That did the trick. I have no idea what would happen now that the SATA drive really isn't the first drive anymore, but Vista is just being fooled into thinking it is, if I had EasyBCD or Vista check the boot configuration now. Not gonna do it, wouldn't be prudent. It works like a normal computer now and I don't want to start any trouble.

Too bad stupid YaST thinks the rootnoverify line should be (hd0,0) because I had changed it to that from (hd1,0) first by human error and it had saved that. Now I can't get YaST to accept the change through its own manual edit section or my doing it with Kate. I'm really hoping the next time I boot Linux YaST doesn't set it back to (hd0,0) to insist on having things done its way. YaST has been known to be sometimes not to nice to folks who manually edit their configuration files. It wants to be the master! I wouldn't mind it so much if its own editing process wasn't broken.

Gosh, I sure hope I don't need to edit that file with Kate every time I want to boot into Windows. I don't think that's going to happen, but what do I know until I check it out.

In any case, that map section is what's needed for letting Vista feel all secure that it's in charge of its own first boot drive (but we know better, he, he). I remember that this wasn't necessary when I used 2 normal ATA drives. The Vista drive continued to be the first drive even after Linux was installed and Grub installed itself into the Vista drive's MBR. Now it's on its own drive and I've got 2 MBR's booting the system. Grub just chainloads from its MBR to Vista's MBR I guess. Or, something like that.

I could have gone on with the bios switching method but this is much less of a hastle. Just bootup normally and select what I want from Grub. And then it works. Incredible, these machines.

My next venture is possibly going to be on my other computer since I got my Gigabyte NVidia card back from RMA with a new fan installed. I'm likely to install my other copy of Vista Ultimate retail upgrade (I bought 2 to avoid problems even though I only use 1 computer at a time. I just don't want the hastle of calling Activation every time I switch computers. I did the same thing when I was using XP.) on that one and Fedora 7 as well.

Tell you what though. Gosh, SuSE looks simpler to setup and run. I've been reading and printing info on how to do stuff with Fedora 7 like crazy, just like I did when starting with SusE. I'm going to be doing more terminal typing with Fedora, and there are lots of things that will need my keeping an open mind and adjusting to. It's still Linux (probably in a purer form than OpenSuSE with less GUI help, although I'll still have KDE and that's about the same), but there are vital things that are very different. One example are the way NVidia drivers are handled through the Livna repo rather than the NVidia installer. Doing it the Fedora way, I'm forced to use AIGLX instead of the native NVidia GLX. This is for the Compiz/Beryl goodies. The versions of Compiz and Beryl for Fedora are compiled to work with either XGL or AIGLX. And the Livna repo NVidia driver does not install it's GL libraries. Fedora thinks it creates instabilities to replace the versions included in Mesa by the xorg drivers. And they only work with XGL or AIGLX.

What I've enjoyed about the NVidia GLX is that games and videos are not affected while using Compiz or Beryl. But both XGL and to a lesser extent AIGLX do interfere with image quality and frame rates. So most folks turn the pretty stuff off for movies or gaming. That's not necessary on OpenSuSE when using NVidia GLX.

Plus, wahhh, mommy no more YaST! I'll actually need to learn some Linux. Oh well, I've got to learn sometime I suppose. I barely ever opened a terminal using SuSE. Hmm, that's going to change, eh?
 

mqudsi

Mostly Harmless
Staff member
#14
lol, I'm sorry - I guess I didn't notice the new date :S

The old forum system made it so hard to keep track of read posts - hopefully this will be easier.

SUSE and Ubuntu are great for anyone trying to "learn the terminal" - then comes Fedora, then Slackware, and finally Gentoo.