Need XP To Boot Again

#1
Hello,

I have Windows 7 installed in my C drive and I have XP on my D drive. When I installed Windows 7 on the C drive the DVD installer, I just formatted the C drive and installed it.

I tried to get XP to be in the Boot Selection and tried this:
bcdedit /create {ntldr} /d "Windows XP"
bcdedit /set {ntldr} device boot
bcdedit /set {ntldr} path \ntldr
bcdedit /displayorder {ntldr} /addlast


Apparently that only works on Vista and so I messed up the boot path.



This is my settings right now:
There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS:

Entry #1

Name: Windows XP
BCD ID: {e9c73f28-f96e-11dd-8cde-febf8e85f132}
Drive: C:\
Bootloader Path: \NTLDR

Entry #2

Name: Windows 7 Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows


Only Windows 7 works right now even though it says Entry #1 is Windows XP.
How can I get XP to boot again?



-Thank You.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi midnight, welcome to NST.
You'll need to copy the XP boot files across to the W7 partition root, and edit the new copy of boot.ini to point back to XP.
Have a look at the sticky thread points 5 and 6.
 
#3
I downloaded the ntldr and ntdetect.com and I placed them in my C: drive. I also created a boot.ini and this is what is in it:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect

For EasyBCD it still says the same thing as the bootpath and bootloader, isn't it suppose to change?

Entry #2

Name: Microsoft Windows
BCD ID: {e9c73f2f-f96e-11dd-8cde-febf8e85f132}
Drive: C:\
Bootloader Path: \NTLDR
 

JustinW

Super Moderator
Staff member
#4
ntldr needs to be on your Vista parttion if that is the partition with the boot flag. If its still not working you'll need to tweak your rdisk() and partition() values until you find the right disk/partition. Make sure you're modifying the default=... line for any changes you make.