NeoGrub and Fedora 10

#1
Ive installed fedora 10 preview (its one step before the final release) 64bit version. I've been trying to make NeoGrub work with this installation but with no success. Im attaching the grub.conf file in case it helps.
I have mostly tried to use the configuration from grub.conf in the neogrub, as is and with variations. I always get the "Error 2: Bad file or directory". Googling around I found this page where there is the changelog for the "auto super grub" prog. The author says
"Applied ext3 256-byte inode support patch which it is useful with newer linux distributions. If you used older versions you would have got an: Error 2: Bad file or directory."
Could it be that neogrub is incompatible with the (newer) ext3 filesystem of the partition I've installed fedora? It was formatted from the fedora installer as ext3 filesystem.
Note that the original grub boot process works fine in booting both lunux and Vista.
Thank you for this great program!
 

Attachments

JustinW

Super Moderator
Staff member
#2
Let Fedora install its version of grub and then uninstall neogrub, remove the current entry for it, and re-add it. This well setup neogrub's configuration automatically for you.
 
#3
This doesnt work, default neogrubs options are very generic. Nothing seems to work with fedora 10 and Neogrub, installing grub to MBR (/dev/sda) as well as installing it to the linux partition (/dev/sda5). It seems like neogrub is incompatible with this distro for some reason.
Edit :
Might be a mix up on my side. I installed Ubuntu 8.10 following your wiki instructions and it boots just fine. I will do the same with fedora 10 in a few hours and i'll report back here :smile:
 
Last edited:
#4
After being successful with my Ubuntu installation and booting from BCD, I installed Fedora (10) to the same partition, and it worked out of the box with it too, I just chose the previously created Ubuntu entry in the BCD list and it booted Fedora nicely.
So! Using easyBCD to boot linux from bcd is indeed a breeze and thank you for this fantastic utility.
Im going to explain what i did wrong in case it helps someone else.
From my first efforts I installed Linux the bootloader to a different partion than the boot-root one, and chose not to have the MBR overwritten. I thought it was obvious I had to choose the easyBCD option Grub isn't installed to the bootsector,and all my efforts were with this ticked. So normally i had to mess with neogrub, and I didnt manage to make it work inspite the numerous efforts (perhaps neogrub is just not meant to work with grub installed in a different partition-drive than the root one).
When i fount your wiki instructions, and didnt tick this option, it worked wonders.
Perhaps this extra-neogrub option can be a bit confusing, or its just me that I dont comprehend the boot procedure. Eitherway I'm staying with my current configuration for as long as it takes.
Yours Chris B.
 

mqudsi

Mostly Harmless
Staff member
#5
Hi Chris,

So long as you installed GRUB to a partition - anyone - and not the MBR then you shouldn't tick that option in EasyBCD.

Thanks for sharing your experience and glad you got it to work :smile: