NeoGRUB losing menu.lst file?

#1
I successfully ran EasyBCD-1.7.2 and it's associated NeoGRUB to triple boot two Vista Images and a Windows 7 RC image for the last six months. With the Windows 7 retail version out, I've begun the process of dumping Vista. I have one RAID 0 drive available to the system and a second single disk for doing backups. The RAID 0 drive is partitioned into three primaries and an extended with three partitions inside it. I use the three primaries as my bootable partitions and used NeoGRUB to hide the other primaries when booting the second or third primary partition. NeoGRUB was set up to make all three primaries unhidden when the first primary was made active for booting so that I had full access from that partition for activities like backups and defragging. Everything worked fine before I started my upgrade.

Now, I have reformatted the first primary partition and installed Windows 7 on it. I then installed EasyBCD-2.0-beta and used that to install NeoGRUB, again. I restored the contents of the menu.lst file to give the same configuration as before. The new image of Windows 7 boots fine.

NeoGRUB, however, now goes to a grub> prompt instead of the menu provided in the menu.lst file. Oddly, if I enter "configfile /NST/menu.lst", the menu comes up and I can switch partitions just as I could before. Doing that, I can get boot the Vista partition successfully but it's copy of NeoGRUB now has the same behavior. It goes to the grub> prompt, as well. Keep in mind that this second paritition boots with the first primary partition hidden. So, it shouldn't be seeing the first partitions copy of NeoGRUB nor that partition's menu.lst file. It should still see it's own.

The RC build of Windows 7 on the third partition also does not boot correctly. It hangs. I'm planning to replace that with the release version. So, I'm not so worried about that.

Do you have any suggestions as to why NeoGRUB would be going to the grub> prompt, now, when this all worked before the installation of Windows 7 retail and EasyBCD-2.0-beta?

I installed Windows 7 retail on a similarly configured second machine but on the second partition and everything is working well on that machine.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Jandoife, welcome to NST.

Have you tried removing and reinstalling NeoGrub in EasyBCD 2.0? What build of EBCD2 are you using?
 
#3
Yes, I have. It had no effect. I still get sent to the grub> prompt. I'm using the latest build of EasyBCD-2.0-beta, build 76. Did the version of NeoGRUB change since EasyBCD-1.7.2?

Addendum:

I just checked the version on the second machine and it is older, 0.4.3 instead of 0.4.4. I also noticed that it appeared to be run from disk(0,0), the Vista partition on that machine instead of the booting Windows 7 partition.

Addendum:

That fixed it. DOSGRUB-0.4.4 fails to load my NST/menu.lst file automatically but will load it manually. DOSGRUB-0.4.3 loads it automatically.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
:S

I recently upgraded to version 0.4.4 because it has better ext4fs support. I'll have to check with the devs if this is a known issue; thanks for bringing it to my attention, Jandoife.
 

robvr

New Member
#5
I have the same problem with NST/menu.lst.
I downgraded from 2.0.0.76 to 2.0.0.65 and the problem was solved, although that version
also uses 0.4.4.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Rob, thanks for that. Let me see if I can spot the problem, then.

:smile:
 
#8
2.0.0.65 Right!

Thanks, robvr and the rest ! I had same problems with DOSGRUB-0.4.4, it could not read automatically menu.lst, and after a while grub console was appearing. After writting the code for loading Ubuntu 9.04 it was booting but i had to write it every time. So version, 2.0.0.65 is the right one for solving this kind of problem.