NeoGrub - No menu just BASH shell

#1
Hi,

I am trying to use NeoGrub to hide Vista from XP. I have installed NeoGrub and the menu option exists. When I select the menu option I go straight to a Bash prompt and don't see a menu which is what I expected to see. XP can load OK from the vista bootloader.

Can anyone see what I am doing wrong here or suggest anything to try.

Thanks.

My configuration is as follows

First Hard disk, First partition = Windows Vista (contains menu.lst)
First Hard disk, Second partition = Windows XP
First Hard disk, Third partition = Windows XP Test Installation

I also have a fourth extended partition containing Ubuntu and data partitions.

Code:
# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub menu.lst file, and should be located at C:\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries
# [URL]http://neosmart.net/wiki/display/EBCD[/URL]
 
default 0
timeout 10
 
title XP - Hide Vista
hide (hd0,0) # SET THIS TO THE VISTA DRIVE
# Optionally repeat the above entry for all the Vista drives
chainloader (hd0,1)/ntldr # SET THIS TO THE BOOT PARTITION
boot
 
title XP Test - Hide Vista
hide (hd0,0) # SET THIS TO THE VISTA DRIVE
# Optionally repeat the above entry for all the Vista drives
chainloader (hd0,2)/ntldr # SET THIS TO THE BOOT PARTITION
boot
 
# Optional section
# If you include this section, you will see a second bootloader menu!
#title Boot XP - Unhide Vista
#unhide (hd0,1) 
# SET THIS TO THE VISTA DRIVE
# Optionally repeat the above entry for all the Vista drives
#chainloader (hd0,0)/ntldr 
# SET THIS TO THE BOOT PARTITION
#boot
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#2
Hi tripleboot, welcome to neoSmart Technologies.

Have you tried the 1.61 beta builds?
 
#3
Thanks for your help. I'll try the beta version and advise whether it makes a difference.

As far as you can see did the menu.lst file look OK. I'm new to this so would appreciate a comment if you get chance to look.

Thanks again.
 
#4
autochk program not found

Computer Guru,

i am hopeful you are online as I am in need of some of your Guru Magic :happy:


I have followed your suggestion and installed the latest Beta version. I received the message "Setup failed to load windows runtime library msvcr71.dll - Fresh install?". I ignored this error message as I saw another mention of it in the forums so I continued.

I then installed NeoGrum again and used my same menu.lst file and retried.

There was some progress in the fact that the menu now appears and I can select my hide partition options. However when I select one of the XP options the WinXP loader appears (I assume that this is what is supposed to happen) but when the loader screen moves on the PC resets.

I then went to try running Vista from the Vista bootloader and I have found it fails to load stating "Autocheck program not found" - Is the partition still hidden?

If I select XP from the Vista loader it still boots up OK.

Can you make any suggestions?

Thanks.
 
#5
I followed my assumption that the Vista partition was still hidden and confirmed this from the XP install. So I have now gone to the command line of NeoGrub, typed unhide(hd0,0) and I can now run Vista again (Yipeee!).

However when I select the XP options from the NeoGrub menu then the original XP loader appears then the computer resets. I have tried changing hide(hd0,0) to unhide(hd0,0) but it doesn't seem to make a difference.

It looks like it should work because I get the XP loader but I cannot think what should cause the reset. Any ideas.

It looks a fantastic product by the way as long as I can resolve this niggle.

Thanks.

======================

To see if it was an XP related problem I tried loading Ubuntu from the NeoGrub command line by carrying out the following. On doing this the machine rebooted after typing the boot command in a similar way to XP. One thought I have is that I am using a Hitachi 1Tb drive and was wondering whether that should be OK?

Code:
root(hd0,5)
kernel /vmlinuz root=/dev/hd5
initrd /initrd.img
boot
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Seems you've made some progress there, TripleBoot.

Only reason for a reset that I can think of is that it's searching for a file off the now-hidden Vista partition... which it shouldn't.

There is a very useful command called "find --set-root" that you can use to boot Ubuntu. It'll search for Ubuntu and boot it - with minimal guess work on your behalf.

Code:
find --set-root /vmlinuz
kernel /vmlinuz root=/dev/hd5
initrd /initrd.img
boot
But that doesn't feel right!

hd5 needs to be a partition not a drive. So it would be something more like hd5a or so.
vmlinuz usually contains version numbers - and the same for initrd.

Here's a sample entry:
Code:
title Ubuntu
find --set-root /boot/vmlinuz-2.6.17-10-generic
kernel /boot/vmlinuz-2.6.17-10-generic ro root=/dev/hdb2
initrd /boot/initrd.img-2.6.17-10-generic
boot
 
#7
Thanks. I will try your advice with the linux boot (I'm a newbie to that so I am not surprised that there are mistakes). The main reason I tried it was to see what the problem was for the XP Boot (hoping that linux would just boot thus isolating it to an XP only issue).

Can you think of anything which would allow for the XP Bootloader to appear but to then stop the boot sequence continuing to the next stage? I have also found that if I unhide the Vista partition then the system still fails to boot if I use NeoGrub but using the Vista loader remains OK.

I was wondering whether it could be an issue with the 1TB drive?

Thanks.
 

mqudsi

Mostly Harmless
Staff member
#8
Well, only thing I can think of is that NTLDR and NTDETECT aren't on all of your partitions?
 
#9
Thanks for the tip. NTDETECT was missing from the XP partitions. Now I have copied it across the XP booting appears to work. The only minor issue is having to unhide the Vista partition before returning to Vista.

I have corrected the linux loader to include the version numbers for my install. At the moment it complains that it cannot find root=/dev/hda5 which I also changed. I'll do some research to see if I can find what is wrong.

PS What does the seperate "ro" mean in your kernel line example?

Thanks.
 

mqudsi

Mostly Harmless
Staff member
#10
ro == read-only

It only tells GRUB not to change anything, not that does anyway....

We're working on a program that will automate the entire thing, including the unhiding of Vista when booting Vista....

Stay tune for more info on that.
 
#11
Thanks I'll wait for that.

By the way I did a small "Chip in" but it doesn't appear to have been registered on your bar chart. Does it take some time?
 

mqudsi

Mostly Harmless
Staff member
#12
Thanks tripleboot, much appreciated.
We use an external service (chipin) which can take upto 24 hours to update... it used to be immediate, but they've been having some load issues.