Neogrub not recognizing ext4 partitions?

#1
I just installed RHEL 6.4 onto a second hard drive and am trying to use EasyBCD 2.2/Neogrub to dual boot it from the Windows 7 bootmanager.

For some reason, Neogrub refuses to recognize the ext4 partition that holds the RHEL installation. It is installed on /dev/sdb3, which I believe should equate to (hd1,2). However, when the boot fails and I get to the grub command prompt, when I type "root (hd1,2)" it returns "Error 22: No Such Partition". If I use the EasyBCD 2.2 program, click "Add New Entry", and select the Linux/BSD tab, the Drive: dropdown shows the partition I wish to boot from as "Drive1, Partition 3, (0x28 - 1444 GiB). I have also installed Extfs under Windows 7, and I can see the RHEL installation files in the partition. So the ext4 partition is clearly there - but Neogrub seems unable to recognize it.

I have played around with this for hours to no avail, and have read dozens of web postings about similar problems, but have been unable to identify a solution. So any help you might be able to offer would be much appreciated.
 

Terry60

Knows where his towel is.
Staff member
#2
Since grub2 partition numbers have aligned with Windows numbering system
Grub1 starts counting at 0, grub2 at 1. (try hd1,3)
 
#3
Yep, have tried everything from (hd1,0) to (hd1,4). Only partitions neogrub (or any of the several other grub versions I have tried) are NTFS. For all other partiions, I get the "No such partition" error. FYI, my windows loader MBR is installed on /devl/sda. When I installed RHEL, I had the bootloader installed in the installation partion (/dev/sdb3).

This is so frustrating! Has anyone out there been able to get RHEL to boot from the windows loader when RHEL is installed onto a separate drive from the one where the windows bootloader is installed? If so, would you please try to describe how you managed this?
 

mqudsi

Mostly Harmless
Staff member
#4
NeoGrub has full ext4 support. Did you create an LLVM-based scheme?
 
#5
Just to be sure, I recreated the swap and ext4 partitions on the second disk (/dev/sdb). The ext4 partition was created as a primary partition. I changed the relative position of swap and ext4, so that swap and ext4 are last two partitions on the disk, in that order. The first two partitions on the disk were made by Windows - the first is a small unformatted partition, and the 2nd is a 2TB NTFS partition. Unfortunately, I am getting the exact same problem - Neogrub only recognizes the NTFS partitions. For example, if I issue a "find" command from the grub prompt, it lists the 2 NTFS partitions that exist - one on the first disk, and the one on the second disk.

Could the problem be related to the size of the installation disk? It is a 4TB disk, and the partitions are in the latter 2TB of the available space.
 

mqudsi

Mostly Harmless
Staff member
#6
Are you sure you're on the latest EasyBCD?

And, yes, the size of the disk would matter. I'm not sure if it supports GPT natively or if it's using MBR emulation (which wouldn't see past 2TB).