New Dual Boot XP + Win 7 RC1 Problem

Zap

New Member
#1
Hi,

I've read the stickies and various posts on this subject, but none of the solutions are working.

My scenario: Had XP Pro 32bit installed as primary drive (RaptorX 150GB). Added a second Hard Drive (RaptorX 160GB) and installed Win 7 RC1 (64bit). After install, no dual boot option showed up and system went straight into Win 7 - which works good.

Downloaded the EasyBCD 2.0 tool and added XP. Restart = Dual boot option (Win7 top default, XP bottom) with 30 sec timer. Hit enter on XP and got the \NTLR error (0x000000F).

Back to Win 7 and ran EasyBCD with the tip to let EasyBCD install /NTLR and boot options... still no entry to XP :scared:.

Back to EasyBCD, removed XP entry, added XP again... still have the \NTLR error!

Went into the BIOS, where the XP 150GB HDD was the first boot drive, and switched the Win 7 HDD to boot first. Restart and now Dual boot screen has an error that no OS available, boot problem. Went back to BIOS and put the XP drive back as the first boot drive. Now Dual boot option is again functioning, but XP still has the \NTLR ERROR - Win 7 is OK and loads fine.

So, what do I do next to get XP Pro to load?

Here are some pics of the Hard Drive flags and EasyBCD settings window.




 

Terry60

Knows where his towel is.
Staff member
#2
Hi Zap, welcome to NST.
You'll notice that W7 has installed its boot files to an unlettered partition on your XP HDD (that's what "system" means)
Are you using the latest build of EasyBCD 2.0 ?
It should be able to handle "secret" W7 boot partitions, though there have been isolated instances of failure which are being looked into.
If you're not using build 63, try it.
If you are using it, give that partition a letter and remove/add the XP entry again and let it auto-configure with a lettered boot partition and you should find it works.
 

Zap

New Member
#3
Hi Zap, welcome to NST.
You'll notice that W7 has installed its boot files to an unlettered partition on your XP HDD (that's what "system" means)

If you are using it, give that partition a letter and remove/add the XP entry again and let it auto-configure with a lettered boot partition and you should find it works.
Jackpot! XP boot now works again. Your suggestion to name the unlettered partition seems to have worked - I'm typing this post on XP now :smile:. (Though it seems so dated compared to Vista and Win 7, I have older programs that seem to like XP better). And yes, I used the latest EasyBCD 2.0 to reconfigure the boot files..

Thank you Terry for the timely reply and excellent information. Thank you also to NeoSmart for providing the EasyBCD tool and this informative Forum.

Cheers, Zap
 

Terry60

Knows where his towel is.
Staff member
#4
Guru's looking at the problem of why this sometimes fails after he'd included code to deal with anonymous partitions, but meanwhile we'll always try to workaround any problem. Glad you're OK now.
 

mqudsi

Mostly Harmless
Staff member
#5
I'm setting up a virtual machine as I type this to test the problem.