new laptop doesn't boot anymore

#1
My new (Siemens) laptop with Vista worked fine for 4 weeks. But now it won't boot into Windows anymore, cause unknown. After power on I only have a black screen with a blinking cursor without any messages.

On my other XP laptop I managed to download and burn the recovery CD and I booted from CD and did a startup repair.This could not detect any problems. I tried the system recovery options but there are no recovery points.

I started the command prompt and did a chkdsk and found no bad sectors. I followed the instructions on http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD until step 3. Now I can’t find bootsect.exe on the CD, and 0 indentified Windows installations?? Also, I found C:\Boot but no C:\Boot\BCD.

Any suggestions on how to go further?

Some output:
Startup Repair diagnosis and repair log
---------------------------
Last successful boot time: 10/26/2008 10:51:14 AM (GMT)
Number of repair attempts: 4

... (All tests in the log completed successfully)

Root cause found:
---------------------------
Boot status indicates that the OS booted successfully.


C:\Boot>bootrec.exe /rebuildbcd
Scanning all disks for Windows installations.

Please wait, since this may take a while...

Successfully scanned Windows installations.
Total identified Windows installations: 0
The operation completed successfully.

C:\Boot>bootrec.exe /fixmbr
The operation completed successfully.

C:\Boot>f:\Boot\bootsect.exe /nt60 all /force
'f:\Boot\bootsect.exe' is not recognized as an internal or external command,
operable program or batch file.

C:\Boot>f:

F:\>dir boot
Volume in drive F is WinRE
Volume Serial Number is 4055-9121

Directory of F:\boot

06/03/2008 09:39 PM <DIR> .
06/03/2008 09:39 PM <DIR> ..
01/04/2008 06:22 PM 262,144 bcd
01/03/2008 02:23 AM 3,170,304 boot.sdi
01/03/2008 01:54 AM 1,024 bootfix.bin
01/04/2008 06:23 PM 2,048 etfsboot.com
06/03/2008 09:39 PM <DIR> fonts
4 File(s) 3,435,520 bytes
3 Dir(s) 3,553,841,152 bytes free

F:\>

C:\>bcdedit

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale nl-NL
inherit {globalsettings}
default {default}
resumeobject {6300ac91-324c-11dd-a9fb-a18fe6d5eeed}
displayorder {default}
bootsequence {memdiag}
toolsdisplayorder {memdiag}
timeout 30

Windows Boot Loader
-------------------
identifier {default}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale nl-NL
inherit {bootloadersettings}
recoverysequence {572bcd56-ffa7-11d9-aae0-0007e994107d}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {6300ac91-324c-11dd-a9fb-a18fe6d5eeed}
nx OptIn
 

JustinW

Super Moderator
Staff member
#2
Check to see if your hard drive is first in the boot sequence and that you don't have any removeable devices plugged in that are capable of being booted from (ie. flash drives). You should run chkdsk c: /f from the command prompt from Vista's DVD if the problem persists or consider getting important files off the disk before resorting to a clean install. You'll need a full Vista disc for re-installation though, as the recovery disc only contains the files needed to repair a Vista installation. You might have a recovery partition you can boot from by pressing a special key combaination at startup that'll put your computer back to the way it was the first day you got it, but you'll need to check the documentation for your model or the OEM's website for that information.
 
#3
Booted with hard drive first in boot sequence and no removable devices present. Still nothing has changed.

Found out that c:\boot\bcd is present but hidden, followed instructions from somewhere else on the internet.
• bcdedit /export C:\BCD_Backup
• c:
• cd boot
• attrib bcd -s -h -r
• ren c:\boot\bcd bcd.old

• bootrec /FixMbr
• bootrec /FixBoot
• bootrec /ScanOs
• bootrec /RebuildBcd

Can’t find a bootsect.exe, so can do nothing with the instruction x:\boot\bootsect.exe /nt60 all /force from the wiki. Still have the same problem.

Then continued with step 4. After that, when booting from the recovery CD, the startup repair began automatically. The result is that a Windows Error Recovery screen comes up at power on and I can choose to start up in a safe mode. System32 drivers are loaded and then after a while a loading bar appears (Microsoft Corporation) and then I get a black screen and an arrow cursor that reacts on the touchpad but not on a mouse movement. After that no activity, the only thing to do is power off.
 

JustinW

Super Moderator
Staff member
#4
Vista might take awhile to boot up, but give startup repair another go. Have you tried booting Windows normally? Startup repair sometimes requires that you run it more then once to fix everything.
 
#5
Hi there,

I did all that. I booted many times, normally, in safe mode, with advanced boot options (F8), from recovery CD. Alternately many times startup repairs and chkdsk c: /f, and an advanced boot option ‘boot with logging enabled’.

The startup repair sometimes picked up something, and sometimes could not detect a problem. The chkdsk c: /f mentioned a problem with an index item config.sys , so I copied this file, removed it and copied it back. That made that the chkdsk finds no problems anymore. After that I run startup repair until it could not detect problems.

My last attempt was the ‘boot with logging enabled’. That started another disk check came with 11 ‘filename errors in systemfile recordsegments’ (4 to 15). After that a reparse point was made.

Yesterday I contacted the manufacturer (Fujitsu-Siemens). They asked me to unplug power supply and battery for a moment and then plug in the power supply. This didn’t fix it either. Then they asked me if I had the option in the advanced boot options menu for making an Install DVD myself. This wasn’t the case, so now they will send me the Vista software on DVD, without any costs for me. Now I know how to obtain the original software on disk. I hope to be able to reinstall my Vista Premium soon now.

First things after that is checking that recovery works (recovery points available) and that virus checking is enabled.

Thanks all for your help and responses.
 

JustinW

Super Moderator
Staff member
#6
Glad you're getting that disc for free... a lotta companies challenge you or try to charge you for something you already own. At this point I'd be backing up any files that are important to you, because a clean re-install well clear the disk of its previous contents.