Newbie query.. EasyBCD .. multi-boot ... Windows 10, 11, Zorin and Ubuntu -- (1) nvme and (4) SSD's

Hi all... First thank you for EasyBCD and NeoSmart. - no rush. Question.

My desktop set up contains 4 SSD's and 1 nvme. For longest I installed linux on the nvme (since it's fixed to the motherboard and used Grub Customizer) as the boot agent...and things worked fine somewhat until Win 11 came out. My preference is for learning and experimentation, thus I set up each OS in its own SSD.

1643587077893.png

Three of the Windows SSDs are partition style of GUID Partition Table (GPT)
Only one of the Windows is partition style of Master Boot Record (MBR) ... see above


For reasons unknown to me, thru trial and error, EasyBCD works best with the MBR and can logon and select the other two windows installs. However I am at a loss on how to point to the linux OS's on the nvme. Any basic thoughts would be greatly appreciated. The only way to access the linux OS's so far seems via the BIOS which I don't want to do. And hard lessons aside, I don't just yet wish to give Win-11 any control or power; meaning only want it to be an an option. No sure but some times it conflicted with the set up before and forced me to reset two of the win10 OSS's, a painful process. On the nvme, Zorin was installed first, then Ubuntu added. Via BIOS, I able to access with whichever OS from grub.

For longest--prior--I employed GrubCustomizer as the main multi-boot agent--[a fine product which I greatly appreciate Daniel Richter], however for reasons beyond my newbie knowledge, it only recognized the SSD's formatted in GPT or not MBR... from within zorin. So for now foregoing GrubCustomizer for short-term and attempting to go route of Easy BCD 2.4.

Dear all, only want a basic, top level, neanderthal, Cro-magnon style, intuitive guide without getting too detailed. Thank you God Bless!


Here's lsblk

lsblk.png

And here are 2 images.. for sudo parted -l .... (image 1 of 2... and image 2 of 2) . Thanks.


sudo parted -l  (image1-of-2).png
sudo parted -l  (image2-of-2).png
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
1 Windows multiboot must use the latest version bootmgr (W11 in your case) to be able to load earlier versions of Winload. An older Windows bootmgr can never load a newer Winload (digital signature error)
2 UEFI Windows from W10 onwards has a bootmgr.efi which MS has prevented from being able to load any "foreign" OS or even MS legacy OSs
 

pmshah

Member
I would suggest you try out "Boot IT Bare Metal", a third party boot manager, from Terabyteunlimited. It is not free but your problem will most likely be solved. You won't have to deal with any of the Windows BCD options beyond what relates to that particular installation.
 
Finally found a superb and exquisite solution to this conundrum. This solution is safer, less headache, at hardware level and I daresay even prevents the transmission of virus from one ssd/hdd to another ssd/hdd. Kingwin HDD-PS6 - I pray no argument.
 
Top