No ang0 on all drives problem

#1
I have used EasyBCD for about 2 years roughly now to boot between Windows 7 and Ubuntu with great success since when I first got Ubuntu Grub didn't configure properly for some reason. My problem now is that the boot manager is not booting to Ubuntu. I boot to Windows (a 256Gb Samsung 840 Pro) as default after a countdown of 15 seconds, and Ubuntu is on a separate drive to Windows (Samsung 500Gb) but the files are all on C. I have tried many things, restoring old backups from when I had Win 7 Pro, deleting the ANG0 file and the NST folder on the root of C where EasyBCD installs to, then deleting both entries from within EasyBCD, saving the settings, then recreating each entry and saving again. I then also made a 1Gb USB flash drive bootable from within EasyBCD. Upon getting EasyBCD to say that the default drive was C and not where I stored the backup files, I rebooted to try Ubuntu again. And true to form it failed to find the ANG0 file on any of the NTFS drives in my machine but found it on the USB Drive I made bootable.

I'm the latest version of EasyBCD 2.0.2 something, NOT the 2.2 Beta. At one point I deleted the Ubuntu entry and added it again without saving, at the same time I was watching the root of C, and an ANG1 file was created (I didn't look in the NST folder where "AutoNeoGrub0.mbr" is located), so it isn't unable to create files. When I changed from 7 Professional to 7 Ultimate I installed EasyBCD and recreated the entries rather than using a backup, and it worked perfectly, until a month or so ago when I noticed it had stopped working. I'm actually now wondering whether the latest firmware from Samsung caused this problem, now that I'm Ubuntu it says it can't mount it because of "No object for D-Bus interface", I have it on the 6Gbps port of my Motherboard for speed more than anything and I'm wondering if this is the problem. Can I put the files on my 2Tb Storage drive which is E and hide them so I don't accidentally change them or delete them?

If anyone has any suggestions please let me know.

Thanks in Advance,

Stephen
 

mqudsi

Mostly Harmless
Staff member
#2
2.0.x is outdated and has known issues. Since you know 2.2 is out, why have you not tried it?

In particular, it does fix this problem w/ certain NTFS layouts.
 
#3
My mistake, I looked at EasyBCD again and I'm using 2.2.0.182 which is the latest free release I believe that isn't a beta. I have tried to change boot drive, when I do a few applications crash as does Windows explorer meaning I can no longer browse my computer until I restart, upon restarting and trying Ubuntu I get the following text on screen:

Try (hd0,0): NTFS5: No ang0
Try (hd0,1): Invalid or null
Try (hd0.2): Invalid or null
Try (hd0.3): Invalid or null
Error while reading MBR of _ in partition table of drive (hd01)
BIOS: Drive=0x0, H=0, S=0

Try (fd0): NTFS5: 0
Cannot find ang0 in all drives. Press Ctrl+Alt+Del to restart

(Between "reading MBR of" and "in partition table" the _ is just acting as extra space since several spaces between words are automatically made into 1 space)

Every time boot back into Windows it takes a while longer than normal to log in and seems to do a LOT of HDD running and when I check EasyBCD again it has toggled back to booting from C drive again when I specifically told it to change to E. I have checked my E drive and there is a BOOT folder (uncheck the box under Alt>Tools>Folder Options>View>Hide Protected Operating System Files (recommended) and it appears) and in it is a load of files that EasyBCD created, but do I need to rewrite the MBR to E drive with EasyBCD THEN change the boot drive to E or what? I'm at a complete loss now as to what to do aside from copying the ANG0 file and the NST folder to the root of E and seeing if that works :/.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
Did you delete and re-create the entry with the latest version? Simply upgrading EasyBCD will not automatically upgrade the previously-installed OS loaders.
 

Terry60

Knows where his towel is.
Staff member
#6

mqudsi

Mostly Harmless
Staff member
#7
I'd say still delete the entries and re-add.
 
#8
Terry60, that may apply to me for the D-Bus problem, I'll check my BIOS when I next boot my PC as I messed up EasyBCD and had to power off the computer from the power button which resets all the clocks and some other BIOS settings, though I'm sure it WAS disabled.

Computer Guru, I have already done that. Deleted both entries, save settings, closed EasyBCD, reopened EasyBCD and readded the entries. I have just done it again to be sure and I shall try booting to Ubuntu on reboot.
 
#9
Terry60: I've checked my BIOS, Flopped was already set to None which is disabled, Ubuntu can now read my SSD fine, I had installed Software Updates but I hadn't restarted so perhaps there was a new driver installed or something.

Computer Guru: Still no luck, I've deleted the entries in EasyBCD 2.2.0.182, saved the settings, closed EasyBCD and opened it again and re-added the 2 entries with no luck, the only place ang0 is seen is on my 1Gb USB stick which was made with EasyBCD as a backup in case I screwed things up again as a quicker method than having to put my Windows disk in and repair the MBR. Do you have ANY suggestions on how to fix my problem, aside from always have the USB stick plugged in if I want to use Ubuntu?
 

mqudsi

Mostly Harmless
Staff member
#10
You definitely should not see ang0 being created on your USB. Do you have EasyBCD set to load your USB's BCD automatically?
 
#11
I made the USB drive bootable using EasyBCD. I think at one point I may have loaded the store from it into EasyBCD, and of course because it had ANG0 and AutoNeoGrub0.mbr on it, the bootloader booted to Ubuntu when it was plugged in. But I'm still puzzled why it couldn't read my SSD, or for that matter the 2Tb HDD (E:\) that I changed to be the boot drive, again using EasyBCD. However when I did the latter and rebooted back into Windows (because Ubuntu still didn't work unless the USB Drive was plugged in), the boot drive changed back to C even though I'm sure I loaded the store from E beforehand. I guess having boot files on multiple drives can cause problems.
 

mqudsi

Mostly Harmless
Staff member
#12
Reinstalling EasyBCD isn't enough - did you delete and re-create the entry in EasyBCD as well?