no auto invocation of windows boot screen

#1
Read the docs and looked for a previous posting, but can't find anything relevant.

I've installed Ubuntu with a GRUB /boot at a primary partition (sda3) on top of a Windows 7 install on a HP Z200 workstation (HP BIOS), using EasyBCD to control the MBR loader, which has "Windows 7" set as the default with the other option to boot from /dev/sda3 (Legacy GRUB). Both Windows 7 and Ubuntu work fine! BUT to get Ubuntu to load I must hit the "space" key immediately after the BIOS load to get the MBR boot screen to appear (and then choose Ubuntu). If I just turn the PC on and do nothing, then Windows 7 starts without any boot screen preceding it.

I know it is possible to get the boot screen to appear prior to Windows 7 since I have a dual-boot HP laptop which does that, though for it I just used the Windows 7 command bcdedit.exe not EasyBCD. I figure that EasyBCD should be able to work the same! Am I doing something wrong? I looked for some EasyBCD configuration option which might affect this but did not see anything that looked relevant.

Jack
 

Terry60

Knows where his towel is.
Staff member
#2
Check in "edit boot menu" that you don't have timeout 0 or "skip menu"
 
#3
"Skip the boot menu" is UNchecked, "Boot default after ..." is 5 seconds

Addendum:

I've been exploring and altering the BIOS since my last message. The HP Z200 workstation has something called the "Intel Boot Agent" installed, which runs on boot up. And in my HP BIOS under the "Advanced" tab is "Power On Options" which when selected displays many "POST" choices. Many, many reboots later I find that I must have its "POST Messages" parameter set to "Enabled" (the default was "Disabled") to get the Windows MBR boot screen to appear! I had thought perhaps the problem was the default "POST Delay" setting of "None", but that turns out to be OK. I don't know if this info is already known to others - if not, hopefully this will help someone else encountering the same problem.

Jack
 
Last edited: