No NST dir... can't boot osx on other drive

Discussion in 'EasyBCD Support' started by aroide, Mar 3, 2007.

  1. aroide

    aroide New Member

    Joined:
    Mar 3, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have Vista and XP happily booting with easymbr. I recently have an osx partition on a different hard disk (unplugged Vista/XP disk when I did that). I have been searching the forum and trying everything I can think of to get easybcd to boot osx. Stuff I've noticed and/or tried:

    - I don't have a c:\NST directory. I uninstalled easybcd and reinstalled 1.52 and still don't have one even after adding osx as "generic osx86" with auto mode to the menu. Is this normal or am I missing something basic?

    - after reading some forum posts, I tried creating c:\nst, putting boot.efi in there, but easybcd is apparrently looking for nst_mac.mbr.

    - tried adding chain0 file to boot.ini file (on both XP and Vista partitions), see it on menu, but no dice.

    - if I unplug my vista/xp disk, osx happily boots, so no issues there.

    - my system: disk0 has primary partition for XP and primary partition for Vista. I do boot into Norton bootmagic (long story of debugging hell), but always choose Vista. disk1 is an NTFS data disk, osx is on disk2. All disks are SATA with EHCI enabled in bios.

    Any direction to help me would be appreciated. :)
     
  2. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
    *wince*
    EasyBCD you mean - not EasyMBR :p

    Can you paste the contents of "Detailed View" below please?

    Thanks
     
  3. aroide

    aroide New Member

    Joined:
    Mar 3, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Sorry about the MBR BCD confusion... Lots of TLAs here :)

    Here is my detailed log with the desired (not working) osx boot option.

    Windows Boot Manager
    --------------------
    identifier {bootmgr}
    device unknown
    description Windows Boot Manager
    locale en-US
    inherit {globalsettings}
    default {current}
    resumeobject {888278cd-7738-11db-929e-a3672ff38c84}
    displayorder {current}
    {2460d1bb-77de-11db-954f-001676b1dff9}
    {2460d1c0-77de-11db-954f-001676b1dff9}
    toolsdisplayorder {memdiag}
    timeout 30

    Windows Boot Loader
    -------------------
    identifier {current}
    device partition=C:
    path \Windows\system32\winload.exe
    description Windows Vista (TM) Ultimate
    bootdebug No
    nointegritychecks No
    osdevice partition=C:
    systemroot \Windows
    resumeobject {4a53e7ba-b7e4-11db-8bad-806e6f6e6963}
    nx OptOut
    pae ForceDisable
    sos No
    debug No

    Windows Legacy OS Loader
    ------------------------
    identifier {2460d1bb-77de-11db-954f-001676b1dff9}
    device partition=C:
    path \ntldr
    description Microsoft Windows XP

    Windows Legacy OS Loader
    ------------------------
    identifier {2460d1c0-77de-11db-954f-001676b1dff9}
    device unknown
    path \NST\nst_mac.mbr
    description NST Mac OS X
     
  4. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
    "device unknown"

    That's the problem.
    EasyBCD 1.6 accounts for this, and addresses the issue. If you are interested in testing it, please let me know via PM.
     
  5. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
    PM Sent.
     
  6. Austin

    Austin New Member

    Joined:
    May 7, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I'm having this same issue.

    There are a total of 2 entries listed in the Vista Bootloader.
    Bootloader TimeOut: 30 seconds.
    Default OS: Microsoft Windows Vista

    Entry #1

    Name: Microsoft Windows
    BCD ID: {b64fcc30-f763-11db-8055-944cee9b6912}
    Drive: C:\
    Bootloader Path: \Windows\system32\winload.exe
    Windows Directory: \Windows

    Entry #2

    Name: NST Mac OS X
    BCD ID: {b64fcc2f-f763-11db-8055-944cee9b6912}
    Drive: Deleted Partition\
    Bootloader Path: \NST\nst_mac.mbr
    Windows Directory: \Windows

    I'm tired of using the darwin loader and dislike it. I just set my vista partition as active so now I want to figure out BCDEdit and make it work properly. If you have any input let me know.

    thanks,
    Austin
     
  7. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
  8. Austin

    Austin New Member

    Joined:
    May 7, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Same error...

    when I try to boot it says that \NST\nst_mac.mbr is missing or corrupt. Any ideas?

    I think it's fixed

    I ran the rescue from the diagnostics menu.

    rebooting now...

    ok huge problem

    now windows vista won't boot but darwin will

    after running the rescue i rebooted and tried to boot into windows and it says

    File: \Windows\system32\winload.exe
    Status: 0xc000000e
    Info: Selected entry could not be loaded because the application is missing or corrupt.

    Hit continue and I can boot into osx.

    How do I recover my boot mgr. I assume a repair with the vista cd will clear things up but I really want to make this thing work.
     
  9. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
    you were supposed to delete the old os x entry, then create a new one.

    which repair option did you choose?
    If HFS, What drive and partition numbers did you enter?

    HFS is ONLY if you are experiencing HFS problem. Nothing else.
    Drive numbers start from 0, partition numebrs start from 1.

    I hope you didn't pick the wrong drive/partitino combo!
     
  10. Austin

    Austin New Member

    Joined:
    May 7, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I did a vista cd repaiir and it fixed that problem.

    Here is exactly what I did. Every time I load EacyBCD it says the Unfortunately EasyBCD could not detect the drive letter of your boot device. So I follwoed the directions to "Reset BCD Storage". When I did this I received an error and it deleted all the entries but Vista from my boot menu. So I re-added NST OSX and then checked to see if that \NST\nst_mac.mbr existed. Well it did! So I thuoght I was set...reboot and BAM osx worked and vista didn't. Repaired and now I'm back at square one.

    here is my current config after running Vista repair and not touching any settings in EasyBCD:

    There are a total of 2 entries listed in the Vista Bootloader.
    Bootloader TimeOut: 5 seconds.
    Default OS: Windows Vista (TM) Ultimate (recovered)

    Entry #1

    Name: NST Mac OS X
    BCD ID: {b64fcc31-f763-11db-8055-944cee9b6912}
    Drive: C:\
    Bootloader Path: \NST\nst_mac.mbr

    Entry #2

    Name: Windows Vista (TM) Ultimate (recovered)
    BCD ID: {current}
    Drive: C:\
    Bootloader Path: \Windows\system32\winload.exe
    Windows Directory: \Windows
     
  11. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,476
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Chicago
    Back to EasyBCD.
    Reset BCD storage.

    Then go BACK and delete ALL entries, including Vista.
    Add a Vista entry manually to Drive C:
    Add an OS X entry.

    Cheers! :)
     
  12. leehuas

    leehuas New Member

    Joined:
    Nov 7, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    This is for Computer Guru

    I registered to this site just so i could say a big big thank you for providing the quickest and easiest solution to this problem........i read countless forums on this problem suggesting chain0 copies and fdisk commands which are far to complicated and dont seem to work for a lot of people anyway.......i reinsatalled Mac OS X so many times but always got stuck at the point after reparing my winload.exe resulting in me being able to boot Vista but leaving the Darwin boot useless........i even attempted different fixes suggested with BCD to no avail.........then Viola!! your simple solution provided the answer.

    Thanks so much for your much appreciated knowledge. :brows:

    Lee
     

Share This Page