No pop-up menu for iReboot

#1
iReboot has been working great for almost a year to dual-boot two Windows 7 instances, then a few weeks ago it stopped working on one of them. I've tried re-installing, but didn't help at all.

Also found the iReboot Background Service and it was stopped, so I tried starting it and got this message: "The iReboot Background Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Basically, when I left-click or right-click the little blue hat (or whatever the icon is), I don't get the pop-up menu anymore. Absolutely nothing happens.

Only thing I can think that changed was my company rolled out DirectAccess, and I got some updates to Group Policy a few weeks ago on the W7 instance where iReboot is failing. iReboot still works fine on my other OS.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi dna5122,

Sorry for the late reply.

Basically, the reason you're not seeing the iReboot menu is because the iReboot service (required to get around the stupid UAC regulations: Want UAC-Free iReboot? You got it: iReboot 1.1 released! The NeoSmart Files)

Now why the service is shutting down.. that's a good question.

If you run bcdedit from an elevated command prompt, what do you get?
 
#3
Running bcdedit from an elevated command prompt gives me all the expected entries.

Is there any logging in the service that I can access (or turn on) to see what's happening?

Thanks.
 

JustinW

Super Moderator
Staff member
#4
Well, you could try re-installing, but it would appear to be the group policy change thats causing this.
 

mqudsi

Mostly Harmless
Staff member
#5
Download iReboot 1.0 from the sidebar of the iReboot download page. It didn't use a service.

Caveat emptor: iReboot 1.0 (without the service) does NOT run at startup if you have UAC enabled. Stupid Windows "security" architecture (#fail).
 

JustinW

Super Moderator
Staff member
#6
I haven't tried it, but to get around this limitation you could try creating a task to start iReboot for you at login as an administrator, right?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
I should have thought of that... I used CSword a few times in the past, found it pretty helpful.

However, I think it might run into the same problem that iReboot did with v 1.0. Namely, no UAC elevation dialog may be presented at startup. If your app requests evelation and it's run at startup, it'll be shot down and denied.

I had to use a service to make iReboot actually not require UAC in the first place.

Addendum:

I see you've modified your reply (I loaded this tab last night and never got around to reply :grinning:)

Using the task scheduler would indeed work, but with this service + agent model, limited user accounts (non-admin) may also use iReboot.
 
Last edited:

JustinW

Super Moderator
Staff member
#8
csword doesn't run elevated in its parent process. Most of its features don't require that you be an admin, but for those that do, it launches another instance of itself elevated. Its worth a try, I don't have the setup to test it right now.