Not an error or problem, more of an annoyance

JoeyImage

Member
I did have a working boot, just an unwanted second OS Choices menu.

Vista is on the C drive, which is disk 0. XP is installed on D, which is disk 2. The files ntldr and NTDETECT.COM are on C. So if I'm understanding correctly, the correct boot.ini should look like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

I only have the full drive as the partitions in my system.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
See last post
"Just ensure that the values are identical on both lines."
boot.ini should have the same values for rdisk and partition in both lines
otherwise you'll get the 2nd menu presented.
if you only use full disk partitions, then the job should be easy.
Just try rdisk(0 - n) partition(1) in both lines till you find the one that boots.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Why ?
Are you saying that none of the rdisk() values works ?

Addendum:

You say that XP is D:\ but there's no D disk in your post 5 !
What else have you changed to make the original problem come back after you'd previously said it was fixed ?
If none of the rdisk values works, lets get back to basics.
Please post your disk managment screenshot, making it clear which partitions are Vista and XP.
post the contents of the EasyBCD "view settings" display
post a screenshot of the Explorer view of the root of the OS partition marked as "system"
post the contents of the boot.ini file from that same partition.
 
Last edited:
Top