Not so fast

Well, things aren't going just perfectly as I had previously thought. When I attempted to boot XP, I got the following message:
"Windows could not start because the following file is missing or corrupt:
<Windows Root>\system32\hal.dll.
Please re-install a copy of the above file.
I have no idea how to re-install a single file. But I don't believe that XP will be happy again without a functioning Hardware Abstraction Layer. I'll search the forum before posting, but I am not too confident.

After reading the documentation trying to figure things out myself, more questions arose. I'm unable to find a "boot" folder anywhere on the hard drive using Windows Explorer. Doing a search for it, though, turns several up. But "Boot.ini" and "ntldr" are missing in action and the only way I can even see the XP partition is via the Disk Management MMC snap-in.

I'd REALLY like to be able to boot XP, because Vista on this laptop runs like total crap.

I'd also really like to tell all who may happen to read this to REALLY try to never have a head-injury. Mine sure-as-hell don't go out of their way to help with things like this!

I'd greatly appreciate it if someone could help me get this thing straightened out!


Mak 2.0

Staff member
The first thing you need to do is go under Folder Options and turn on all hidden files. This is done under the View tab. Make sure you uncheck all the boxes for hide hidden files including the system protected files. These are where the Boot files are hidden in the root of the XP drive.

After you unhide these file you will be able to find them.

You can read thru the wiki:

Troubleshooting Windows XP - NeoSmart Technologies Wiki

Toward the bottom there is instructions for how to fix the hal.dll missing. You can also insert the XP Disc go intot hte recovery console and replce the file thru that as well.
I had things set to show hidden files, but 'Hide protected operaing system files (recommended)'

was checked. That did make the difference, thanks.

Unfortunately, now I'm getting hung up on the Bootcfg command. Whenever I run the required

command from the Recovery Console I am presented with the following:
"Error: Failed to successfully scan disks for Windows installations. This error may be caused

by a corrupt file system, which will prevent Bootcfg from successfully scanning. Use checkdisk

to detect any disk errors.
Note: This operation must complete successfully in order for the /add or /rebuild commands to be

I am unsure how to proceed since I receive that same message DIRECTLY AFTER running Checkdisk and

repairing the disc.

How can I successfully complete the Bootcfg operation?

Thanks so much for your on-target diagnosis and recommendations!



Mak 2.0

Staff member
That part i honestly dont know. The only suggestion i would have at this point would be to replace the hal.dll thru the recovery console of XP Disc.

Mahmoud will have to give you more info on how to get the bootcfg part fixed and working. That is beyond my knowledge at this time.
How exactly does one replace a file through the Recovery Console? I'd be happy to do that if I knew how to do that... I tried initiating a Chkdsk while logged on to this account in Vista. No matter which parameters and switches I tried, it simply told me that the volume was locked.

Don't worry about not knowing what to tell me to do to combat this current barrier. You have helped me to make a heckuva lot of progress with the situation, and I thank you, sir!:happy:


Mak 2.0

Staff member
It is my pleasure. Well first you boot with the XP Disk. The first screen that comes up after the files load you will see Hit "R" to go to the Recovery Console. Do so. From there you will hit 1 or 2 depending on which is your XP install. Go into that and you will get a command prompt.

From here type Help to get the help commands. This will give you the list of commands to use to copy a file over. The you just select the hal.dll file from the CD ROM under the i386 folder. From there copy it to your install drives Windows System32 Folder.

So it would look like d:\i386_c:\windows\system32

That is assuming that your D Drive is the CD ROM and that the C Drive is the XP Install of course.

If you can get into Vista you can also try this right thru the Windows mode or in Ubuntu as well. If you can boot into any other OS except XP that is. See if that helps out at all.
Well, unfortunately there's a problem with that. The partition that XP is installed on has a Volume Label of

"Windows XP Professional [on Belinda]". But it does not have a Drive Letter and therefore can

only be viewed through Disk Management. All that's visible through Computer or Windows Explorer

is the partition with a Volume Label of "Local Hard Disc 0 [on Belinda]". That partition is

assigned the Drive Letter C:. The optical drive IS assigned the letter "D". With the Disk

Management snap-in, I can see three healthy partitions before "Local Hard Disc 0 [on Belinda]"

and two after (the last being the XP). I'm not sure why the Gutsy Gibbon or swap partitions

don't appear in Computer.

I dunno how to copy a file to a partition that has no Drive Letter. I'd probably try assigning

it a letter, but I'm sure that's play hell with Vista HnS... So, I don't think I'll do that

because at least the Vista is currently functional (crummy as it is).

Can you think of a way that I can un-screw myself with this?

And, thank you, again for your talented assistance!


Mak 2.0

Staff member
Have you tried thru the XP CD at all? Since you can not do it thru Vista that would be your best option to do it rhtu the recovery console.


Mostly Harmless
Staff member

Your easiest route to recovery would be to just perform a repair-install/in-place-upgrade of Windows XP. It'll fix everything (and get XP booting) without losing your data or files:
How to perform an in-place upgrade (reinstallation) of Windows XP

Once that's done, you can use EasyBCD to add an XP entry and reinstall the Vista bootloader.

When I try from Recovery Console from XP SP2 disc, bootcfg fails to scan the disk because of some

fs corruption. And, for some reason, the Chkdsk when run from Recovery Console is really

hamstrung and limited as compared to the typical Chkdsk. And I'm REALLY stumped (not to mention

pissed!) why 'bootcfg /rebuild' detects corruption immediately after running 'chkdsk /p /r'.:rage:

I copied a file named "hal.dl_" to 'F:\System32' after it told me it couldn't find a file named

"hal.dll". But I still get the same error when I attempt to boot XP. However, I didn't try

copying it to 'F:\Windows\System32'. Think I'll try that.


After reading the info at the link you provided, it appears to me that if the different directory

doesn't do the trick that I'm basically going to need to format & reinstall. Damned Internet Explorer!:rage:


Evidently, there's more to it than simply copying "hal.dll" into the 'X:\Windows\System32'

folder. Because I've tried two different versions of said file in 'f:\Windows\System32'. The

one originally there was dated 8/17/01 and the one currently there is dated 8/03/04. Attempting

to boot XP results in same error message.

Something I have noticed that just doesn't look right are the contents of a boot.ini file copied

while logged on to the Vista account: "[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin

;multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons

If I've understood what I've read at the EXTREMELY enlightening Rebuilding+Boot.ini page,

shouldn't the second entry, Partition(1), be equal to whatever the nomenclature is supposed to be

for Windows Vista? And yet, the Vista is booting just fine... Oh, I'm so confused!
Last edited:

Mak 2.0

Staff member
The boot.ini should reflect where XP is. Not Vista. Vista uses teh BCD for booting while only XP uses the boot.ini. While copying the hal.dll over might not have fully fixed this issue you will most likely have to edit the boot.ini to reflect the postition of XP according to the Disk Management screen.

From what i see it is showing 2 different XP's.

The first one is under the [operating system] with a location of Disk 1 partition 3. While the Fast Detect is showing Disk 1 partition 1. that could be where you problems are coming in.

Where do you have XP located? First drive first partition? Or do you ahev it on the first drive 3rd partition?


Mostly Harmless
Staff member
Windows Vista doesn't use boot.ini, so none of the entries in there should be pointing to the Vista entry.
Your problem is with the XP entry, and your path of "multi(0)disk(0)rdisk(0)partition(3)\WINDOWS" is *not* correct.

Download and run drive grabber from this link: The NeoSmart Forums - View Single Post - [Download] Vista Hide 'n Seek BETA
Run it in a command prompt (cmd) window in Vista, and post the output here.

Mak, the hal.dll issue is rarely (almost never) actually caused by a corrupt hal.dll file. This is a problem with an incorrectly-configured boot.ini file.

Mak 2.0

Staff member
I figured as much. But that is the easiest thing i suggest to other users. It is much more difficult on a double or Triple booted system to just say that. But at least we are making progress.
[Title: I'm Stuck]


I am having issues with the Bulletin Board software and am not able to obtain Drive Grabber from

the link you provided. Whenever I click on the EXE file at your link, I am taken to a login

screen. (Even if I'm already logged in). While logged-in as "linux_wannabe", I've gone to the 8th page of the "[Download] Vista Hide 'n Seek BETA" thread and clicked on the EXE file at your Post #108. Here is what that results in: "
vBulletin Message
You are not logged in or you do not have permission to access this page. This could be due to one of several reasons:

1. You are not logged in. Fill in the form at the bottom of this page and try again.
2. You may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
3. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

Log in
User Name:
Forgotten Your Password? Remember Me?
When I supply the proper login information there, I am left at a generic lobby type of location at the URL The NeoSmart Forums

And, of course, if I click on the link from your last post, I am prompted to login which leaves me at the same generic location.

I've had troubles with it all along. I don't know if you've noticed all the messages noted "Automatically merged double post." Those have been quick-replies submitted after an attempted reply told me I needed to login (when I <i>should have already been</i> logged in). I've composed everything in Notepad text files which I've usually pasted and sent as quick-replies after fighting with the damned BB software.

So I dunno where to go from here. I can't believe that the BB works just fine for everyone except me. But I also can't see what I can do differently.

Do you have any ideas for me, guys?



Mostly Harmless
Staff member
I can send you the file via email.... but no one else has this problem :S

Have you tried a different browser?
Kinda Sorta

It does appear that some part of Firefox has a difference of opinion with the BB software. I was able to D/L Drive Grabber using Netscape 9. However, even Netscape doesn't act quite like I'd expected, either. While logged in and reading the thread, I had to login again when I clicked on 'Post Reply'.

Browser idiosynchracies aside, I feel REALLY stupid because I am not able to run Drive Grabber in a command prompt. I go into the directory where it's saved and type "Drive Grabber.exe" (minus the quotes, of course) and I get "'Drive' is not recognized as an internal or external command, operable program or batch file."

I can execute the downloaded file from the browser, but don't read fast enough to keep up with the results. I got the same "'Drive' is not recognized..." message when I tried to run it off of a flash drive, too.

Can you please tell me how to run the silly thing so that I can give you the info you're needing?

Thanks for hangin' in there with me!



Knows where his towel is.
Staff member
Last edited:
Well, let's see...
Disk #0, Partition #0, Type: Unknown
Disk #0, Partition #1, Type: Installable File System
Disk #0, Partition #2, Type: Installable File System
Disk #0, Partition #3, Type: Extended Partition
Disk #2, Partition #0, Type: Installable File System
Disk #1, Partition #0, Type: Installable File System
Does that give ya the info you needed, Guru?

Many thanks, Terry! :happy: (BTW,What the heck is that in your avatar?! A turbo?)

Last edited:


Knows where his towel is.
Staff member