Not your typical XP boot issue

CJTE

New Member
#1
OK. Before I even dive into this, I beleive I have a handle on what you're thinking. Something like 'look at this newb, we have a bunch of posts regarding Windows XP not booting and instead of searching/reading them he had to go and post ANOTHER thread.'

I promise you, that is not the case.

I have 4 partitions on my HDD. 2 of them are primary partitions, and 2 of them are logical partitions within an extended partition.
The first partition is a 10GB recovery partition (I dont know why I left it there... But as of right now its looking like an excellent place to put GRUB, or SOMETHING).
The second partition is a 40GB partition with Windows XP installed on it.
Then there is the extended partition
Within the extended partition there are 2 logical partitions.
The first logical partition is 40GB, and contains Windows 7 build 7000 (Public Beta)
The 2nd logical partition is 40GB and contains Vista Ultimate SP1.

After putting this all together, BCD came out with 2 options. Vista Ultimate, and (recovered). Vista Ultimate boots to, Vista Ultimate. (recovered) boots to Windows 7. Windows XP is nowhere to be found.

I used EasyBCD to re-arrange the bootlist order, and renace (recovered) to Windows 7.
I then attempted to add XP. I was notified that NTLDR and NTDETECT.COM were not on my primary HDD. That was in fact correct, NTLDR and NTDETECT.COM (and boot.ini) mysteriously dissappeared from my XP partition, nonetheless, since those files belong on my new boot parition (which is the 1st logical partition within the extended partition now), I downloaded the NTLDR and NTDETECT.COM from here, and the attempted to add XP again. Everything was successful.

I rebooted the machine, chose Windows XP.
Invalid BOOT.INI file
Booting from c:\windows\
NTDETECT failed

OK. I screwed up. No boot.ini file. Simple fix.
Booted back into 7. Created the boot.ini file
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP Professional" /fastdetect
(note that I am using partition(2) because partition(1) is the recovery partition)

rebooted.
Same error.
Booted back into Windows 7, and noticed that EasyBCD reported the drive as
\Device\HarddiskVolume1
modified it to reflect C: (the boot drive).

rebooted.
Same error.

Booted back into Windows 7
deleted the Windows XP entry in BCD
re-added the Windows XP entry in BCD

rebooted.
now it says it cant find NTLDR

for fun I changed the drive to F:\ (where XP resides when im booted into Win7).
and it came back that boot.ini was missing, ntdetect failed, etc.

Ive tried repairing BCD with the Vista & 7 cd, no luck.
I cant use the XP cd because there is an issue with my AHCI driver in text-mode.

The following is what the Disk Manager shows in Windows 7. It may help y'all understand my partition map a little better.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi CJTE, welcome to NST.
Please read the sticky thread.
Note point 3. All of your boot files are in the "system" partition. This cannot be on a logical drive, it must be primary. It's not your W7, Vista or XP partitions, It's the 9.77Gb partition, though the screenshot you give is too condensed to show the flag. Fullscreen that display and you'll see it following "active".
Bearing that in mind, follow the rest of the links and notes in the thread to find what you need to know to get everything booting.

(remember that when MS says "boot", it doesn't mean what the rest of the world means)
 
Last edited:

CJTE

New Member
#3
this is more than 5 characters damnit

OK.
Can I not use GParted or Acronis Disk Management to change which partition is active?
 

Terry60

Knows where his towel is.
Staff member
#4
You can copy everything to the XP partition, (not one of the logicals), set it active, repair the BCD etc and have XP as "system", but why go to the bother ?
It'll be a load of effort, but there's no problem with all your systems booting from the present partition.
You just have to recognize that's where it is when you're setting up the boot entries.
Just making XP active won't help by itself.
The active flag tells the MBR where to find the boot files. If you point it to somewhere else, nothing will boot.
You'll need to assign a disk letter to the 1st partition, so that you can point to it when you're setting up your entries if you leave the boot files where they are.
 

CJTE

New Member
#5
My sincerest apologies. By the time I had typed that out, I already had the system going, how dumb of me. Apparently I wasn't paying attention. This isn't the first time Ive had this issue (in other capacities) and that aggravates the hell out of me.
 

Terry60

Knows where his towel is.
Staff member
#6
No problem. Glad it's all working now.