NTDetect Failed Loading Vista and XP

mjws

New Member
#1
Been fighting this too long now. Read everything I could find here but no dice.

System is simplified. Duo Core 6400, 2GB RAM, 2 Sata Drives, 1 Vista, 1 XP. Dual boots nicely from BIOS selecting boot drive.

Running latest beta. I have copied ntldr, ntdetect, boot.ini to Vista Drive (C:\) and left them on the xp drive. boot.ini has been auto configured, and I also manually tried all drive and partition options iterating through rdisk() and partition(). Been multi-booting win2k, xp, linux for years so comfortable editing.

I get "Invalid BOOT.INI file booting from c:\windows\ NTDETECT failed" no matter what I try. Deleted ntldr just to test I was on the right drive and it threw the missing ntldr error correctly. Tried downloadable version of files, clean, and existing with no change.

Need a new place to look. Tell me its late and I've missed something.

Attached are a few more system details.

Current Boot.ini:
[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP on F:\" /fastdetect

Thanks. Hopefully a fresh pair of eyes gets there.

Mike
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
Hi Mike, welcome to NST.
It sounds as though you've read the sticky, and followed all the correct steps, and that you have a C:\ntdetect.com on Vista.
If so see if any of this applies to you.
 

mjws

New Member
#3
Thanks for the last link Terry. I'll look there as well.

Has to be something to do with what my BIOS is showing the loader and boot.ini. It typically gets confused and ends up wrecking perfectly good mbr's and os's during install. I'm sure it got multiboot right once on its own, but I had used a small IDE drive to upgrade from and ended up redoing it. So this has been done in paranoid mode with only the drive it needs to see installed.

EasyBCD is great. Just wish I could figure out the anomaly on this box. At this point a fresh install where it gets multiboot right would have saved me dozens of hours not too mention a few hundred reboots.

Would any other diagnostics be useful? This reminds me of the golden days of linux in the early days (early 90's) when we had to work for things. Nuked Vista almost 3 years ago, and thought I'd give it another chance (works nice on my laptop). Talk about painful.

Thanks again,

Mike

Addendum:

SOLVED. Here's one for your db.

Reading through BIOS update changelogs for my ASUS p5NE-SLI. I noticed one corrected a reporting error of SCSI and RAID: "1. Modified "SCSI:" string to "RAID:" on the Boot menu for RAID device." No RAID on this box right now, but figured if they screwed it up in one place possibly others.

Reflashed motherboard BIOS. (I only flash as a last resort so my bios was OLD). Multiboot with the Vista loader now works as it should. BIOS update fixed vista boot, but hosed my ability to enter and tweak BIOS. Luckily a cmos clear put me back in business.

Had to flash (underclock) my video card (7900GT) as well so VISTA wouldn't corrupt my displays in dualview. What a headache. I haven't even started to mess with software incompatibilities yet. Not sure what I was thinking when I tried this. XP Pro treats me so well.

Hopefully this will help someone who has done everything right, but still can't multi-boot.

Regards,

Mike
 
Last edited: