NTLDR disregards boot.ini

#1
Hello,
I've recently installed Windows 7 in my machine, along with my other 2 (previously installed) Windows XP copies (each on different partitions). I installed and configured EasyBCD to boot the 3 of them, and everything's OK.

BUT... the only menu I can get to boot up the XP versions seems to be automatic, as if NTLDR just scans the partitions and generates a menu on-the-fly, with complete disregard to what my BOOT.INI file is configured to.
The menu just shows the items "Windows XP on E:\ - Windows XP on F:\", but my boot.ini file is not that. I even deleted the boot.ini file, and still works with the same menu.
I really need to start an XP copy with the /3gb option turned on, but can't find the way to do it if NTLDR doesn't even care for a boot.ini to exist.

Any ideas??? Many thanks.
 
#2
If you perform a "fixboot" from the repair console of an XP startup disk, it will likely find *both* XP installations (it finds my clone backup along with the installation I run) and let you choose one or the other for a startup ("fixboot") repair ... and that should get ntldr seeing the "boot.ini" on the drive of the one you select. At that point, you should then be able to go back to "C" or wheverever and edit that re-found file ...

... and then you will have to do the same for Win7 to get its boot working again. XP's "fixboot" will overwrite Win7's boot, but then Win7's repair console at least *should* again pick that up while repairing its own startup. However, Win7 *must* be on your first drive and your first drive *must* be your active boot drive in order for Win7 to repair its own startup.
 

Terry60

Knows where his towel is.
Staff member
#3
If you boot XP via Vista/7 bootmgr, it doesn't use boot.ini on the XP drive, it makes a copy on the "system" partition of all the XP boot files and uses those. This is standard MS design. (unless XP happens to be "system" itself)
If you're using EasyBCD to boot multiple XPs It uses a custom version of NTLDR because MS design does not support multiple XPs from a single boot menu.
Read this for details of how the latest version of EasyBCD does this.
 
#4
... MS design does not support multiple XPs from a single boot menu.
Read this for details ...
... within the contect of someone wanting only one menu, correct?

... what happens if you try to add a second Windows XP entry to the mix? Keep in mind that there's only one active partition on disk 0, and that one and only one boot.ini may exist at a time. NTLDR can't get its list of operating systems from anything other than the boot.ini on the active partition on disk 0 ...
... and that is exactly how it boots my Win2k that could just as easily be a second XP:

=======================
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
[boot loader]
timeout=8
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
c:\="Windows 98 lite"
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Pro" /NOEXECUTE=OPTIN /FASTDETECT
multi(0)disk(0)rdisk(0)partition(5)\WINDOWS="Windows XP Pro" /NOEXECUTE=OPTIN /FASTDETECT
c:\grldr="Arch & Puppy (Linux) & Return"
=======================
 

Terry60

Knows where his towel is.
Staff member
#5
If you're happy with two menus, the MS design works fine.
It's still using boot.in and NTLDR on the "system" partition though, not necessarily on XP
I was replying to the OP.
 
Last edited:
#6
I understand, and I certainly did not mean to confuse anything. I am one who definitely does not like Windows' dominance over my machine's startup and boot processes, yet I do not want to compromise my ability to repair them easily and quickly, if ever necessary.
 
#7
If you perform a "fixboot" from the repair console of an XP startup disk, it will likely find *both* XP installations (it finds my clone backup along with the installation I run) and let you choose one or the other for a startup ("fixboot") repair ... and that should get ntldr seeing the "boot.ini" on the drive of the one you select. At that point, you should then be able to go back to "C" or wheverever and edit that re-found file ...

... and then you will have to do the same for Win7 to get its boot working again. XP's "fixboot" will overwrite Win7's boot, but then Win7's repair console at least *should* again pick that up while repairing its own startup. However, Win7 *must* be on your first drive and your first drive *must* be your active boot drive in order for Win7 to repair its own startup.
Hi guys, thanx for trying to help me solve this out.
I did use Recovery in Windows XP, executed "fixboot". However, when I rebooted, I still have the Win7 popping out, hence, same problem (I didn't even ran Win7's fixboot, because nothing got broken).

Addendum:

If you're happy with two menus, the MS design works fine.
It's still using boot.in and NTLDR on the "system" partition though, not necessarily on XP
I was replying to the OP.
Hi Terry.
I would be happy with the two menus, but I can't get the second menu to read boot.ini.
Just in case, I copied all files (boot.ini, NTDETECT and NTDLR) to the root of ALL my harddrives. It doesn't care for any of them, just presents me with its own (automatic?) menu.

I've read all of the documentation for EasyBCD, and even though it uses its own NTLDR, it says it should read boot.ini.
It also says that, when using EASYLDR, it generates "ebdcd.00x" files for each configuration, but it doesn't create anything actually --except for the easyldr# files in NTS folder, which are not editable.

It's driving me crazy... I've tried lots of stuff, but can't even get myself to corrupt the boot!!!!!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#8
The boot.ini in use can be found (and edited) using EasyBCD > Tools > Edit legacy entries
"XP on E" and "XP on F" is the naming convention used in the EasyBCD created boot.ini, so it looks as if that's the one you are (and should be) using.
 

mqudsi

Mostly Harmless
Staff member
#9
Hi SaintYorke,

It sounds like you don't have the viewing of Hidden and System Files enabled. You'll need to change that first by opening My Computer -> Tools -> Options and checking those two (!) checboxes.