NTLDR missing on Vista

pwgb

New Member
#1
Hi - I hope you will bear with me whilst I try to get head around this....

I'm running Vista Home premium on a DELL inspiron 530 with my main HDD allocated to C: and a similar backup HDD allocated to E:.

Without warning today, Vista crashed, the screen went black and the message 'NTLDR is missing. Press CTRL + ALT + DEL to restart was displayed.

I tried several times to re-boot without success (including after checking hard drive data cables) and got the same error message; eventually (and purely by accident) I got back in by pressing F12, selecting Utility Partition and Vista somehow started normally.

The forums and notes on this site indicate that this message can occur on a dual-boot setup (Windows/XP) with the message relating to the XP side.

What's confusing me however is that this PC has had Vista from new and I have never attempted to set up dual-boot functionality with XP.

The Easy BCD program "View Settings" tells me that:

There is one entry in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS: Microsoft Windows Vista
Entry #1
Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

I would be most grateful if someone could steo me through the process of resolving this error in not-too technical language as I really don't know what I should be doing.....

Many thanks for your time.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi pw, welcome to NST.
You're correct. That is an XP (or more properly an NT) boot message, and it indicates that the MBR Initial Program Loader which should be the Vista version, seeking out Vista's Bootmgr, has been replaced with an NT version, looking for NTLDR.
This happens routinely if you install XP after Vista in a dual-boot, but shouldn't happen out of the blue.
I assume that what must have happened is that your Vista MBR has been damaged, and that the BIOS is unable to recognize the first HDD as bootable, so has moved on to the 2nd HDD, which contains an NT MBR at the front.
If you were provided with a bootable Vista Installation disk by Dell, you can boot from it and select "repair my computer" / "repair startup" 2 or 3 times (until the boot works again).
If you have no such disk, you can download a recovery disk from this site which will enable you to fix the problem in the same way, or you can follow the instructions here on how to use EasyBCD to fix it manually.
 

pwgb

New Member
#3
Now BOOTMGR is missing

Hi Terry - many thanks for your reply.
Here’s what I’ve done so far:
I’m able to get into Windows by booting from the Vista installation DVD.
I ran EasyBCD to firstly reinstall the Vista Bootloader (Type 1). This completed successfully, but on reboot, the following message was displayed:-
Boot from CD
BOOTMGR is missing
Press CTRL+ALT+DEL to restart

Using the Vista DVD, I got back into Windows and then ran EasyBCD to reset the Vista Bootloader Configuration(Type 2). Again this completed successfully, but I received the same message as above.

I then ran EasyBCD to re-configure all the files from scratch(Type 3). However this is did not complete, saying that boot files were already present and that EasyBCD will not be recreating the Windows Vista BCD files.

So, I ran Startup Repair from the Vista DVD, and on the first run it indicated that there was a problem, so I ‘repaired and restarted’, however the same message appeared upon startup.

I reran Startup Repair again; this time there were no problems, confirmed by the repair report. However the same message is still being displayed upon startup.

The message to boot from CD has only started happening since the problem first arose yesterday.

The boot menu (F12) is showing the following (which I assume is the order in which the PC tries to boot):

Hard Disk
- SATA-0
- SATA-5
- Bootable Add-in Cards
CD-ROM
Utility Partition.

So, in summary, there is something preventing bootup from the Hard Drive, but all the avenues I’ve tried so far indicate that all is well.

Any further suggestions are most welcome!

Many thanks





 

Terry60

Knows where his towel is.
Staff member
#4
Have you been editing your BIOS ?
The boot sequence is determined there, not in the PF12 menu.
hit "del" (or whatever the BIOS splash screen says) to enter the BIOS at power up, and check that your Vista HDD is before the other one. (The normal sequence is floppy/CD/HDD1/HDD2)
 

pwgb

New Member
#5
I'm not aware of ever having editted my BIOS (starting to lose my way a bit here...).

Pressed F2 to get into setup - brought up the Phoenix menu.

I selected Boot Device Configuration (hope this is the right area) which shows

Hard Disk Boot Priority: 1. SATA-5
2. SATA-0
3.Bootable AddIn Loads

First Boot Device: CD-ROM (no floppy on my PC)
Second Boot Device: Hard Disk
Third Boot Device: CD-ROM
Boot other Device: Enabled.

Does this look right?

Many thanks.
 

Terry60

Knows where his towel is.
Staff member
#6
Try swapping the HDD boot priority section, to put 0 before 5. (maybe you swapped channels when you were checking the data connections ?)
 

pwgb

New Member
#7
Yes, swapping SATA-5 and SATA-0 around seems to have done the trick - have managed to twice reboot successfully.

Many thanks for your help, Terry and your patience with me finding my way round this problem - much appreciated!