NTLDR+NTDETECT.COM Missing

#1
Hi everyone,I am a recent new member and I have a problem,I run a Vista 64bit system on my pc and have put a 50 GB partion on the Hard drive and after a lot of reading and head banging I installed EasyBCD and tried to add entry named Windows XP on drive X for dual booting,EasyBCD is indicating that NTLDR etc is not my C drive and therefore download them from NeoSmart.I did this but the download that I received is not compatible ie 32bit and not 64bit.Any help/advice please.
 

Terry60

Knows where his towel is.
Staff member
#2
Get EasyBCD 2.0 latest build.
delete the XP entry and add it again, letting it auto-configure.
2.0 does everything for you automatically
1.7 expects you to know the additional steps, and to do them yourself.
 
#3
Thanks Terry I will try your suggestion and get back to you later

Addendum:

Terry! Your'e the man, Did what you suggested and everything is fine, this reply is from my XP os on my new partition. Youv'e made an old novice very content.

Addendum:

Terry, I'm sorry to report that I have lost my boot manager,I must have clicked some wrong buttons to finalise configs. How do I get the boot manager back and indeed control of my pc. Help!!!!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
#5
Hi Terry. To explain I am contacting you via my laptop my desktop pc still wont boot having lost the boot manager.I made a vista 64bit recovery disc put in and after a while the pc is apparently still in the xp mode therefore the recovery didn,t work.I am in the process of looking for an xp recovery solution I APPRECIATE YOUR HELP AND MORE NEEDED!!!
 

Terry60

Knows where his towel is.
Staff member
#6
You need the Vista bootmgr to dual-boot. XP NTLDR won't do.
Boot the CD and run "startup repair" three times, till Vista boots again, then use EasyBCD to add the XP entry again.
 
#7
Hi everyone,

I've recovered NTLDR using EasyBCD 2.0, as explained above. Unfortunatelly I still cannot use my WinXP installation. It crashes every time, few seconds after I've choosen "Win XP" from the bootloader menu. The flash of BSOD is unfortunatelly too short for me, to notice the error's code. My second system is Win 7 and it works properly. Does anybody know the solution?
 

mqudsi

Mostly Harmless
Staff member
#8
After selecting Windows XP from the BCD menu, pound the F8 key. When you see a second menu, choose "Disable automatic restart"

That will let you read the BSOD so you can start looking for a solution.
 
#9
Thank you Computer Guru, you've helped me very much indeed. I've done what you said and easily found the solution. What I've needed was to change HDD mode to IDE (Compatible mode in Asus computers). At last both OS work as they are supposed to. What a relief!
 

mqudsi

Mostly Harmless
Staff member
#10
:smile: Glad to help!